[BETA] jcfplayer: mp3 Flash player

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

so close

Post by rtrev64 »

Here is the error, you can now click on post and the field will come up but you click on submit, then I get this error..


Fatal error: Call to undefined function: bbencode_first_pass_pda() in /home/rtrev64/public_html/test/includes/bbcode.php on line 255

^Andy^
Registered User
Posts: 28
Joined: Tue Oct 19, 2004 6:29 am

Post by ^Andy^ »

Check your bbcode.php file again.

At or around line 255 should be the new code segment..

Code: Select all

// JCFPluginMarker ============================== Start
// [MP3] and [/MP3]
$text = bbencode_first_pass_pda($text, $uid, '[mp3]', '[/mp3]', '', false, '');
// JCFPluginMarker =============================== End
And following that new code should be the existing code..

Code: Select all

// [code] and 
for posting code (HTML, PHP, C etc etc) in your posts.
$text = bbencode_first_pass_pda($text, $uid, '

Code: Select all

', '
', '', true, '');[/code]

If you have something different than paste it so we can see please.

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

Post by rtrev64 »


^Andy^
Registered User
Posts: 28
Joined: Tue Oct 19, 2004 6:29 am

Post by ^Andy^ »

I dont know if it's just the way that you have pasted that code but there appear to be a lot of misplaced comment lines. If I were you i would revert that file to a working version and reapply the edits.

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

Post by rtrev64 »

^Andy^ wrote: I dont know if it's just the way that you have pasted that code but there appear to be a lot of misplaced comment lines. If I were you i would revert that file to a working version and reapply the edits.



what do you mean revert that file to a working version?

^Andy^
Registered User
Posts: 28
Joined: Tue Oct 19, 2004 6:29 am

Post by ^Andy^ »

I mean replace the file with a backup or with the original file from a clean installation.

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

ok..

Post by rtrev64 »

Check it out now.. I was able to post but how do you make it work?

http://www.roberttrevino.com/test/

User avatar
Merri
Registered User
Posts: 255
Joined: Mon Nov 25, 2002 1:08 pm
Location: Riihimäki, Finland
Contact:

Post by Merri »

The player doesn't work well with lower quality clips, it plays them all too fast: http://maayas.net/viewtopic.php?p=6510#6510 for a sample.

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

upload

Post by rtrev64 »

Ok, I have the clip loaded in my server.. http://www.roberttrevino.com/test but as you can see when clicking the link, I cant see the player or even how to make it work..

jcfrog
Registered User
Posts: 9
Joined: Fri Mar 17, 2006 4:39 pm

Post by jcfrog »

Merri wrote: The player doesn't work well with lower quality clips, it plays them all too fast: http://maayas.net/viewtopic.php?p=6510#6510 for a sample.



you're right. i have seen the same problem with ather mp3 flash player.
i think it is due to the loadSound function.

anyway as you said in another forum, those mp3 are very rare.

so use use high quality! ;)

surprised to see some activity in this thread, i thought it was dead.
i should pass by more often! ;)

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

help

Post by rtrev64 »

http://www.roberttrevino.com/test

I have this installed and cant see the player to how to upload the mp3. I have it on my server but where is it in my test board? I see the brackets "MP3" any help would be great..

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

Thanks

Post by rtrev64 »

To the guest who went into my board and gave me a fresh code to replace the includes.bbcode.php but it did not work, I got this error message..

Fatal error: Call to undefined function: dss_rand() in /home/rtrev64/public_html/test/includes/bbcode.php on line 238

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

I did

Post by rtrev64 »

You sent me a code and I pasted it exactly like that and got the error message.. I changed nothing..

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

Post by rtrev64 »

re-installed old code..it now is as a link but music or mp3 will not play and it is on my server..

User avatar
rtrev64
Registered User
Posts: 286
Joined: Wed Nov 24, 2004 5:35 am
Contact:

code not good

Post by rtrev64 »

Well I tried but the code is just not good..The Jcf MP3 Flash Player..

Post Reply

Return to “[2.0.x] MODs in Development”