[MODDB]Better Captcha

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
uniterre
Registered User
Posts: 29
Joined: Mon May 29, 2006 1:28 pm
Contact:

Post by uniterre » Thu Jul 20, 2006 10:03 am

strange : it works with one forum installed on my server :
http://www.chantier-humanitaire.org

and it does not work with my other forum
http://forum.uniterre.com
It displays a broken picture !
(In this forum, the previous confirmation visual was working.)

Regards,
A[/url]

marvuk
Registered User
Posts: 15
Joined: Sat Jan 28, 2006 11:20 am
Contact:

Post by marvuk » Mon Jul 31, 2006 10:27 am

I'm having trouble with this now, the characters are often too small to read properly, and it's easy to confuse 5, S, 1, 7, I, 2, Z etc and as such I'm getting a lot of failed registrations from genuine members.

What changes can I make to remove those characters from the available set (I've tried changing the $chars array but it doesn't affect anything as it's not used anywhere else) and to boost the size?

marvuk
Registered User
Posts: 15
Joined: Sat Jan 28, 2006 11:20 am
Contact:

Post by marvuk » Thu Aug 03, 2006 9:09 am

Just to let you know, I've had to make modifications to this mod's usercp_captcha.php and phpBB's usercp_register.php to solve some of the problems I posted above.

akiyama
Registered User
Posts: 61
Joined: Sun Aug 15, 2004 12:16 pm

Post by akiyama » Fri Aug 11, 2006 11:42 am

Is there any way to make this work in previous versions of phpbb?

I have GD extension enabled and the default visual confirmation installed. When I install this mod the confirmation image is broken.

JonBeinart
Registered User
Posts: 2
Joined: Thu Aug 10, 2006 1:19 pm
Contact:

Post by JonBeinart » Fri Aug 11, 2006 11:09 pm

Hi. I like the sound of this mod. I run a high traffic Surreal Art forum http://surrealartforum.com and the bots are driving me crazy!!! How do I install this mod? I have never installed a mod before and am not very code savy. I'm an artist ;) not a Techy. Any help would be much appreciated.
Thankyou

sander815
Registered User
Posts: 23
Joined: Thu Oct 02, 2003 1:39 pm

Post by sander815 » Thu Aug 17, 2006 8:16 am

i just installed this, copied root to /include and edited profile.php
GD is installed afaik:
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

But i never see an image when i register. Do i need to enable it or so? I also don't see the standard captcha build into phpbb

s!mon
Registered User
Posts: 23
Joined: Fri Apr 16, 2004 12:47 am
Contact:

Post by s!mon » Thu Aug 17, 2006 9:31 am

How can I see wether this GD-Thing is activated on my server or not?

s!mon
Registered User
Posts: 23
Joined: Fri Apr 16, 2004 12:47 am
Contact:

Post by s!mon » Thu Aug 17, 2006 2:57 pm

And damn.. how do i install it? I have to edit profile.php.. but how?

sander815
Registered User
Posts: 23
Joined: Thu Oct 02, 2003 1:39 pm

Post by sander815 » Thu Aug 17, 2006 3:24 pm

with a txteditor f.i.?

ddeo
Registered User
Posts: 14
Joined: Sun Jan 09, 2005 3:34 am

Post by ddeo » Thu Aug 17, 2006 8:26 pm

paul999 wrote: No. This mod requires it, and without it cannot work.


Is there an easy way to turn this switch on ?:
--enable-gd-native-ttf

or do you have to re-complile php? ( I have root access but uncomfortable doing that)

this is what my phpinfo says:

gd
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

Any help is appreciated!

webexplorer
Registered User
Posts: 1
Joined: Sat Aug 19, 2006 9:14 am

alt to profile.php

Post by webexplorer » Sat Aug 19, 2006 9:19 am

hi,
my friends forum is being killed by the most hideous and offensive spam os i offered to help by trying to install this mod. i have been able to determine that the GD library is definitely installed on the server but i am unclear as the alteration i need to make to the profile.php file.
i would appreciate if something could explain the steps to me.
thanks in advance.

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25462
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Post by Paul » Sat Aug 26, 2006 8:02 pm

ddeo wrote:
paul999 wrote:No. This mod requires it, and without it cannot work.


Is there an easy way to turn this switch on ?:
--enable-gd-native-ttf

or do you have to re-complile php? ( I have root access but uncomfortable doing that)

this is what my phpinfo says:

gd
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

Any help is appreciated!
Please ask your host, thanks.
akiyama wrote: Is there any way to make this work in previous versions of phpbb?

I have GD extension enabled and the default visual confirmation installed. When I install this mod the confirmation image is broken.
Why you would like to use an old phpbb version? Thats really unsafe :?
webexplorer wrote: hi,
my friends forum is being killed by the most hideous and offensive spam os i offered to help by trying to install this mod. i have been able to determine that the GD library is definitely installed on the server but i am unclear as the alteration i need to make to the profile.php file.
i would appreciate if something could explain the steps to me.
thanks in advance.
s!mon wrote: And damn.. how do i install it? I have to edit profile.php.. but how?
JonBeinart wrote: Hi. I like the sound of this mod. I run a high traffic Surreal Art forum http://surrealartforum.com and the bots are driving me crazy!!! How do I install this mod? I have never installed a mod before and am not very code savy. I'm an artist ;) not a Techy. Any help would be much appreciated.
Thankyou
In the kb here at phpbb.com you can find a tut.
s!mon wrote: How can I see wether this GD-Thing is activated on my server or not?

Code: Select all

<?php phpinfo();
Put that in a php file, and give here a link.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Firestorm ZERO
Registered User
Posts: 25
Joined: Tue Jul 19, 2005 3:22 pm

Post by Firestorm ZERO » Sat Aug 26, 2006 9:05 pm

I am having trouble with this mod as well. Same as the guys above, the image isn't showing up. I have GD installed and enabled.

EDIT: I fixed the problem. I checked the captcha and it said "unable to read font". For some reason when Easymod copied the fonts over, it wasn't copied correctly. I just reuploaded the fonts in BINARY and works fine now.

ddeo
Registered User
Posts: 14
Joined: Sun Jan 09, 2005 3:34 am

Post by ddeo » Tue Sep 05, 2006 3:10 pm

Hi Paul, I have confirmed that I have --enable-gd-native-ttf.

I have installed better-captcha but no image appears with the reg page. No broken link either. It sounded like a similar problem to the last poster so I also re-uploaded the fonts in Bin mode but still didn't work.

Please let me know if anyone else has any ideas. Thansk!

meshenka
Registered User
Posts: 4
Joined: Wed Mar 23, 2005 9:18 am

Post by meshenka » Tue Sep 05, 2006 3:28 pm

same for me

gd is enable, as --enable-gd-native-ttf

but the image is not displayed. Firefow onmy says Image contains errors and cannot be displayed.

Locked

Return to “[2.0.x] MODs in Development”