[RC2] Anti Bot Question

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
anest
Registered User
Posts: 11
Joined: Sat Jan 22, 2005 8:47 pm

Post by anest » Sun Dec 10, 2006 6:08 pm

You have no Visual Confirmation Mod ?? WHY ??? :twisted:

User avatar
Dogs and things
Registered User
Posts: 2114
Joined: Fri Sep 01, 2006 9:04 am
Location: Spain
Contact:

Post by Dogs and things » Sun Dec 10, 2006 6:14 pm

anest wrote: You have no Visual Confirmation Mod ?? WHY ??? :twisted:

Whom you´re asking?
For phpBB2 support visit phpBB2refugees.

MagMo
Registered User
Posts: 20
Joined: Sat Apr 15, 2006 3:01 pm
Contact:

Post by MagMo » Sun Dec 10, 2006 10:07 pm

Hi,
ipetter wrote: Any idea what could be causing this?
You made a mistake. This is wrong:

Code: Select all

if ( !defined('IN_PHPBB') ) 
{ 
   die("Hacking attempt"); 
   exit; 

// Anti Bot Question Mod - Start 
... MOD Code ...
// Anti Bot Question Mod - End 

}
Try this:

Code: Select all

if ( !defined('IN_PHPBB') ) 
{ 
   die("Hacking attempt"); 
   exit; 
}

// Anti Bot Question Mod - Start 
... MOD Code ...
// Anti Bot Question Mod - End 
@ IPB_Refugee
I'm working on a new add-on version.

Greetings
MagMo

User avatar
Dogs and things
Registered User
Posts: 2114
Joined: Fri Sep 01, 2006 9:04 am
Location: Spain
Contact:

Post by Dogs and things » Mon Dec 11, 2006 12:09 am

Well Magmo,

I´m impressed.

Just out of curiosity, how long did it take you to spot this mistake?
For phpBB2 support visit phpBB2refugees.

covercopy
Registered User
Posts: 1
Joined: Mon Dec 11, 2006 4:02 pm

Anti-Bot Question

Post by covercopy » Mon Dec 11, 2006 6:40 pm

I'm hoping someone here can help me out with this as I'm a bit lost. On my registration page I, getting the following:

Warning: main(./language/lang_english/lang_abq.php): failed to open stream: Permission denied in /home/bbq/bbq/html/board/includes/usercp_register.php on line 44

Warning: main(): Failed opening './language/lang_english/lang_abq.php' for inclusion (include_path='.:/usr/share/pear') in /home/bbq/bbq/html/board/includes/usercp_register.php on line 44

Warning: main(./includes/functions_abq.php): failed to open stream: Permission denied in /home/bbq/bbq/html/board/includes/usercp_register.php on line 45

Warning: main(): Failed opening './includes/functions_abq.php' for inclusion (include_path='.:/usr/share/pear') in /home/bbq/bbq/html/board/includes/usercp_register.php on line 45

Warning: Cannot modify header information - headers already sent by (output started at /home/bbq/bbq/html/board/includes/usercp_register.php:44) in /home/bbq/bbq/html/board/includes/page_header.php on line 479

Warning: Cannot modify header information - headers already sent by (output started at /home/bbq/bbq/html/board/includes/usercp_register.php:44) in /home/bbq/bbq/html/board/includes/page_header.php on line 485

Warning: Cannot modify header information - headers already sent by (output started at /home/bbq/bbq/html/board/includes/usercp_register.php:44) in /home/bbq/bbq/html/board/includes/page_header.php on line 486


And on my "post reply" page, I get these errors;

Warning: main(./language/lang_english/lang_abq.php): failed to open stream: Permission denied in /home/bbq/bbq/html/board/posting.php on line 30

Warning: main(): Failed opening './language/lang_english/lang_abq.php' for inclusion (include_path='.:/usr/share/pear') in /home/bbq/bbq/html/board/posting.php on line 30

Warning: main(./includes/functions_abq.php): failed to open stream: Permission denied in /home/bbq/bbq/html/board/posting.php on line 31

Warning: main(): Failed opening './includes/functions_abq.php' for inclusion (include_path='.:/usr/share/pear') in /home/bbq/bbq/html/board/posting.php on line 31

Warning: Cannot modify header information - headers already sent by (output started at /home/bbq/bbq/html/board/posting.php:30) in /home/bbq/bbq/html/board/includes/functions.php on line 941

reedy
Registered User
Posts: 39
Joined: Wed Oct 08, 2003 8:28 pm

Post by reedy » Tue Dec 12, 2006 12:12 am

Hey everyone

I have just installed this MOD, all seemed to go well.

However, when I login to my admin panel, when I select the following menus:

configuration
"Automatic Questions" administration
font administration

I am presented with a completely blank page. Similarly on the registration page the anti-bot question is not appearing.

I have run through all the code changes twice and from what I can see I have installed everything correctly.

Any ideas?

finalfantasy7
Registered User
Posts: 26
Joined: Wed Aug 09, 2006 12:01 pm

Post by finalfantasy7 » Tue Dec 12, 2006 6:45 pm

Does this work with Easy MOD? I am terrible at messing with database and actually too nervous to do anything as drastic as this. Is there some similar mod that i can install with Easy MOD that will keep the spam out?

ipetter
Registered User
Posts: 3
Joined: Sat Dec 09, 2006 1:54 pm

Post by ipetter » Wed Dec 13, 2006 5:59 pm

MagMo: Thanks a million! It's working perfectly now :D

creak
Registered User
Posts: 10
Joined: Wed Oct 05, 2005 9:51 pm

Post by creak » Sat Dec 16, 2006 2:42 pm

Hi, i'd like to submit a patch for this mod, but I don't understand german enough to even pass the anti-spam question in the contact form :D

I've made it because the freetype library wasn't well detected on my servers (both under PHP5, Linux and Apache2).
So maybe you'd be interested in it MagMo, you'll find it here:
http://creak.foolstep.com/pub/patchs/pa ... ft.diff.gz

Hope it wasn't already patched :)

d'Artagnan
Registered User
Posts: 20
Joined: Sat Mar 08, 2003 9:01 pm
Location: Hell
Contact:

Post by d'Artagnan » Sat Dec 16, 2006 5:03 pm

I have installed the new version. ACP functions working great. But I still get no visual confirmation in the Registratrion area. (FYI: I did not implement the code into the posting.php, due to I dont allow guest to register anyways) But I doubt that has an effect on why its not coming up in the Registration area... (Also disabled the stock registration visual confirm). Any ideas?

Thanks!

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Post by IPB_Refugee » Mon Dec 18, 2006 5:29 pm

Hello MagMo,

are there any news regarding the add-on for the Easy Contact Form MOD? :)

BTW: There´s another Contact Form MOD in development which seems to be interesting.

Merry Christmas to you all!
Wolfgang

MagMo
Registered User
Posts: 20
Joined: Sat Apr 15, 2006 3:01 pm
Contact:

Post by MagMo » Thu Dec 21, 2006 8:09 am

IPB_Refugee wrote: are there any news regarding the add-on for the Easy Contact Form MOD? :)
Yes, you can download the new add-on version.

@ creak:
If the MOD uses the freetype library, it also needs the function imagettftext(). The original MOD version checks both:
- Is the freetype library installed?
- Does the function imagettftext() exists?
If one answer is no, the MOD says: No freetype installed.
Your patch does not check the second requirement. Therefore it could cause an error.

You can choose between automatic detection and manual configuration (freetype library AND imagettftext() available or not) in version 2.0.2 (release: between Christmas and New Year's Eve).

Greetings
MagMo

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Post by IPB_Refugee » Thu Dec 21, 2006 8:46 am

MagMo wrote:
IPB_Refugee wrote:are there any news regarding the add-on for the Easy Contact Form MOD? :)
Yes, you can download the new add-on version.


Thanks a lot, Master MagMo!

I really feel ashamed but I have already installed Marcus´ Contact Form MOD instead of the Easy Contact Form because Marcus´ MOD is clearly better.

Unfortunately his captcha doesn´t work for me (there is no picture shown), although phpinfo() tells me
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype


Therefore an add-on of your great mod for Marcus´ Contact Form would be highly appreciated. :oops:

But thank you very much for your good work!
Wolfgang

anest
Registered User
Posts: 11
Joined: Sat Jan 22, 2005 8:47 pm

Post by anest » Thu Dec 21, 2006 10:43 pm

Dogs and things wrote:
anest wrote:You have no Visual Confirmation Mod ?? WHY ??? :twisted:

Whom you´re asking?

Because you NEED IT for install this mod. You read README file from mod?

User avatar
Dogs and things
Registered User
Posts: 2114
Joined: Fri Sep 01, 2006 9:04 am
Location: Spain
Contact:

Post by Dogs and things » Thu Dec 21, 2006 10:47 pm

What´s your problem anest?

I have this MOD installed and it´s working very nicely thank you.

Maybe you want to borrow my glasses?
For phpBB2 support visit phpBB2refugees.

Post Reply

Return to “[2.0.x] MODs in Development”