[RC2] Anti Bot Question

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
triffendesign
Registered User
Posts: 7
Joined: Mon Jan 01, 2007 4:12 pm

It's in German

Post by triffendesign »

I tell you it is true. Though I wish it weren't :D

I go to my admin page and all the admin area is in German. The link to go there is in English though. Thank you.

Michael

User avatar
Dogs and things
Registered User
Posts: 2114
Joined: Fri Sep 01, 2006 9:04 am
Location: Spain
Contact:

Post by Dogs and things »

sbourdon wrote: Hello,

I've been using this MOD for a couple of months already, and I must say it works perfectly!

I'm still using version 1.0.3 and have noticed that the latest is 2.0.1. I wanted to see what had been updated in the MOD but unfortunately, updates are in German in the installation file... Could someone tell me what's new in this version?
## 2006-11-26 - Version 2.0.0
## - It is no longer possible to check if you have the latest version in the ACP.
## - Apart from Individual Questions you can now also use automatically generated questions.
## - The amount of register attempts is limited in case the register attempt fails. In the earlier version there was no limit to this.
## - Non-valid HTML corrected.
## - Added Picture Upload Funktion.
## - Font-Upload-Funktion added.
## - HTML is no longer available in the editing of Individual Questions. Instead BBCode can be used now.
## - Registers that select a non-installed language will recieve an error message (as this is a clear sign of Botregistring)
##
## 2006-12-09 - Version 2.0.1
## - As Multiplikationsign in the mathmetic question you can now choose between *, x and X.
## - Instead of the Textfield for the answer you can now also select to have the answer choosen from a list.
## - Check for GD- and Freetype-Library installation has been changed, because the old Method caused some Problms.
## - On PIcture Upload is being tested if the Funktion getimagesize() is available.
## - Adapted random selection of Individual Questions to MSSQL syntax because MSSQL requieres another syntax as for instance MySQL


Thanks; I guess this will benefit to all of us who don't speak German! ;)

Well, here you are. :wink:
For phpBB2 support visit phpBB2refugees.

User avatar
triffendesign
Registered User
Posts: 7
Joined: Mon Jan 01, 2007 4:12 pm

It's in German

Post by triffendesign »

Woo Hoo. I figured it out. For some reason I got the english and german language files mixed up. It is correct now. :D

Thank you for consideration.

Michael

sbourdon
Registered User
Posts: 174
Joined: Sat Nov 13, 2004 6:29 pm

Post by sbourdon »

Dogs and things wrote:
## 2006-11-26 - Version 2.0.0
## - It is no longer possible to check if you have the latest version in the ACP.
## - Apart from Individual Questions you can now also use automatically generated questions.
## - The amount of register attempts is limited in case the register attempt fails. In the earlier version there was no limit to this.
## - Non-valid HTML corrected.
## - Added Picture Upload Funktion.
## - Font-Upload-Funktion added.
## - HTML is no longer available in the editing of Individual Questions. Instead BBCode can be used now.
## - Registers that select a non-installed language will recieve an error message (as this is a clear sign of Botregistring)
##
## 2006-12-09 - Version 2.0.1
## - As Multiplikationsign in the mathmetic question you can now choose between *, x and X.
## - Instead of the Textfield for the answer you can now also select to have the answer choosen from a list.
## - Check for GD- and Freetype-Library installation has been changed, because the old Method caused some Problms.
## - On PIcture Upload is being tested if the Funktion getimagesize() is available.
## - Adapted random selection of Individual Questions to MSSQL syntax because MSSQL requieres another syntax as for instance MySQL


Well, here you are. :wink:


Thanks a lot!

Myaj
Registered User
Posts: 54
Joined: Sun Dec 11, 2005 2:41 am

Post by Myaj »

Its been asked a couple dozen times in this thread already but never gets an answer...

Does anyone have any idea which file would be the one triggering the problem of the question mod not showing up on the registration pages?

Everything looks good in my config, I've used this mod on two other boards (I didn't install, but used to what its supposed to look like), and I keep going over and over my edits and can't find any mistakes.. What should I be looking for?

This is frustrating the living heck out of me...

Gary787
Registered User
Posts: 12
Joined: Thu Jan 06, 2005 2:13 pm

Post by Gary787 »

Help!

i just installed the mod (v2.0.1) and tried it.
After filling out th registration form I get the following error:

Fatal error: Call to undefined function: abq_antwortpruefen() in /home/newbies/public_html/forum/includes/usercp_register.php on line 354

What did I do wrong??

EDIT: forget it - I installed another MOD and got that one to work..
Last edited by Gary787 on Tue Jan 02, 2007 7:58 pm, edited 2 times in total.

blurry3
Registered User
Posts: 1
Joined: Tue Jan 02, 2007 5:10 pm

Anti Bot Install problem: Blank screen

Post by blurry3 »

I tried installing and the mod without success. With so many edits, I tried using EasyMod. Tough install with lots of manual tweaks to get that working. Now Easymod is giving the following error:

Function Trace: open_files[5]->Write method not recognized.
MOD script line #695 :: FAQ :: Report

Tried a manual instal again and ended up getting a blank page when going to the "register" screen.

I'm using the charcoal template and had trouble finding the last edit to make in templates/charcoal/profile_add_body.tpl. Just added it near the end.

Did everything again with subSilver and the same results.

Any suggestions?

Thanks.

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Post by IPB_Refugee »

@Myaj:

Please check the modification especially of the following files:

includes/usercp_register.php
templates/xxx/profile_add_body.tpl

xxx = all templates you are using (e.g. subSilver/profile_add_body.tpl, subBlue/profile_add_body.tpl...)

And don´t forget to check if you have uploaded the files lang_abq.php and lang_abq_admin.php to all of your language folders (e.g. language/lang_english).

Good luck!
Wolfgang

safe_reader
Registered User
Posts: 105
Joined: Sun Apr 10, 2005 11:10 am

Post by safe_reader »

Well it worked for me the first time I installed it. But now with the new version of phpbb I neeed to re-update everything. I just hope I don't mess up anything on the way :( I MAY just get around to doing it all today.... just MAYBE! I'll get back and tell you all how it goes.

markus808
Registered User
Posts: 6
Joined: Fri Nov 11, 2005 9:42 pm

Post by markus808 »

Same here. Everything was working fine with the old version, until I updated phpBB from 2.0.21 to version 2.0.22. After that, the Mod no longer worked. I'd appreciate if anyone could share their experiences on how they solved this.
Version 2 of the Mod doesn't seem to be a solution for me, as I don't think it can be installed with easyMod?

User avatar
jumborex
Registered User
Posts: 143
Joined: Fri Mar 28, 2003 3:18 pm
Name: Franco Giambalvo
Contact:

Post by jumborex »

I was really impressed by this MOD, and I was thinking to use it inside my Board. One only problem: if they release (at last) phpBB3, have you plans to upgrade?
Thanks.
I have not failed. I've just found 10,000 ways that won't work.
(Thomas Alva Edison)

RikR
Registered User
Posts: 9
Joined: Wed Nov 10, 2004 2:21 am
Location: Wake Forest, NC USA
Contact:

Post by RikR »

This mod seems to have stopped for me what was a terrible daily exercise of dealing with bot registrations.

I had no problem adding the mod to my phpBB after the latest phpBB upgrade. The instructions were very clear.
Rik Rasmussen
Two Way Radio Directory
http://twowayradiodirectory.com

markus808
Registered User
Posts: 6
Joined: Fri Nov 11, 2005 9:42 pm

Post by markus808 »

Does version 1_0_3 of this mod work with phpBB version 2.0.22, yes or no?

Myaj
Registered User
Posts: 54
Joined: Sun Dec 11, 2005 2:41 am

Post by Myaj »

IPB, thank you. I have gone over every file many times, redone the entire mod 3 times all with the same results.

The only template I run is SubSilver, though I do have a new "style" that is subsilver but with color changes, as far as I can tell this is not a new template at all and shouldn't affect anything? The mod doesn't work even if I switch back to SubSilver for my style though.

I will double check the language files though, thank you.

User avatar
IPB_Refugee
Registered User
Posts: 1290
Joined: Fri Jul 07, 2006 2:25 pm
Location: Austria
Name: Wolfgang Weber

Post by IPB_Refugee »

@markus808:

Yes, it does.

@Myaj:

If the new style has an own folder in your templates folder (e.g. templates/subSilverNewColors) you also have to apply the code changes to templates/subSilverNewColors/profile_add_body.tpl and so on.

Good luck!
Wolfgang

Post Reply

Return to “[2.0.x] MODs in Development”