Page 31 of 45

Posted: Fri Mar 02, 2007 12:06 pm
by Dogs and things
Hello Charles,

If the file exists it´s in the wrong place. It should be in templates/admin/ and not in the templates folder. And make sure to install the ABQ in all of your templates, not just in subSilver. :wink:

Posted: Sun Mar 04, 2007 1:20 am
by safe_reader
Hey guys, I'm back again. Noticed phpbb went through a new version release, 2.0.22. I decided to ugprade to this. Then noticed that the spam bots were getting through again. I figured that may happen.

I then spent my 20 minutes last night re-editing the files as the mod indicates, and doing everything exactly the same as I did for the earlier forum.

I thought I had it all working... when I test register I get an image and a question but it seems there is still a problem. Spam bots are still getting through! I did a test and it seems even if I put in the wrong answere, the forum still tells me I have successfuly registered!

I am curious what file/template I may have made a mistake in here? Or is this a problem more due to 2.0.22?

Posted: Sun Mar 04, 2007 5:12 pm
by krabar
I get sth like this almost everywhere:

Code: Select all

Warning: ini_get, ini_alter, ini_restore, ini_set, getrusage, mysql_list_dbs, get_current_user, set_time_limit, getmyuid, getmypid, dl, leak, listen, chown, chmod, chgrp, realpath, tmpfile, link, mb_send_mail() has been disabled for security reasons in /data/members/free/tripod/uk/n/e/o/neonnnnn/htdocs/phpBB2/includes/functions_abq.php on line 1516
What's the problem?

Posted: Sun Mar 04, 2007 9:57 pm
by safe_reader
Hmm, I decided to run the db_update.php file again. Some new things were inserted, though I got a few errors for some duplications.

However the forum still seems to accept new registers no matter what they answere in the questions. Still puzzled.

Posted: Mon Mar 05, 2007 2:21 am
by safe_reader
Alright, I finally fixed it! Did some backtracking and found a missing insertion in the file includes/usercp_register

So that being said, I got 1.0.3 of this mod to work fine with the latest 2.0.22 of PhpBB.

Posted: Mon Mar 05, 2007 10:42 pm
by WoSLee
Hi, When I answer Anti-Bot questions it always says that it's a wrong answer! Iv checked everyfile over and over again and cannot find the problem. Iv also went through every post on this thread, but still no luck.

Anyone got any ideas???

Posted: Tue Mar 06, 2007 9:56 pm
by abssorb
Dogs and things wrote:
WoSLee wrote:Hi, im getting the following Error, can anyone help??

phpBB : Critical Error

Could not query anti bot question mod config information

DEBUG MODE

SQL Error : 1146 Table 'phpBB2.ANTI_BOT_QUEST_CONFIG_TABLE' doesn't exist

SELECT * FROM ANTI_BOT_QUEST_CONFIG_TABLE

Line : 32
File : admin_anti_bot_question_index.php



Thanks.

You must run the sql queries that are in the install script because this messages means you didn´t. :wink:


I'm also got this error. It was because constants.php was not uploaded.

V2.0.22 :)

Posted: Tue Mar 06, 2007 10:39 pm
by Dogs and things
Got confused. :?

Posted: Tue Mar 06, 2007 10:54 pm
by abssorb
Sorry - I found an answer as I was waiting and edited my post to remove my question.

but - I have a new problem. I can see the admin screens and everything appears to be working properly.

Except - the registration page just has the old captcha!


A side-problem also is now I can;t test because I keep getting:
You have exceeded the number of registration attempts for this session. Please try again later.

Posted: Tue Mar 06, 2007 10:57 pm
by Dogs and things
You must activate ABQ, in it´s configuration Panel, and disable the Visual Confirmation.

Just login/logout and you can try the register page again, four times.

Posted: Tue Mar 06, 2007 11:05 pm
by abssorb
Thanks for the reply. :) I checked. Yes - I have it activated:


ABQ MOD / Configuration:

Enable Anti Bot Questions for registrations = YES
Enable Anti Bot Question for guests = YES.

Also with captcha on / off it is the same. Nothing in user registration page.

Any ideas?

EDIT*****

Fixed it. There was a problem uploading usercp_register.php
Probably user error with FTP. :oops:

Posted: Wed Mar 07, 2007 9:32 am
by WoSLee
Dogs and things wrote: You must activate ABQ, in it´s configuration Panel, and disable the Visual Confirmation.

Just login/logout and you can try the register page again, four times.


I thought id give that a try too, but still incorrect answers every time.

iv included my Posting.php and Usercp_register.php files if someone could have a look.

Thanks again.

Posting.php

usercp_register.php

Posted: Thu Mar 08, 2007 9:01 am
by Morganhahaha
Granted that its 4:00 AM, and I may have made a mistake, I thought I did everything right, yet I seem to be getting this error when I click Anti Bot Question MOD in the Admin Control Panel

Template->make_filename(): Error - file admin/abq_index_body.tpl does not exist

Can anyone help me out here? All I understand is copy here, paste there :P

Posted: Thu Mar 08, 2007 10:44 am
by Dogs and things
Morganhahaha,

It looks to me that

Code: Select all

admin/abq_index_body.tpl
is not in it´s place.

Check it. It should be in templates/yourtemplatehere/admin/.

Maybe you are using more then one style, you should apply the istall instruccions related to templates to all the styles you have installed on your board.

Posted: Thu Mar 08, 2007 7:28 pm
by Morganhahaha
Ah yeah thats why :) I have two templates, subsilver and acidtech, I actually edited all of the files for subsilver and acid tech, I just forgot to copy the files to acidtech. It seems to be working except when I try to register, I don't see the question thing :?

I know I just enabled it, I don't see why it doesn't want to work

Fatal error: Call to undefined function abq_antwortpruefen() in /home/.bellatrix/administrationator/wotamod.net/phpBB2/includes/usercp_register.php on line 342

antwortpruefen?

antwortpruefen was mentioned in two places in posting.php, and I can verify that I did add the code, so is it asking for another file I must have forgot to add or something?