Page 44 of 45

Re: [RC2] Anti Bot Question

Posted: Sun Jan 27, 2008 10:22 am
by DarkArchon
I'm sorry if answers to these questions are given, I searched as best I could, but I'm not reading 43 pages of posts.

1) Has this mod been updated to work with 2.0.22?
2) Can someone post an image of what this mod shows in the ACP (a screen shot of the section of the ACP where this mod shows up... I hope that makes since)

Re: [RC2] Anti Bot Question

Posted: Fri Feb 01, 2008 6:29 am
by stryker23
Hello,

Very interested in using your mod. I am getting the following when attempting to install using Easymod:

Critical Error

FIND FAILED: In file [includes/usercp_register.php] could not find:

global $userdata, $template, $lang, $phpbb_root_path, $phpEx;

MOD script line #1183 :: FAQ :: Report

Please assist if possible, thank you.

Re: [RC2] Anti Bot Question

Posted: Fri Feb 01, 2008 2:34 pm
by Cissell
Cissell wrote:Just installed this mod and it appears to be working good. Now when i go to the User Admin- Management page there is nothing below the Avatar section when i scroll down. What page did I modify that would cause this?

view it here http://nagca.com/jpg/opps.jpg
Is this mod no longer supported???? Could use some help please!!!!!! :cry:

Re: [RC2] Anti Bot Question

Posted: Fri Feb 01, 2008 8:54 pm
by dellsystem
stryker23 wrote:Hello,

Very interested in using your mod. I am getting the following when attempting to install using Easymod:

Critical Error

FIND FAILED: In file [includes/usercp_register.php] could not find:

global $userdata, $template, $lang, $phpbb_root_path, $phpEx;

MOD script line #1183 :: FAQ :: Report

Please assist if possible, thank you.
Just do the edits manually if easymod doesn't work.
Cissell wrote:
Cissell wrote:Just installed this mod and it appears to be working good. Now when i go to the User Admin- Management page there is nothing below the Avatar section when i scroll down. What page did I modify that would cause this?

view it here http://nagca.com/jpg/opps.jpg
Is this mod no longer supported???? Could use some help please!!!!!! :cry:
Check templates/yours/admin/board_config_body.tpl

Re: [RC2] Anti Bot Question

Posted: Sat Feb 02, 2008 2:19 am
by Cissell
Cissell wrote:
Cissell wrote:Just installed this mod and it appears to be working good. Now when i go to the User Admin- Management page there is nothing below the Avatar section when i scroll down. What page did I modify that would cause this?

view it here http://nagca.com/jpg/opps.jpg
Is this mod no longer supported???? Could use some help please!!!!!! :cry:
Check templates/yours/admin/board_config_body.tpl[/quote]

What am I suppose to look for in config_body.tpl? Not sure what to fix???? This file has not been modified since 9/02/2006.

Re: [RC2] Anti Bot Question

Posted: Sat Feb 02, 2008 6:05 am
by stryker23
Hello again.

Thanks for the advice to do it manually, it took some time but worked in the end. The problem now is that when I attempt to register, I receive this error:

Parse error: syntax error, unexpected ';' in /includes/usercp_register.php on line 70


Lines 42-100

Code: Select all

// Anti Bot Question Mod - Start
include($phpbb_root_path . 'includes/functions_abq.' . $phpEx);
// Anti Bot Question Mod - End


$unhtml_specialchars_match = array('#>#', '#<#', '#"#', '#&#');
$unhtml_specialchars_replace = array('>', '<', '"', '&');

// ---------------------------------------
// Load agreement template since user has not yet
// agreed to registration conditions/coppa
//
function show_coppa()
{
	global $userdata, $template, $lang, $phpbb_root_path, $phpEx, $abq_config, $abq_agreedPart2;

	$template->set_filenames(array(
		'body' => 'agreement.tpl')
	);

	$template->assign_vars(array(
		'REGISTRATION' => $lang['Registration'],
		'AGREEMENT' => $lang['Reg_agreement'],
		"AGREE_OVER_13" => $lang['Agree_over_13'],
		"AGREE_UNDER_13" => $lang['Agree_under_13'],
		'DO_NOT_AGREE' => $lang['Agree_not'],

	);

	$template->pparse('body');

}
//
// ---------------------------------------

$error = FALSE;
$error_msg = '';
$page_title = ( $mode == 'editprofile' ) ? $lang['Edit_profile'] : $lang['Register'];

// Anti Bot Question Mod - Start
$abq_agreedPart2 = '';

if (($abq_config['abq_register']) && ($mode == 'register'))
{
	$sql = 'DELETE FROM ' . ANTI_BOT_QUEST_REGCONFIRM_TABLE . ' 
		WHERE start_time < ' . (time() - (int) $board_config['session_length']) . ' 
		AND session_id <> \'' . $userdata['session_id'] . '\'';
	if (!$db->sql_query($sql))
	{
		message_die(GENERAL_ERROR, 'Could not delete stale anti bot question data', '', __LINE__, __FILE__, $sql);
	}
	$db->sql_freeresult($result);

	$sql = 'SELECT confirm_id 
		FROM ' . ANTI_BOT_QUEST_REGCONFIRM_TABLE . ' 
		WHERE session_id = \'' . $userdata['session_id'] . '\'';
	if (!($result = $db->sql_query($sql)))
	{
Any ideas?

If it helps, the only manual step I was not able to complete, due to the inability to find the original lines was:

Code: Select all

#-----[ FIND ]------------------------------------------------ 
# 
		"U_AGREE_OVER13" => append_sid("profile.$phpEx?mode=register&agreed=true"),
		"U_AGREE_UNDER13" => append_sid("profile.$phpEx?mode=register&agreed=true&coppa=true"))

# 
#-----[ REPLACE WITH ]----------------------------------------
# 
		// Anti Bot Question Mod - Start
		"U_AGREE_OVER13" => append_sid("profile.$phpEx?mode=register&" . (($abq_config['abq_register']) ? $abq_config['agreed_variable_name'] : "agreed") . "=" . (($abq_config['abq_register']) ? $abq_config['agreed_variable_value'] . $abq_agreedPart2 : "true")),
		"U_AGREE_UNDER13" => append_sid("profile.$phpEx?mode=register&" . (($abq_config['abq_register']) ? $abq_config['agreed_variable_name'] : "agreed") . "=" . (($abq_config['abq_register']) ? $abq_config['agreed_variable_value'] . $abq_agreedPart2 : "true") . "&coppa=true"))
		// Anti Bot Question Mod - End

# 
Thanks in advance! Looking forward to the mod, the config page worked just fine.

Re: [RC2] Anti Bot Question

Posted: Sun Feb 03, 2008 1:29 pm
by Caboosey
I found this MOD to be very effective and better than any other anti-spam system for phpBB. You'll like this. You have a lot of customization of questions and such. Some of the images generated are a bit confusing to read and hard to figure out. I had no problems installing it on my phpBB 2.0.22 and been running it since October 1, 2007.

Re: [RC2] Anti Bot Question

Posted: Wed Feb 06, 2008 2:13 pm
by Cissell
Cissell wrote:
Cissell wrote:
Cissell wrote:Just installed this mod and it appears to be working good. Now when i go to the User Admin- Management page there is nothing below the Avatar section when i scroll down. What page did I modify that would cause this?

view it here http://nagca.com/jpg/opps.jpg
Is this mod no longer supported???? Could use some help please!!!!!! :cry:
Check templates/yours/admin/board_config_body.tpl
What am I suppose to look for in config_body.tpl? Not sure what to fix???? This file has not been modified since 9/02/2006.
I still need some help!!!!

Re: [RC2] Anti Bot Question

Posted: Wed Feb 06, 2008 3:04 pm
by RMcGirr83
Just installed this on my 2.0.22 test forum with no problems via EasyMod. Well, not no...sql queries setup didn't take, other than that worked/works fine.

Re: [RC2] Anti Bot Question

Posted: Fri Feb 08, 2008 3:58 am
by stryker23
Bump, anyone have a cure for my problem? I hope I havent stumped the whole forum...

I could use just the first 100 lines of the register sql file for reference.

Re: [RC2] Anti Bot Question

Posted: Fri Feb 08, 2008 11:24 am
by RMcGirr83
stryker23 wrote:Bump, anyone have a cure for my problem? I hope I havent stumped the whole forum...

I could use just the first 100 lines of the register sql file for reference.

Code: Select all

   $template->assign_vars(array(
      'REGISTRATION' => $lang['Registration'],
      'AGREEMENT' => $lang['Reg_agreement'],
      "AGREE_OVER_13" => $lang['Agree_over_13'],
      "AGREE_UNDER_13" => $lang['Agree_under_13'],
      'DO_NOT_AGREE' => $lang['Agree_not'],

   );
should be

Code: Select all

   $template->assign_vars(array(
      'REGISTRATION' => $lang['Registration'],
      'AGREEMENT' => $lang['Reg_agreement'],
      "AGREE_OVER_13" => $lang['Agree_over_13'],
      "AGREE_UNDER_13" => $lang['Agree_under_13'],
      'DO_NOT_AGREE' => $lang['Agree_not'])
   );

Re: [RC2] Anti Bot Question

Posted: Sat Feb 16, 2008 5:31 pm
by Trinny
I'm confident I can get this installed on my own, but I've run into a problem that I'm pretty sure is on my hosting partner's end. When copying up the file admin_anti_bot_question_index.php, it tells me the filename is too long. I've tried shortening it to get it uploaded, then renaming the file on the server with the same results. Any ideas how to work around this? Can the name be shortened? If so, what files must I change the name in? Is there a way to force long names on the server? TIA for your help.

James

Re: [RC2] Anti Bot Question

Posted: Sun Mar 02, 2008 3:19 pm
by ges8529
I had this working wonderfully with 2.0.22, but now that I've upgraded to 2.0.23 and reinstalled the MOD, it doesn't seem to work. I see all of the configuration options within the Admin CP, but nothing shows up in the footer of my forums and when I try to register, I don't see the questions or CAPTCHA! Visual confirmation is ON, but this is the only variable I've changed.

Is there a file in the upgrade from 2.0.22 to 2.0.23 that needs to be manually tweaked in order to get this MOD working again? The MOD was working wonderfully, but I'm now getting hit with bogus registrations again, and I'm tired of it.

Thanks in advance.

Re: [RC2] Anti Bot Question

Posted: Thu Apr 17, 2008 5:45 pm
by rlasker3
Caboosey wrote:I found this MOD to be very effective and better than any other anti-spam system for phpBB. You'll like this. You have a lot of customization of questions and such. Some of the images generated are a bit confusing to read and hard to figure out. I had no problems installing it on my phpBB 2.0.22 and been running it since October 1, 2007.
I was also quite happy with this MOD until about 3 days ago when I got flooded with thousands of Porn posts. Not sure how they are getting past the registration MOD or what I can do to prevent it from here on out.

Re: [RC2] Anti Bot Question

Posted: Thu Apr 17, 2008 6:09 pm
by ges8529
I've added the RAC mod, turned visual confirmation on, and disabled registrations by open proxy and I have not had any problems. Yay! :D