[RC] QWiki (Combining the Wiki and the Bulletin Board)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
cmsinai
Registered User
Posts: 3
Joined: Sat Jun 17, 2006 5:22 am

Post by cmsinai » Sun Jun 18, 2006 6:21 pm

That apparently worked!! Thanks!

Sorry about the [ code ] bit, I'm still very new to all of this. Last month I had no idea what a bulletin board was, how to host one, or even how to modify a database.

I'll have to give it some more time - my site will officially launch tomorrow, but until I kick the tires a bit more, I'm not sure that the "wiki recent changes" link is working correctly.

Thanks again for your help.

User avatar
Quezza
Registered User
Posts: 212
Joined: Sat Oct 23, 2004 7:17 pm
Location: Hertfordshire, UK
Contact:

Post by Quezza » Sun Jun 18, 2006 7:09 pm

Ok, Great that worked :) If you ever need any phpBB help, I'm happy to help where I can. If you do find a problem with the Recent Changes, please say so and I'll take a look.

Nilmalith
Registered User
Posts: 14
Joined: Sat Nov 12, 2005 6:49 pm

Post by Nilmalith » Tue Jun 20, 2006 12:17 pm

Hello :)

I've installed this MOD on my forum and it seems to work but ...
When I want to watch the revisions, I can see the old version but there's no crossed red words and no underscored green words.

Why ?

Thanks, and sorry for the mistakes, I'm french :oops:

User avatar
Quezza
Registered User
Posts: 212
Joined: Sat Oct 23, 2004 7:17 pm
Location: Hertfordshire, UK
Contact:

Post by Quezza » Tue Jun 20, 2006 1:02 pm

What is the URL of your forum? Can I test it there?

User avatar
Quezza
Registered User
Posts: 212
Joined: Sat Oct 23, 2004 7:17 pm
Location: Hertfordshire, UK
Contact:

Post by Quezza » Tue Jun 20, 2006 5:19 pm

OK, For some reason it is not showing the revisions that you can select between. The reason no changes are shown is because you are comparing it with itself. I shall have a look for a fix for you and post here when I find one.

Nilmalith
Registered User
Posts: 14
Joined: Sat Nov 12, 2005 6:49 pm

Post by Nilmalith » Tue Jun 20, 2006 6:23 pm

Thank you :D

Very very nice MOD, I could try to translate in French the lang_wiki for you, I've done it for my forums but I've to use it better to translate in (to ?) the right words ;)

User avatar
Quezza
Registered User
Posts: 212
Joined: Sat Oct 23, 2004 7:17 pm
Location: Hertfordshire, UK
Contact:

Post by Quezza » Thu Jun 22, 2006 7:49 am

Hi, A translation would be great. I shall be spending more time on this mod in a week or so's time, so a translation into French would be excelent!

Luke

Ionical
Registered User
Posts: 14
Joined: Wed May 24, 2006 3:32 pm

Post by Ionical » Fri Jun 30, 2006 4:57 pm

When I try to edit a post, this occurs:

Code: Select all

Error by getting post revision data.

DEBUG MODE

SQL Error : 1054 Unknown column 'p.poster_id' in 'on clause'

SELECT p.*, pt.*, u.username FROM phpbb_posts p, phpbb_posts_text pt LEFT JOIN phpbb_users u ON u.user_id = p.poster_id WHERE p.post_id = '4755' AND pt.post_id = p.post_id

Line : 59
File : functions_wiki.php
Exactly how is this fixed? Thanks.

vossen
Registered User
Posts: 123
Joined: Thu Aug 21, 2003 9:11 am

Post by vossen » Thu Aug 03, 2006 11:18 am

i'm watching this mod some time and see that there is nothing new!?
is it working fine?
seeing the test forum, i do not realy understand the point, of doing a topic in wiki and not.
can't i di just one forum category where all topics will be in wiki format?
and the others stay as there are.
best regards
stefan

sonath
Registered User
Posts: 12
Joined: Tue Aug 08, 2006 2:16 am

Post by sonath » Tue Aug 08, 2006 2:22 am

I had to apply the following patch in order to fix the search.php error (which seemed different than the error cmsinai was getting):

Code: Select all

--- search_old.php      2006-08-07 19:15:03.000000000 -0700
+++ search.php  2006-08-07 16:46:29.000000000 -0700
@@ -324,6 +324,7 @@
                                                {
                                                        $current_match_type = 'and';
                                                }
+                                               $where_sql = '';
                                                 // BEGIN QWiki MOD By LoonyLuke (www.Quezza.com AND www.ForumImgs.com)
                                                 if ($return_wiki)
                                                 {
@@ -336,7 +337,7 @@
                                                {
                                                        $match_word = str_replace('*', '%', $split_search[$i]);
                                                        $sql = "SELECT m.post_id
-                                                               FROM " . SEARCH_WORD_TABLE . " w, " . SEARCH_MATCH_TABLE . " m . $from_sql . "
+                                                               FROM " . SEARCH_WORD_TABLE . " w, " . SEARCH_MATCH_TABLE . " m " . $from_sql . "
                                                                WHERE w.word_text LIKE '$match_word'
                                                                        AND m.word_id = w.word_id
                                                                        AND w.word_common <> 1
(sorry, I'm a unix guy, I prefer diff -urN to the PHPBB format!)

-Sonath

Narnian
Registered User
Posts: 34
Joined: Sat May 20, 2006 12:02 am
Contact:

Post by Narnian » Thu Aug 10, 2006 4:26 am

I installed it, and i have 2 errors.

1) clicking in wiki in the header, appears a white page

2) editing a wiki-post give me the same error that is in the Ionical post

My website is www.foros.narniaespanol.com.ar. but the mod is no longer installed cause the error 2) also appears in normal editing

-------------------------------------------------------------------

Ionical, which mods have you installed?

Narnian
Registered User
Posts: 34
Joined: Sat May 20, 2006 12:02 am
Contact:

Error located, but no solution

Post by Narnian » Fri Aug 18, 2006 8:55 pm

I think, this query was wrote for MySQL 4, and it's running in a MySQL 5, but I always use MySQL 4 and don't know how correct it.
SQL Error : 1054 La columna 'p.poster_id' en on clause es desconocida

SELECT * FROM phpbb_posts p, phpbb_posts_text pt LEFT JOIN phpbb_users u ON (u.user_id = p.poster_id) WHERE p.post_id = '31486' AND pt.post_id = p.post_id

Line : 59
File : functions_wiki.php

GoGades
Registered User
Posts: 22
Joined: Tue Mar 15, 2005 12:41 am

Post by GoGades » Sun Aug 20, 2006 8:59 pm

I'm interested in trying this mod out, but the hosting site seems to be expired.... Any alternate source ? Or if someone could email me a copy at gogades@gmail.com I would be very thankful. :P

Narnian
Registered User
Posts: 34
Joined: Sat May 20, 2006 12:02 am
Contact:

Post by Narnian » Tue Aug 22, 2006 1:18 am

Ok, it seems to be very abandoned.
So I suggest: Make support and correct bugs by ourselves.

Here is my first correction.
There are 4 bugs corrected (incompatibility with mysql5 included) detailed in the file "Narnian modifications.txt"

Download it from
http://www.narniaespanol.com.ar/persona ... V1-1-1.zip

deepriver
Registered User
Posts: 3
Joined: Fri Aug 25, 2006 10:19 pm

changing Background color

Post by deepriver » Sat Aug 26, 2006 12:22 am

Hi everyone,

This mod seems really great, so I installed it - and it works fine! But I'd like to make my Board users aware of Wiki Posts, so I'd prefer to give them another backround color. I think this would be possible if there were special Blocks such as
<!-- BEGIN switch_is_WikiPost --> ... <!-- END switch_is_WikiPost -->
which I can use in my .tpl files.

Does anybody know how to add such Block support?
Is there a much simpler method to give the WikiPosts another Background color?

Post Reply

Return to “[2.0.x] MODs in Development”