Page 1 of 1

SpellCheck button to far right

Posted: Wed Apr 26, 2006 2:48 am
by Kerrith
phpBB 2.0.20 and PHPSpell version 1.06p.

I just installed 1.06p on a newly created forum. I have another phpBB forum Version 2.0.20 on which l have PHPSpell version 1.06.

Everything works fine with 1.06p except that the SpellCheck button is to the far right rather than aligned under the message window.

The code that I think this pertains to on posting_body.tpl looks like this:

<tr>
<td colspan="9"><span class="gen">
<textarea name="message" rows="15" cols="35" wrap="virtual" style="width:450px" tabindex="3" class="post" onselect="storeCaret(this);" onclick="storeCaret(this);" onkeyup="storeCaret(this);">{MESSAGE}</textarea>
</span></td>
</tr>
<tr><td colspan="9" align="right">
<input type="button" class="mainoption" value="SpellCheck" name="button" onclick="openspell();">
</td></tr>
</table>
</span></td>
</tr>

I have the diags loaded and can't see anything wrong. or,, anything different from the 1.06 pasting_body.tpl.

I'm at a loss as to how to fix it. It's really only cosmetic but still....

Suggestions?

Thanks,

Kerry

Here's the URLs to the forum.

http://managercoaching.com/forum/viewtopic.php?p=24#24

http://managercoaching.com/forum/spelli ... _diags.php

Posted: Wed Apr 26, 2006 3:01 am
by NGLeader
Kerrith:

If you want someone to help you, Setup a test account on your forum. This way whoever is helping you don't have to register.

PS: Nice UBB Board. 8O

Posted: Wed Apr 26, 2006 9:33 am
by Kerrith
Hi NGLeader,

Thanks for the nice ack, we've had that UBB board for about 5 years.

Here's URL to the Test Account No registration required.

Kerry

Posted: Wed Apr 26, 2006 10:47 am
by mr.boo
Kerrith,

First, you're post on wrong forum :)

Second, look at

<tr><td colspan="9" align="right">
<input type="button" class="mainoption" value="SpellCheck" name="button" onclick="openspell();">
</td></tr>

just delete align="right"
or replace it with align="center" (center justify)

Posted: Wed Apr 26, 2006 12:38 pm
by NGLeader
I use to have the same problem, If I remember right I thing that I had to change something in that line of code.

Here mine:

Code: Select all

		<tr>
			<td colspan="9" align="right">
     				<input type="button" class="mainoption" value="Spell Checker" name="button" onclick="openspell();">
			</td>
		</tr>
Add that above code after this code in posting.php

Code: Select all

		<tr>
			<td><textarea name="message" rows="15" cols="76" wrap="virtual" style="width:450px" tabindex="3" class="post" onselect="storeCaret(this);" onclick="storeCaret(this);" onkeyup="storeCaret(this);">{MESSAGE}</textarea></td>
		</tr>
Hope that works.

Posted: Wed Apr 26, 2006 6:58 pm
by drathbun
MOD Support questions go in the appropriate MOD topic. If you downloaded the MOD here, then it will either be in the MOD Releases forum, or the MOD Development forum, depending on the status of the code.

If you're not sure where the MOD is, you can use the MOD Search tool to try to find it.

Note that you cannot start a "new" topic in the MOD Releases forum, you must reply to an existing topic. Please find the appropriate topic and post your question there, thanks.

Closing this topic.