[BETA] Antispam for all fields (updated: 10-01-2009:V1.3.1)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
MackemMan
Registered User
Posts: 36
Joined: Sat Dec 29, 2007 7:39 pm

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by MackemMan » Thu Jan 17, 2008 9:41 pm

Ramon Fincken wrote:
Traxion wrote:I have just installed 1.2.8 and everytime someone registers I get a "get lost_register" message, even when they are legit accounts. Do I not have something configured right? Any help would be great. Thanks!

C
double check your profile_add_body.tpl there's an online txt file as example

I recently loaded version 1.2.8 fresh and am getting exactly the same error, I have checked the profile_add_body.tpl against the example line by line and the only thing different is from another mod I added (calendar) and its only one line.

I have checked on the user that they have done everything correctly and not used a 'banned' name. No-one can register on our forum. As you can imagine this is a major problem.

Please can anyone help asap.

TYIA.

Rob

Traxion
Registered User
Posts: 15
Joined: Wed Mar 30, 2005 11:32 pm
Contact:

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by Traxion » Fri Jan 18, 2008 3:23 pm

jerryT wrote:Finally updates to 1.2.8 and seems to be working..

I get the odd registration entry that shows no further details, just that it was a registration attempt.
Clicking open/close shows no more detail. Any Idea ? is this right ??

Also I have a couple of entries for mode 'editprofile', that have a type of 'website source' these are valid users but when I approve the registration, I get: "User was denied due to ban rules"

What ban rules ??

Thanks
I started having the problem too. No matter what usergroup I add the user to I get the same error and cannot approve the registration. Any ideas? Thanks!

C
"Never underestimate the predictability of stupidity"

MackemMan
Registered User
Posts: 36
Joined: Sat Dec 29, 2007 7:39 pm

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by MackemMan » Fri Jan 18, 2008 9:56 pm

Can anyone help me with our register problem???

They get the message "get lost_register".

Our url is http://www.btdpokerforum.com

HELP please!

Rob

MackemMan
Registered User
Posts: 36
Joined: Sat Dec 29, 2007 7:39 pm

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by MackemMan » Sun Jan 20, 2008 4:37 pm

Since I can't get an answer, looks like I will have to remove this MOD. Damn shame as it seems to have stopped all spammers (we had a few prior to installing this MOD).

Now no-one can register.

I have re-run through the whole MOD and everything (appears) as in the instructions. The profile_add_body.tpl is exactly the same as the on-line example except for an additional line from a previous MOD.

I am now looking for a replacement for this MOD.....

Rob.
Last edited by MackemMan on Sun Jan 20, 2008 7:36 pm, edited 1 time in total.

MackemMan
Registered User
Posts: 36
Joined: Sat Dec 29, 2007 7:39 pm

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by MackemMan » Sun Jan 20, 2008 7:29 pm

This is just getting worse by the minute for me.....

When I replace all the modified files with their originals I get the following message...

phpBB : Critical Error

Could not query config information

DEBUG MODE

SQL Error : 1146 Table 'btdpoker_phpb2.CONFIG_TABLE' doesn't exist

SELECT * FROM CONFIG_TABLE

Line : 219
File : common.php

Can anyone enlighten me please. Is anyone monitoring this thread?

Rob

MackemMan
Registered User
Posts: 36
Joined: Sat Dec 29, 2007 7:39 pm

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by MackemMan » Mon Jan 21, 2008 9:43 pm

Does anyone have a way of uninstalling this MOD?

4 days now and still no answer...getting desperate!

Rob.

User avatar
tormentor
Registered User
Posts: 94
Joined: Wed Dec 17, 2003 9:20 pm
Contact:

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by tormentor » Mon Feb 04, 2008 9:40 pm

Disable the FIELDFEST in the admin panel, and it will (probably) work. I've erased the integrated fieldfest because it get that error 8and because I've seen no replies for a long while on this thread).

In order to uninstall the mod simply replace the modified files with the original ones or edit them again, and these are the changes that it made to the database, so reverse these ones too :

Code: Select all

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_version','1.2.8')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_groupbypassid','-1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_sentmail','0')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_htmlmail','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_adminmail','')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_userposts','2')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_userdays','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_main_adminid','2')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_dbstore','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_checkremote','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_check_pm','0')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_check_post','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_check_register','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_fieldfest','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_fieldfest_regchange','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_fieldfest_regadd','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_semicron','0')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_maxsites','1')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_maxsitescount','5')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_level','3')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_live_email_validation','0')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_api','0')
+++ Successfull

# INSERT INTO `phpbb_config` VALUES ('mod_spamcheck_api_auth','')
+++ Successfull

# CREATE TABLE `phpbb_antispamdb` ( `Id` int(6) unsigned NOT NULL auto_increment, `user_id` mediumint(8) default NULL, `ip` varchar(25) default NULL, `ip_forwarded` varchar(25) default NULL, `time` int(11) NOT NULL default '0', `type` varchar(40) default 'word', `status` varchar(8) default 'false', `word_triggerid` smallint(5) default NULL, PRIMARY KEY (`Id`) )
+++ Successfull

# CREATE TABLE `phpbb_antispamdb_data` ( `Id` int(6) unsigned NOT NULL auto_increment, `core_id` mediumint(9) NOT NULL default '0', `vartype` varchar(30) NOT NULL default '', `varkey` text NOT NULL, `varvalue` text, PRIMARY KEY (`Id`) )
+++ Successfull

# CREATE TABLE `phpbb_antispamdb_words` ( `word_id` mediumint(8) unsigned NOT NULL auto_increment, `word` char(100) NOT NULL default '', `replacement` char(100) NOT NULL default '', `word_count` MEDIUMINT(8) DEFAULT '0', PRIMARY KEY (`word_id`) )
+++ Successfull

# CREATE TABLE `phpbb_antispamdb_fieldfest` ( `fieldfestid` mediumint(8) NOT NULL auto_increment, `type` varchar(30) NOT NULL default '', `sort` varchar(30) NOT NULL default '', `old` varchar(50) NOT NULL default '', `new` varchar(50) NOT NULL default '', `time` int(11) NOT NULL default '0', `session_id` varchar(32) NOT NULL default '', PRIMARY KEY (`fieldfestid`), KEY `sesson_id` (`session_id`), KEY `type` (`type`), KEY `sort` (`sort`) )
+++ Successfull

User avatar
tormentor
Registered User
Posts: 94
Joined: Wed Dec 17, 2003 9:20 pm
Contact:

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by tormentor » Wed Feb 13, 2008 9:46 pm

This code (with the url without "http:" for the link passes easily the "max websites per post" test )

Code: Select all

[url=somesites.net]	something written	[/url] 
Is this mod still mantained ?

rtank77
Registered User
Posts: 20
Joined: Fri Mar 31, 2006 6:49 pm
Contact:

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by rtank77 » Fri Mar 21, 2008 11:07 am

Hi Ramon,

I'm experiencing problems in running this very promising antispam MOD ver 1.2.8 of yours.

I've double checked all of the .php and .tpl files modifications and they seem to be ok.

Then, I run http://mydomain.com/forum/sql_update.php.

But once I try to log-in, the following error message appears:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
I checked for any string containing "message_die()" within the page_tail.php but no sign of it.

I'm really clueless and I hope someone can help... :(

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by Lumpy Burgertushie » Fri Mar 21, 2008 6:48 pm

that error usually means one of two things.

1.there is either a install directory, a contrib directory or both, in your phpbb directory.

remove them


2. one or more of the subSilver files are missing or named incorrectly.

however, this MOD is no longer very effective.

the RAC MOD or the Security Question MOD are the two that are working now.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

banditsc
Registered User
Posts: 4
Joined: Fri Oct 13, 2006 4:57 pm

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by banditsc » Thu Apr 17, 2008 5:07 pm

I am also getting the "get lost_register" error. It only seems to be happening with the AOL browsers, when the user switched to the IE brower it worked fine.

cdaveb
Registered User
Posts: 3
Joined: Fri Jul 18, 2003 3:24 am

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by cdaveb » Thu Jun 19, 2008 6:10 am

I'm also experiencing the "no valid location for this timezone" issue. I did find the following lines in functions_antispam.php that I have commented out for now, this seems to have fixed the problem, but not understanding the details of why it is happening I would like a more long term solution.

Code: Select all

		if (empty ($location)) {
			return array (
				'error' => true,
				'error_msg' => 'No valid location for this timezone.'
			);
		}

User avatar
Ramon Fincken
Registered User
Posts: 4835
Joined: Thu Oct 14, 2004 1:04 am
Location: NL, The Netherlands Amsterdam area @GMT +1
Contact:

Re: [BETA] Antispam for all fields (updated: 26-06-2008:V1.2.9)

Post by Ramon Fincken » Thu Jun 26, 2008 8:48 am

UPGRADES AVAILABLE:
Simply download the latest zipfile and easy upgrade instuctions + files are in that zipfile !
** upgrade 1.2.8 -> 1.2.9 26062008
http://www.phpbbantispam.com/viewtopic.php?t=139
All changes below:
-ACP: Fieldfest-
No alterations in functions.
-ACP: Management-
No alterations in functions.
-ACP: Spam Database-
No alterations in functions.
-ACP: Testcenter-
No alterations in functions.
-ACP: Wordlist-
No alterations in functions.
-Core function-
* Cleanup and alignment of code for most files
* Optimization of code, and functions
* Added: some length checks
* Added: 3 second delay on the register page
* Added: 2 phpbb_root_path and phpEx bot stoppers
* Added: changed usergroups to usertable attribute to cleanup usergroup
* Added: removal of [/b ] alike in check level 1
* Added: Some site seen as a valid url in posts
http://phpbbantispam.com/viewtopic.php?t=129
-FieldFest function-
No alterations in functions.
-Semicron function-
* Enabled again, the userlist wil clean itself up and users will have a new attribute :)
-Lang file-
* Added italian langfile !
-API-
No alterations in functions.
-Bugfixes-
* Spamcheck level goes to 1
http://phpbbantispam.com/viewtopic.php?t=130
-Language entries updated-
No new entries.
-Installation-
No alterations in functions.

Upgrade instructions are in the 1.2.9 zipfile
Dutch quality fully managed WordPress hosting - ManagedWPHosting.nl

Before changing a file, some code or installing a MOD >> Make a backup first!

Do you like my mods? paypal me $1 :) forumsoftware[AT}creativepulses[DOT}nl [/size]
PhpBBantispam.com || Instant find your mod here

User avatar
Ramon Fincken
Registered User
Posts: 4835
Joined: Thu Oct 14, 2004 1:04 am
Location: NL, The Netherlands Amsterdam area @GMT +1
Contact:

Re: [BETA] Antispam for all fields (updated: 04-11-2007:V1.2.8)

Post by Ramon Fincken » Thu Jun 26, 2008 8:52 am

banditsc wrote:I am also getting the "get lost_register" error. It only seems to be happening with the AOL browsers, when the user switched to the IE brower it worked fine.
Get lost register test and explanation:
http://www.phpbbantispam.com/viewtopic.php?t=136

***
tormentor wrote:This code (with the url without "http:" for the link passes easily the "max websites per post" test )

Code: Select all

[url=somesites.net]	something written	[/url] 
Is this mod still mantained ?
Yest this function has been implented in 1.2.9


***
@MackemMan, @rtank77 PM me your board info and I'll look at it


***

@Quimbly

1. Why is Location not part of the word censor list? I seem to get around 5-10 fake accounts being registered every day. If I could also include country names, this mod would catch a lot more fakes. The reason is because my site is very local and anyone registering from another country is a spammer.

2 + 3. When the Spam Database form actually does come up, it gives a list of users with posts waiting to be approved. What does that mean? Are the posts not being shown on board? If they need to be approved, where do I approve them?
By clickin on the link , a list wil appear
Image

And Yes I am aware that the spam DB can initiate time outs in your admin panel.

4. Also, what does the notification mean when it says "there are N spam reports" on the main page (page_tail.php), I believe. Where do I view these reports and what are they?
>> in the spam database in your ACP
Last edited by Ramon Fincken on Thu Jun 26, 2008 9:09 am, edited 1 time in total.
Dutch quality fully managed WordPress hosting - ManagedWPHosting.nl

Before changing a file, some code or installing a MOD >> Make a backup first!

Do you like my mods? paypal me $1 :) forumsoftware[AT}creativepulses[DOT}nl [/size]
PhpBBantispam.com || Instant find your mod here

User avatar
Ramon Fincken
Registered User
Posts: 4835
Joined: Thu Oct 14, 2004 1:04 am
Location: NL, The Netherlands Amsterdam area @GMT +1
Contact:

Re: [BETA] Antispam for all fields (updated: 26-06-2008:V1.2.9)

Post by Ramon Fincken » Thu Jun 26, 2008 9:03 am

@cdaveb

I'll make a switch to en/disable this feature in the next version.
It is ment to force you to enter a (valid) location

update: added to todo list
Dutch quality fully managed WordPress hosting - ManagedWPHosting.nl

Before changing a file, some code or installing a MOD >> Make a backup first!

Do you like my mods? paypal me $1 :) forumsoftware[AT}creativepulses[DOT}nl [/size]
PhpBBantispam.com || Instant find your mod here

Locked

Return to “[2.0.x] MODs in Development”

Who is online

Users browsing this forum: No registered users and 4 guests

cron