[BETA] SEO Urls V2

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
mgutt
Registered User
Posts: 346
Joined: Tue Sep 21, 2004 2:54 pm
Location: Germany, Sankt Augustin
Contact:

Post by mgutt »

Sorry, removing Copyright causes no support on phpbb.com

Code: Select all

<!--
	We request you retain the full copyright notice below including the link to www.phpbb.com.
	This not only gives respect to the large amount of time given freely by the developers
	but also helps build interest, traffic and use of phpBB 2.0. If you cannot (for good
	reason) retain the full copyright we request you at least leave in place the
	Powered by phpBB  line, with phpBB linked to www.phpbb.com. If you refuse
	to include even this then support on our forums may be affected.

	The phpBB Group : 2002
// -->
Forums: Honda || phpBB Categories Hierarchy
Mods: Spamfilter against bot registrations || Seo Urls

User avatar
golddust
Registered User
Posts: 423
Joined: Tue Mar 09, 2004 4:41 am
Location: UK

Post by golddust »

Hi mgutt,

now re-added copywrite, was deleted by mistake on new upload of customized overall_footer.tpl file. not on purpose ;-)

User avatar
golddust
Registered User
Posts: 423
Joined: Tue Mar 09, 2004 4:41 am
Location: UK

Post by golddust »

Mgutt,

I have an issue on my sub forum links eg; 1 2 3 4 my links show up as http://www.*******.com/*****/classic-dance-tunes-f14,start,40.html

i notice that on those link that they contain commers! i browsed your test forum and your looks different for example: http://phpbb2.phpbb-seo.net/example-forum-vf1-5.html no commers!

please advise

mgutt
Registered User
Posts: 346
Joined: Tue Sep 21, 2004 2:54 pm
Location: Germany, Sankt Augustin
Contact:

Post by mgutt »

this is not my mod and not my demo board. commas aren't a problem in urls.
Forums: Honda || phpBB Categories Hierarchy
Mods: Spamfilter against bot registrations || Seo Urls

User avatar
golddust
Registered User
Posts: 423
Joined: Tue Mar 09, 2004 4:41 am
Location: UK

Post by golddust »

ok thanks. But is there a way i can make them - instead of , please.

mgutt
Registered User
Posts: 346
Joined: Tue Sep 21, 2004 2:54 pm
Location: Germany, Sankt Augustin
Contact:

Post by mgutt »

no. I've changed that with the new CH Edition. But this mod is alpha and it's not compatible to vanilla phpbb. demo board: www.phpbb-de.com

regards
Forums: Honda || phpBB Categories Hierarchy
Mods: Spamfilter against bot registrations || Seo Urls

User avatar
yexusbeliever
Registered User
Posts: 586
Joined: Mon Dec 08, 2003 8:49 pm
Location: Olympus phpBB3

Post by yexusbeliever »

mgutt, I am having a bit of difficulty here.

I installed your mod. Since my phpbb folder is "forum", I went into the robot.txt and change the phpBB2 all into forum. Of course I upload the .htaccess and robot.txt to my main directory, which is public_html. The only problem I am getting at is clicking on any of the forum categories or topics to any link there on the forum will lead me to error page. What do you think is the solution for this?

chrisgill369
Registered User
Posts: 13
Joined: Thu Apr 28, 2005 7:49 pm

Post by chrisgill369 »

Hi, im interested in installing this on my forum but im a bit confused with it.
## c.) If your forum runs in an other named folder (http://mydomain.com/forums/index.php etc.) you need to
## copy the files of the folder "phpBB_in_folder" to your root (phpBB_in_folder/*.* to
## http://mydomain.com/*.*)
and change all the the given "phpBB2" to your foldername (f.e. "forums") in
## "robots.txt" and ".htaccess"



What does that bit mean?

Ive extracted the zip file and copied the files in phpbb_in_folder but where do i paste them too? My forum is installed in a folder called 'forums' so do i paste them in the 'forums' folder?

Any help would be great.

User avatar
yexusbeliever
Registered User
Posts: 586
Joined: Mon Dec 08, 2003 8:49 pm
Location: Olympus phpBB3

Post by yexusbeliever »

You will have to add "robots.txt" and ".htaccess" into your main directory. But first change all the phpBB2 in "robots.txt" and ".htaccess" to forums.

I believe that is what the direction saying.

jimday1982
Registered User
Posts: 43
Joined: Wed Feb 05, 2003 1:34 am
Location: Atlanta, GA
Contact:

Post by jimday1982 »

This mod worked perfectly on my heavily modded board and I just wanted to thank the author for his work - GREAT job!

My one complaint is that, like another user, some of my URLs now contain commas instead of hyphens. Surely there is a way to fix this...I wish I had the technical know-how to further investigate.

If anyone has a solution I will gladly compensate you for your time.

jmueller0823
Registered User
Posts: 83
Joined: Wed Dec 29, 2004 3:49 pm

Post by jmueller0823 »

DISREGARD
Where is the mod file?
Usually it's attached to the first post...

Thanks.
Last edited by jmueller0823 on Thu Dec 14, 2006 3:29 pm, edited 1 time in total.

User avatar
golddust
Registered User
Posts: 423
Joined: Tue Mar 09, 2004 4:41 am
Location: UK

Post by golddust »

jimday1982 wrote: This mod worked perfectly on my heavily modded board and I just wanted to thank the author for his work - GREAT job!

My one complaint is that, like another user, some of my URLs now contain commas instead of hyphens. Surely there is a way to fix this...I wish I had the technical know-how to further investigate.

If anyone has a solution I will gladly compensate you for your time.


Hi Jimday,

I have only commers in my links to sub forums 1 2 3 etc, not anywhere else on my forum... You shouldn't have those commers in your links to posts from home page. I would suggest re-installing the mod again. I had this issue and i started from scratch and all links are name-like-this-f3.html..

I would like to replace those commers in the sub forum links 1 2 3 with - but as mgutt mentions above, it's only avaible in the CH Edition of this mod.. :cry:

User avatar
golddust
Registered User
Posts: 423
Joined: Tue Mar 09, 2004 4:41 am
Location: UK

Post by golddust »

I think this mod is great!

Although I have one small issue with this mod. Once your posts are indexed in the search engines like google etc and you start getting some traffic from those-new-indexed-posts. You will find that when your forum members start editing post titles or make a few minor changes, then the original link changes. This will then disbale the link to the old post & will not be active until the search engines re-indexed the new title link! :cry: this could mean the loss of pagerank & traffic for established posts in the search index that have titles chatged or edited.

dscurlock
Registered User
Posts: 27
Joined: Wed Aug 02, 2006 5:07 pm

question.

Post by dscurlock »

mgutt wrote: A little Update to Version 1.2.4:

Code: Select all

#
#-----[ OPEN ]------------------------------------------
#
includes/functions.php
#
#-----[ FIND ]------------------------------------------
#
							'url' => append_sid("viewforum.$phpEx?" . POST_FORUM_URL . "=" . $forum_rows[$j]['forum_id'], '', $forum_rows[$j]['forum_name']),
#
#-----[ REPLACE WITH ]------------------------------------------
#
							'url' => append_sid("viewforum.$phpEx?" . POST_FORUM_URL . "=" . $forum_rows[$j]['forum_id']),
#
#
#-----[ OPEN ]------------------------------------------
#
This is for some browser who use the sitemap function of HTML Meta Tags (link rel=).

Searchphrases: SEO, mod, able2know, dynamic, URL's, Static, increase, page, rank, pagerank, inclusion, rates, search, engines, larger, board, urls, engine, modrewrite, mod, rewrite, apache, sid, session, html, htm, 2lucky, rabbit, short, shorturls, shorturl, seourl, seourls, phpBB, Search, Engine, Indexer, bot, GoogleBB, Link, Enhancement, Surprise, engine-friendly, indexing, Friendliness, Remove, Guest, ID's, SIDs, keyword, title, RewriteEngine, RewriteRule, spider, crawl, crawler, archiv, archive, phprebel
Last edited by dscurlock on Sat Dec 16, 2006 1:59 am, edited 1 time in total.

dscurlock
Registered User
Posts: 27
Joined: Wed Aug 02, 2006 5:07 pm

404 error

Post by dscurlock »

mgutt wrote:
Colin wrote:nice mod..
I'm getting a 404 error when using the sub_folder one. My URL is http://gmperformance.org/hbody

I did make the changes in the .htaccess file per instructions and rechecked my installation for any typos or mistakes. It seems to be correct.

Can you advise?
Thanks,
Colin


I had a typo in the code. Look at the last line in .htaccess.

In your way it must look like this:

Code: Select all

RewriteRule ^hbody/([a-zA-Z0-9_]+)\.html$ /hbody/$1.php [L]
*Download package was updated*
comuter wrote: mirror

Code: Select all

http://www.darkshare.com/v/7389116/mod_seo_urls_v2.zip.html
I have seen good mods like this pass by with dead links


If you are fast enough in updating the packages that is no problem for me ;)

In a few days I will ask for Validation of this mod at phpbb.com, so it will never go offline ;)


I am having the same problem...its like the html is not there for it to find...

Not Found
The requested URL /forums/test-forum-1-f1.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Post Reply

Return to “[2.0.x] MODs in Development”