[BETA] SEO Urls V2

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
dscurlock
Registered User
Posts: 27
Joined: Wed Aug 02, 2006 5:07 pm

Re: 404 error

Post by dscurlock » Sat Dec 16, 2006 1:45 am

dscurlock wrote:
mgutt wrote:
Colin wrote:nice mod..
I'm getting a 404 error when using the sub_folder one. My URL is http://gmperformance.org/hbody

I did make the changes in the .htaccess file per instructions and rechecked my installation for any typos or mistakes. It seems to be correct.

Can you advise?
Thanks,
Colin


I had a typo in the code. Look at the last line in .htaccess.

In your way it must look like this:

Code: Select all

RewriteRule ^hbody/([a-zA-Z0-9_]+)\.html$ /hbody/$1.php [L]
*Download package was updated*
comuter wrote: mirror

Code: Select all

http://www.darkshare.com/v/7389116/mod_seo_urls_v2.zip.html
I have seen good mods like this pass by with dead links


If you are fast enough in updating the packages that is no problem for me ;)

In a few days I will ask for Validation of this mod at phpbb.com, so it will never go offline ;)


I am having the same problem...its like the html is not there for it to find...

Not Found
The requested URL /forums/test-forum-1-f1.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

jmueller0823
Registered User
Posts: 83
Joined: Wed Dec 29, 2004 3:49 pm

Mod successful, just a few questions ...

Post by jmueller0823 » Sat Dec 16, 2006 3:26 pm

We installed the mod and appended the suggested
additions to our robots.txt file.

We utilize a sitemap service that provides our
sitemaps to Google.

I viewed our most recent sitemap and noticed
some unessential phpBB url patterns, such as:

http://www.site.com/boards/profile,mode ... u,883.html
http://www.site.com/boards/memberlist,m ... t,600.html

There are hundreds of these url's.

Of course the above are the new rewritten url's, so the
current robots entries won't exclude them.

Disallow: /boards/profile.php
Disallow: /boards/memberlist.php

--So, is there any harm in ignoring these "extra" url's?
--Or should we disallow (robots?)

eyesbryte
Registered User
Posts: 142
Joined: Tue Oct 12, 2004 11:28 pm
Location: Palm Springs, CA
Contact:

Post by eyesbryte » Sat Dec 16, 2006 7:58 pm

I have comma's in some of my links as well after installing this mod. I too wonder if there will be any problem because of it with the Search Engines. Does anyone know?
-Web site design and programming
http://www.eyesbryte.com

mgutt
Registered User
Posts: 346
Joined: Tue Sep 21, 2004 2:54 pm
Location: Germany, Sankt Augustin
Contact:

Post by mgutt » Sun Dec 17, 2006 5:43 pm

jmueller0823 wrote: I viewed our most recent sitemap and noticed
some unessential phpBB url patterns, such as:

http://www.site.com/boards/profile,mode ... u,883.html
http://www.site.com/boards/memberlist,m ... t,600.html


If you think they are unessential you can disallow them by robots.txt using:

Code: Select all

disallow /boards/profile,
I allow them. Userprofiles are good content. Everybody has to decide for his own.
eyesbryte wrote: I have comma's in some of my links as well after installing this mod. I too wonder if there will be any problem because of it with the Search Engines. Does anyone know?


No problems. I'm using them in all of my webprojects. Commas are one of the best seperators. Better than underscore at all.
Forums: Honda || phpBB Categories Hierarchy
Mods: Spamfilter against bot registrations || Seo Urls

dscurlock
Registered User
Posts: 27
Joined: Wed Aug 02, 2006 5:07 pm

disallow

Post by dscurlock » Sun Dec 17, 2006 6:25 pm

mgutt wrote:
jmueller0823 wrote:I viewed our most recent sitemap and noticed
some unessential phpBB url patterns, such as:

http://www.site.com/boards/profile,mode ... u,883.html
http://www.site.com/boards/memberlist,m ... t,600.html


If you think they are unessential you can disallow them by robots.txt using:

Code: Select all

disallow /boards/profile,
I allow them. Userprofiles are good content. Everybody has to decide for his own.
eyesbryte wrote: I have comma's in some of my links as well after installing this mod. I too wonder if there will be any problem because of it with the Search Engines. Does anyone know?


No problems. I'm using them in all of my webprojects. Commas are one of the best seperators. Better than underscore at all.


I already have disallow /boards/profile.php and still getting those
strange commas, and HTML pages did not exist.

mgutt
Registered User
Posts: 346
Joined: Tue Sep 21, 2004 2:54 pm
Location: Germany, Sankt Augustin
Contact:

Post by mgutt » Sun Dec 17, 2006 11:08 pm

profile.php is profile.php and not profile,

search engines can't see files on your ftp. They can only read what is displayed in the url. Tip: Don't forbid only "profile" because a talking url could contain it as the first word and is forbidden, too.

look my one:
www.maxrev.de/robots.txt

regards
Forums: Honda || phpBB Categories Hierarchy
Mods: Spamfilter against bot registrations || Seo Urls

falafelboy
Registered User
Posts: 29
Joined: Fri Oct 06, 2006 10:36 pm
Location: canada
Contact:

Post by falafelboy » Mon Dec 18, 2006 7:29 pm

mgutt wrote: profile.php is profile.php and not profile,

search engines can't see files on your ftp. They can only read what is displayed in the url. Tip: Don't forbid only "profile" because a talking url could contain it as the first word and is forbidden, too.

look my one:
www.maxrev.de/robots.txt

regards


Ok. I installed the mod and worked flawlessly after I changed the htaccess file to alter the phpbb2 instances.

I also just updated the robots.txt as per previous conversation. Is this change recommended for everyone?

I did it anyway.

Thanks for your hard work. So far so good.

all the best.

mgutt
Registered User
Posts: 346
Joined: Tue Sep 21, 2004 2:54 pm
Location: Germany, Sankt Augustin
Contact:

Post by mgutt » Mon Dec 18, 2006 11:19 pm

My one is not recommened. I use an other version of seo urls.

regards
Forums: Honda || phpBB Categories Hierarchy
Mods: Spamfilter against bot registrations || Seo Urls

sakkiotto
Registered User
Posts: 228
Joined: Mon Jun 13, 2005 9:45 pm

Post by sakkiotto » Wed Dec 20, 2006 1:54 am

i have problem when i view the groups

check ... Parse error: syntax error, unexpected $end in /home/mhd-01/www.pokerlandia.net/htdocs/includes/template.php(127) : eval()'d code on line 162

edit: done.. sorry.

mattyj33
Registered User
Posts: 28
Joined: Wed Dec 13, 2006 5:51 am

Post by mattyj33 » Mon Dec 25, 2006 11:56 pm

Ive read about the new CH version which is coming out...but has anyone got this to work with Simple Sub Forums? Im getting the same error as this following post attempts to solve for a differant SEO mod...im wondering if somebody could tell me if that solution code would work

http://www.phpbb-seo.com/boards/phpbb-m ... -vt41.html

or something similiar

Aliniuz
Registered User
Posts: 310
Joined: Fri Jun 23, 2006 6:12 am
Contact:

Post by Aliniuz » Thu Dec 28, 2006 12:26 pm

I Installed the MOD , great job mgutt but i have a little .... problem .

the link of my topics are like that
http://www.galatiforum.com/font-color-mass-messages-de-pe-yahoo-color-t38.html

I don't wish to appear what i marked with red .

What I have to do ? Thanx .

jamesko20
Registered User
Posts: 1
Joined: Fri Aug 20, 2004 12:07 pm

Post by jamesko20 » Fri Dec 29, 2006 9:56 am

Great mod, works fine ;)

I'm currently using a little script to display latest posts on my frontpage, would it be possible to mod it so that it uses the SEO urls and not the standard url ?

Thanks.

Code: Select all

<?php
// ############         Edit below         ########################################
$topic_length = '';	// length of topic title
$topic_limit = '';	// limit of displayed topics
$special_forums = '';	// specify forums ('0' = no; '1' = yes)
$forum_ids = '';		// IDs of forums; separate them with a comma

$config_path = '';	// path to config.php
$root_path = '';		// link path
// ############         Edit above         ########################################

$path = dirname(__FILE__);
include_once($path.$config_path .'config.php');
mysql_connect($dbhost, $dbuser, $dbpasswd) OR die('Unable to select server.');
mysql_select_db($dbname) OR die('Unable to select database.'); 

// ############## output ##############
echo '<table width="100%" cellpadding="1" cellspacing="1" border="0" align="center">';
// ############## output ##############

$where_forums = ( $special_forums == '0' ) ? '' : 't.forum_id IN ('. $forum_ids .') AND ';
$sql = "SELECT t.*, f.forum_id, f.forum_name, u.username AS first_poster, u.user_id AS first_poster_id, u2.username AS last_poster, u2.user_id AS last_poster_id, p.post_username AS first_poster_name, p2.post_username AS last_poster_name, p2.post_time
	FROM ". $table_prefix ."topics t, ". $table_prefix ."forums f, ". $table_prefix ."users u, ". $table_prefix ."posts p, ". $table_prefix ."posts p2, ". $table_prefix ."users u2
	WHERE $where_forums t.topic_poster = u.user_id AND f.forum_id = t.forum_id AND p.post_id = t.topic_first_post_id AND p2.post_id = t.topic_last_post_id AND u2.user_id = p2.poster_id
	ORDER BY t.topic_last_post_id DESC LIMIT $topic_limit";
$result = mysql_query($sql);
if( !$result )
{
	die('SQL Statement Error: '. mysql_error());
	exit();
}

$line = array();
while( $row = mysql_fetch_array($result) )
{
	$line[] = $row;
}

for( $i = 0; $i < count($line); $i++ )
{
	$forum_id = $line[$i]['forum_id'];
	$forum_url = $root_path .'viewforum.php?f='. $forum_id;
	$topic_id = $line[$i]['topic_id'];
	$topic_url = $root_path .'viewtopic.php?t='. $topic_id;

	$topic_title = ( strlen($line[$i]['topic_title']) < $topic_length ) ? $line[$i]['topic_title'] : substr(stripslashes($line[$i]['topic_title']), 0, $topic_length) .'...';

	$topic_type =  ( $line[$i]['topic_type'] == '2' ) ? 'Announcement ': '';
	$topic_type .= ( $line[$i]['topic_type'] == '3' ) ? 'Global Announcement ': '';
	$topic_type .= ( $line[$i]['topic_type'] == '1' ) ? 'Sticky ': '';
	$topic_type .= ( $line[$i]['topic_vote'] ) ? 'Poll ': '';

	$views = $line[$i]['topic_views'];
	$replies = $line[$i]['topic_replies'];

	$first_time = date('d.m.Y', $line[$i]['topic_time']);
	$first_author = ( $line[$i]['first_poster_id'] != '-1' ) ? '<a href="'. $root_path .'profile.php?mode=viewprofile&u='. $line[$i]['first_poster_id'] .'">'. $line[$i]['first_poster'] .'</a>' : ( ($line[$i]['first_poster_name'] != '' ) ? $line[$i]['first_poster_name'] : 'guest' );
	$last_time = date('d.m.Y', $line[$i]['post_time']);
	$last_author = ( $line[$i]['last_poster_id'] != '-1' ) ? $line[$i]['last_poster'] : ( ($line[$i]['last_poster_name'] != '' ) ? $line[$i]['last_poster_name'] : 'guest' );
	$last_url = '<a href="'. $root_path .'viewtopic.php?p='. $line[$i]['topic_last_post_id'] .'#'. $line[$i]['topic_last_post_id'] .'">'. $last_author .'</a>';

	// ############## output ##############
	
	echo ''. $topic_type .'<a href="'. $topic_url .'">'. utf8_encode($topic_title) .'</a></td>
                    </tr><br>';
	// ############## output ##############
}

echo '</table>';
mysql_close();
?>

onicdesigns
Registered User
Posts: 20
Joined: Sat Sep 30, 2006 10:53 pm

Post by onicdesigns » Sun Dec 31, 2006 2:11 am

Those unwanted url patterns, how do you not have it like that.

I have it installed on forumsales.info -> but if someone tries to look at page 2 after searching for new posts it will 404 error out of them. :(

mikey672
Registered User
Posts: 1
Joined: Tue Jan 02, 2007 12:52 pm

Post by mikey672 » Tue Jan 02, 2007 1:01 pm

hi how is this mod doing for you.

i did not see this before now, i will test this it looks good

SuperFedya
Registered User
Posts: 248
Joined: Sun Jul 14, 2002 9:14 pm
Contact:

Post by SuperFedya » Sat Jan 13, 2007 5:39 am

Hello
Great mod, but:
1. PM dont work "privmsg,folder,inbox.html"
404 error.

2. Category link dont work "category-c1.html"
404 error.

How i can fix that?
My HTACCESS:

Code: Select all

<Files config.php>
Deny from all
</Files>

DirectoryIndex index.php index.html

RewriteEngine On
RewriteBase   /forum/

RewriteRule !\.html$ - [L]
RewriteRule ^[a-z0-9-]+-([pt])([0-9]+)\.html$ viewtopic.php?$1=$2 [L]
RewriteRule ^[a-z0-9-]+-f([0-9]+)\.html$ viewforum.php?f=$1 [L]
RewriteRule ^[a-z0-9-]+-u([0-9]+)\.html$ profile.php?mode=viewprofile&u=$1 [L]
RewriteRule ^([a-zA-Z0-9_]+),([^/,]+),([^/,]*)([^/]*\.html)$ $1$4?$2=$3 [QSA,N]
RewriteRule ^[a-z0-9-]+-([pt])([0-9]+),([^/,]+),([^/,]*)([^/]*\.html)$ viewtopic$5?$1=$2&$3=$4 [QSA,N]
RewriteRule ^[a-z0-9-]+-f([0-9]+),([^/,]+),([^/,]*)([^/]*\.html)$ viewforum$4?f=$1&$2=$3 [QSA,N]
RewriteRule ^([a-zA-Z0-9_]+)\.html$ $1.php [L]
Thanks for help!
Last edited by SuperFedya on Sat Jan 13, 2007 3:58 pm, edited 1 time in total.

Post Reply

Return to “[2.0.x] MODs in Development”