Page 20 of 24

Re: 404 error

Posted: Sat Dec 16, 2006 1:45 am
by dscurlock
dscurlock wrote:
mgutt wrote:
Colin wrote:nice mod..
I'm getting a 404 error when using the sub_folder one. My URL is http://gmperformance.org/hbody

I did make the changes in the .htaccess file per instructions and rechecked my installation for any typos or mistakes. It seems to be correct.

Can you advise?
Thanks,
Colin


I had a typo in the code. Look at the last line in .htaccess.

In your way it must look like this:

Code: Select all

RewriteRule ^hbody/([a-zA-Z0-9_]+)\.html$ /hbody/$1.php [L]
*Download package was updated*
comuter wrote: mirror

Code: Select all

http://www.darkshare.com/v/7389116/mod_seo_urls_v2.zip.html
I have seen good mods like this pass by with dead links


If you are fast enough in updating the packages that is no problem for me ;)

In a few days I will ask for Validation of this mod at phpbb.com, so it will never go offline ;)


I am having the same problem...its like the html is not there for it to find...

Not Found
The requested URL /forums/test-forum-1-f1.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Mod successful, just a few questions ...

Posted: Sat Dec 16, 2006 3:26 pm
by jmueller0823
We installed the mod and appended the suggested
additions to our robots.txt file.

We utilize a sitemap service that provides our
sitemaps to Google.

I viewed our most recent sitemap and noticed
some unessential phpBB url patterns, such as:

http://www.site.com/boards/profile,mode ... u,883.html
http://www.site.com/boards/memberlist,m ... t,600.html

There are hundreds of these url's.

Of course the above are the new rewritten url's, so the
current robots entries won't exclude them.

Disallow: /boards/profile.php
Disallow: /boards/memberlist.php

--So, is there any harm in ignoring these "extra" url's?
--Or should we disallow (robots?)

Posted: Sat Dec 16, 2006 7:58 pm
by eyesbryte
I have comma's in some of my links as well after installing this mod. I too wonder if there will be any problem because of it with the Search Engines. Does anyone know?

Posted: Sun Dec 17, 2006 5:43 pm
by mgutt
jmueller0823 wrote: I viewed our most recent sitemap and noticed
some unessential phpBB url patterns, such as:

http://www.site.com/boards/profile,mode ... u,883.html
http://www.site.com/boards/memberlist,m ... t,600.html


If you think they are unessential you can disallow them by robots.txt using:

Code: Select all

disallow /boards/profile,
I allow them. Userprofiles are good content. Everybody has to decide for his own.
eyesbryte wrote: I have comma's in some of my links as well after installing this mod. I too wonder if there will be any problem because of it with the Search Engines. Does anyone know?


No problems. I'm using them in all of my webprojects. Commas are one of the best seperators. Better than underscore at all.

disallow

Posted: Sun Dec 17, 2006 6:25 pm
by dscurlock
mgutt wrote:
jmueller0823 wrote:I viewed our most recent sitemap and noticed
some unessential phpBB url patterns, such as:

http://www.site.com/boards/profile,mode ... u,883.html
http://www.site.com/boards/memberlist,m ... t,600.html


If you think they are unessential you can disallow them by robots.txt using:

Code: Select all

disallow /boards/profile,
I allow them. Userprofiles are good content. Everybody has to decide for his own.
eyesbryte wrote: I have comma's in some of my links as well after installing this mod. I too wonder if there will be any problem because of it with the Search Engines. Does anyone know?


No problems. I'm using them in all of my webprojects. Commas are one of the best seperators. Better than underscore at all.


I already have disallow /boards/profile.php and still getting those
strange commas, and HTML pages did not exist.

Posted: Sun Dec 17, 2006 11:08 pm
by mgutt
profile.php is profile.php and not profile,

search engines can't see files on your ftp. They can only read what is displayed in the url. Tip: Don't forbid only "profile" because a talking url could contain it as the first word and is forbidden, too.

look my one:
www.maxrev.de/robots.txt

regards

Posted: Mon Dec 18, 2006 7:29 pm
by falafelboy
mgutt wrote: profile.php is profile.php and not profile,

search engines can't see files on your ftp. They can only read what is displayed in the url. Tip: Don't forbid only "profile" because a talking url could contain it as the first word and is forbidden, too.

look my one:
www.maxrev.de/robots.txt

regards


Ok. I installed the mod and worked flawlessly after I changed the htaccess file to alter the phpbb2 instances.

I also just updated the robots.txt as per previous conversation. Is this change recommended for everyone?

I did it anyway.

Thanks for your hard work. So far so good.

all the best.

Posted: Mon Dec 18, 2006 11:19 pm
by mgutt
My one is not recommened. I use an other version of seo urls.

regards

Posted: Wed Dec 20, 2006 1:54 am
by sakkiotto
i have problem when i view the groups

check ... Parse error: syntax error, unexpected $end in /home/mhd-01/www.pokerlandia.net/htdocs/includes/template.php(127) : eval()'d code on line 162

edit: done.. sorry.

Posted: Mon Dec 25, 2006 11:56 pm
by mattyj33
Ive read about the new CH version which is coming out...but has anyone got this to work with Simple Sub Forums? Im getting the same error as this following post attempts to solve for a differant SEO mod...im wondering if somebody could tell me if that solution code would work

http://www.phpbb-seo.com/boards/phpbb-m ... -vt41.html

or something similiar

Posted: Thu Dec 28, 2006 12:26 pm
by Aliniuz
I Installed the MOD , great job mgutt but i have a little .... problem .

the link of my topics are like that
http://www.galatiforum.com/font-color-mass-messages-de-pe-yahoo-color-t38.html

I don't wish to appear what i marked with red .

What I have to do ? Thanx .

Posted: Fri Dec 29, 2006 9:56 am
by jamesko20
Great mod, works fine ;)

I'm currently using a little script to display latest posts on my frontpage, would it be possible to mod it so that it uses the SEO urls and not the standard url ?

Thanks.

Code: Select all

<?php
// ############         Edit below         ########################################
$topic_length = '';	// length of topic title
$topic_limit = '';	// limit of displayed topics
$special_forums = '';	// specify forums ('0' = no; '1' = yes)
$forum_ids = '';		// IDs of forums; separate them with a comma

$config_path = '';	// path to config.php
$root_path = '';		// link path
// ############         Edit above         ########################################

$path = dirname(__FILE__);
include_once($path.$config_path .'config.php');
mysql_connect($dbhost, $dbuser, $dbpasswd) OR die('Unable to select server.');
mysql_select_db($dbname) OR die('Unable to select database.'); 

// ############## output ##############
echo '<table width="100%" cellpadding="1" cellspacing="1" border="0" align="center">';
// ############## output ##############

$where_forums = ( $special_forums == '0' ) ? '' : 't.forum_id IN ('. $forum_ids .') AND ';
$sql = "SELECT t.*, f.forum_id, f.forum_name, u.username AS first_poster, u.user_id AS first_poster_id, u2.username AS last_poster, u2.user_id AS last_poster_id, p.post_username AS first_poster_name, p2.post_username AS last_poster_name, p2.post_time
	FROM ". $table_prefix ."topics t, ". $table_prefix ."forums f, ". $table_prefix ."users u, ". $table_prefix ."posts p, ". $table_prefix ."posts p2, ". $table_prefix ."users u2
	WHERE $where_forums t.topic_poster = u.user_id AND f.forum_id = t.forum_id AND p.post_id = t.topic_first_post_id AND p2.post_id = t.topic_last_post_id AND u2.user_id = p2.poster_id
	ORDER BY t.topic_last_post_id DESC LIMIT $topic_limit";
$result = mysql_query($sql);
if( !$result )
{
	die('SQL Statement Error: '. mysql_error());
	exit();
}

$line = array();
while( $row = mysql_fetch_array($result) )
{
	$line[] = $row;
}

for( $i = 0; $i < count($line); $i++ )
{
	$forum_id = $line[$i]['forum_id'];
	$forum_url = $root_path .'viewforum.php?f='. $forum_id;
	$topic_id = $line[$i]['topic_id'];
	$topic_url = $root_path .'viewtopic.php?t='. $topic_id;

	$topic_title = ( strlen($line[$i]['topic_title']) < $topic_length ) ? $line[$i]['topic_title'] : substr(stripslashes($line[$i]['topic_title']), 0, $topic_length) .'...';

	$topic_type =  ( $line[$i]['topic_type'] == '2' ) ? 'Announcement ': '';
	$topic_type .= ( $line[$i]['topic_type'] == '3' ) ? 'Global Announcement ': '';
	$topic_type .= ( $line[$i]['topic_type'] == '1' ) ? 'Sticky ': '';
	$topic_type .= ( $line[$i]['topic_vote'] ) ? 'Poll ': '';

	$views = $line[$i]['topic_views'];
	$replies = $line[$i]['topic_replies'];

	$first_time = date('d.m.Y', $line[$i]['topic_time']);
	$first_author = ( $line[$i]['first_poster_id'] != '-1' ) ? '<a href="'. $root_path .'profile.php?mode=viewprofile&u='. $line[$i]['first_poster_id'] .'">'. $line[$i]['first_poster'] .'</a>' : ( ($line[$i]['first_poster_name'] != '' ) ? $line[$i]['first_poster_name'] : 'guest' );
	$last_time = date('d.m.Y', $line[$i]['post_time']);
	$last_author = ( $line[$i]['last_poster_id'] != '-1' ) ? $line[$i]['last_poster'] : ( ($line[$i]['last_poster_name'] != '' ) ? $line[$i]['last_poster_name'] : 'guest' );
	$last_url = '<a href="'. $root_path .'viewtopic.php?p='. $line[$i]['topic_last_post_id'] .'#'. $line[$i]['topic_last_post_id'] .'">'. $last_author .'</a>';

	// ############## output ##############
	
	echo ''. $topic_type .'<a href="'. $topic_url .'">'. utf8_encode($topic_title) .'</a></td>
                    </tr><br>';
	// ############## output ##############
}

echo '</table>';
mysql_close();
?>

Posted: Sun Dec 31, 2006 2:11 am
by onicdesigns
Those unwanted url patterns, how do you not have it like that.

I have it installed on forumsales.info -> but if someone tries to look at page 2 after searching for new posts it will 404 error out of them. :(

Posted: Tue Jan 02, 2007 1:01 pm
by mikey672
hi how is this mod doing for you.

i did not see this before now, i will test this it looks good

Posted: Sat Jan 13, 2007 5:39 am
by SuperFedya
Hello
Great mod, but:
1. PM dont work "privmsg,folder,inbox.html"
404 error.

2. Category link dont work "category-c1.html"
404 error.

How i can fix that?
My HTACCESS:

Code: Select all

<Files config.php>
Deny from all
</Files>

DirectoryIndex index.php index.html

RewriteEngine On
RewriteBase   /forum/

RewriteRule !\.html$ - [L]
RewriteRule ^[a-z0-9-]+-([pt])([0-9]+)\.html$ viewtopic.php?$1=$2 [L]
RewriteRule ^[a-z0-9-]+-f([0-9]+)\.html$ viewforum.php?f=$1 [L]
RewriteRule ^[a-z0-9-]+-u([0-9]+)\.html$ profile.php?mode=viewprofile&u=$1 [L]
RewriteRule ^([a-zA-Z0-9_]+),([^/,]+),([^/,]*)([^/]*\.html)$ $1$4?$2=$3 [QSA,N]
RewriteRule ^[a-z0-9-]+-([pt])([0-9]+),([^/,]+),([^/,]*)([^/]*\.html)$ viewtopic$5?$1=$2&$3=$4 [QSA,N]
RewriteRule ^[a-z0-9-]+-f([0-9]+),([^/,]+),([^/,]*)([^/]*\.html)$ viewforum$4?f=$1&$2=$3 [QSA,N]
RewriteRule ^([a-zA-Z0-9_]+)\.html$ $1.php [L]
Thanks for help!