[RC1] Random Quotes 1.7.2

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

well, i dont know why easyMOD would have had any problems with that. the MOD passed the official MOD syntax checker without any errors.

i dont specifically write the MOD for easyMOD compliance, although if it passes the official mod syntax checker, i dont know why easyMOD would have those problems, given i dont pay much attention to easymod.
killyouall
Registered User
Posts: 523
Joined: Tue Oct 18, 2005 3:04 am
Contact:

Post by killyouall »

dfritter4 wrote: thanks. im really close to finishing the changeable fonts (ive just been away for a while) but i cant test it since my host is undergoing maintenance and i dont have ftp access. when i get a chance to test it, ill release the newest version and if a few people are able to test it and it works fine, ill go ahead and make it a release candidate and submit it to the database.


did you get that to work yet?
lol im waiting for the next release befor i try it
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

ill have it working when i get a chance to actually make it.

ive been on vacation and not at home very much the last few weeks so i havent had a chance to sit down and finish the last part.

ill make a post back here when i get home and finish the MOD
killyouall
Registered User
Posts: 523
Joined: Tue Oct 18, 2005 3:04 am
Contact:

Post by killyouall »

ah ok well good luck and hurry up lol na take your time make it sweet rofl
i need another hobbly maby ill pay more attention to my gf lol
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

ok back again with another update:

ive got the whole quotes thing almost figured out.

ive got it so that it has the drop down box with choosable fonts (font options can be added by moddifying a single file) but the problem im now trying to work out is the fact that even though the quotes are being "commanded" to use the font i choose, something else is over-riding it and telling it to be something else.
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

ALRIGHT!!!

FINALLY FINISHED COMPLETELY

i would greatly appreciated someone trying this out on their board.

it works 100% fine on my board as i have just got finished testing it after i fixed the small font problem.

if there are any other suggestions or addons that anyone would like to request, feel free to ask.

the link to the updated download is in my original post
DeeDeeINFJ
Registered User
Posts: 43
Joined: Mon Apr 24, 2006 8:20 pm
Location: Mississippi
Contact:

Post by DeeDeeINFJ »

Great mod! Installed like a charm and works perfectly. If you'd like to see it on my board, here's the link:

http://www.paulbettany.net/phpBB2


Thanks for making it. :D
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

thank you very much. always glad to see my work appreciated

if i could just have at least 1 more person test it successfully, ill go ahead and submit it to the MOD database, and see the MOD team shred it to bits on how bad my coding is :roll:

then ill fix what they tell me to and hopefully this will be in the mod db in no time
Arglwydd
Registered User
Posts: 133
Joined: Tue Dec 06, 2005 7:58 pm
Location: Wales, UK
Contact:

Post by Arglwydd »

I'll give it a spin on my Test Board! :)

Give me a few minutes and I'll let you know how it worked out.
MythicalRealmRPG.net! A roleplaying site for adult writers!
LCNA - A mafia-themed text-based roleplaying game for all ages!
Arglwydd
Registered User
Posts: 133
Joined: Tue Dec 06, 2005 7:58 pm
Location: Wales, UK
Contact:

Post by Arglwydd »

When I install this MOD on a vanilla version of phpBB 2.0.21, I get this;
Quotes MOD Screenshot 1

For it to display in the place you have, I have to switch this part of the code;

Code: Select all

#
#-----[ OPEN ]-----------------------------------------
#
templates/subSilver/overall_header.tpl

#
#-----[ FIND ]-----------------------------------------
#
			</tr>
		</table>

#
#-----[ AFTER, ADD ]-----------------------------------
#
<p align="center"><font color={QUOTES_COLOR}><{QUOTES_BOLD}><{QUOTES_ITALIC}><{QUOTES_UNDERLINE}><span style="font-family: {QUOTES_FONT}">{RNDM_QUOTES}</span></{QUOTES_UNDERLINE}></{QUOTES_ITALIC}></{QUOTES_BOLD}></font></p>

#
#-----[ SAVE/CLOSE ALL FILES ]--------------------------
#
# EoM
for this;

Code: Select all

#
#-----[ OPEN ]-----------------------------------------
#
templates/subSilver/overall_header.tpl

#
#-----[ FIND ]-----------------------------------------
#
<tr>
        <td height="25" align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; &nbsp;<a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}</a>&nbsp; &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</span></td>
</tr>

#
#-----[ AFTER, ADD ]-----------------------------------
#  
<tr>
	<td align="center"><font color={QUOTES_COLOR}><{QUOTES_BOLD}><{QUOTES_ITALIC}><{QUOTES_UNDERLINE}><span style="font-family: {QUOTES_FONT}">{RNDM_QUOTES}</span></{QUOTES_UNDERLINE}></{QUOTES_ITALIC}></{QUOTES_BOLD}></font></td>
</tr>
#
#-----[ SAVE/CLOSE ALL FILES ]--------------------------
#
# EoM
MythicalRealmRPG.net! A roleplaying site for adult writers!
LCNA - A mafia-themed text-based roleplaying game for all ages!
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

well pretty much i could just say

Code: Select all

##
##-----[ FIND ] ------------------------
##

</table>

##
##-----[ AFTER, ADD ]----------------------
##

<p align="center"><font color={QUOTES_COLOR}><{QUOTES_BOLD}><{QUOTES_ITALIC}><{QUOTES_UNDERLINE}><span style="font-family: {QUOTES_FONT}">{RNDM_QUOTES}</span></{QUOTES_UNDERLINE}></{QUOTES_ITALIC}></{QUOTES_BOLD}></font></p>

basically youre just placing the quotes information right after the the menu bar (login, usergroups, memberlist, etc...) table

i believe if i just put the find </table> it should work with every template
Arglwydd wrote: When I install this MOD on a vanilla version of phpBB 2.0.21


im not sure what a vanilla version is, but technically im only supposed to code for the standard phpBB subSilver template.

anyways, i believe just finding the </table> will work for all templates/versions.

what you did when you changed the FIND is ok, but youre still placing it inside the menu bar table. this is fine, i just placed mine outside the table.
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

BTW:

if anyone just wants to see the MOD in action, you can use my test board

BOARD : header quotes test

USERNAME : testing

PASSWORD : testing

youll have to login to the ACP and you do have privledges
Arglwydd
Registered User
Posts: 133
Joined: Tue Dec 06, 2005 7:58 pm
Location: Wales, UK
Contact:

Post by Arglwydd »

Strange. By vanilla installation, I mean that my test board has no MODs and is using the subSilver template. I just realised though that that's not strictly true, since my test board does have easyMOD installed, which is what I used to install the Quotes in Header MOD. That might be the source of the problem. Other than that though, it seems to install fine with easyMOD.

One consideration for future versions of this MOD if you're thinking to work more on it at any point, pre or post-release, might be another drop down box with a choice of font sizes, just to add increased control to the user. :)

EDIT: I'm having a slight problem with this MOD on my testboard. I've just realised that when you change font, although it remembers the change in font in the ACP, the display font doesn't seem to change at all.

EDIT: I see that the font changes on your TestBoard. So I'll see if I can work out why it isn't on mine. I'll keep you updated.
MythicalRealmRPG.net! A roleplaying site for adult writers!
LCNA - A mafia-themed text-based roleplaying game for all ages!
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

Arglwydd wrote: Strange. By vanilla installation, I mean that my test board has no MODs and is using the subSilver template. I just realised though that that's not strictly true, since my test board does have easyMOD installed, which is what I used to install the Quotes in Header MOD. That might be the source of the problem. Other than that though, it seems to install fine with easyMOD.

One consideration for future versions of this MOD if you're thinking to work more on it at any point, pre or post-release, might be another drop down box with a choice of font sizes, just to add increased control to the user. :)

EDIT: I'm having a slight problem with this MOD on my testboard. I've just realised that when you change font, although it remembers the change in font in the ACP, the display font doesn't seem to change at all.

EDIT: I see that the font changes on your TestBoard. So I'll see if I can work out why it isn't on mine. I'll keep you updated.


there might be a problem in the overall_header.tpl

can you post the quotes code that is actually in your overall_header.tpl

i might be able to tell you what the problem is from that
User avatar
dfritter4
Registered User
Posts: 479
Joined: Wed Jul 20, 2005 6:39 pm
Location: Ohio
Contact:

Post by dfritter4 »

actually i just found the problem

i forgot to change the text in the page_header.php for the mod

where it says add whatever in page_header.php change it to this:

Code: Select all

	//START random quote mod by dfritter4
	'RNDM_QUOTES' => $rndm_quotes,
	'QUOTES_COLOR' => $board_quotes['quotes_color'],
	'QUOTES_FONT' => $board_quotes['quotes_font'],
	'QUOTES_BOLD' => $quotes_bold,
	'QUOTES_ITALIC' => $quotes_italic,
	'QUOTES_UNDERLINE' => $quotes_underline,
	//END random quote mod by dfritter4
i end up doing this sometimes. im constantly changing my own files and uploading them to see if it works, and then i forget to change the .mod file where it tells everyone else what to do :roll: silly me.
Post Reply

Return to “[2.0.x] MODs in Development”