Page 6 of 7

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Sat Jun 09, 2007 5:27 am
by PupChow
Great mod! The only 2 little things I have a very minor issue with and hoping somebody can help:

1) Can the little + sign be to the right of the field right from the start? Instead of popping to the right after I added in a name / added another field.

2) When previewing, is there any way to list all the receipients' name in a single line, instead of having one line for each name?

Thanks!

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Fri Jul 20, 2007 9:31 am
by nims
Even I am facing the same problem, I sent PM to around 2000 members on my forum to check a new feature, but only few members got PM :(

Is there any other similar MOD ?

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Thu Aug 02, 2007 4:54 pm
by tarotamerica
I get a "Sorry, but no such user exists." message when I fill in the first field. I don't get this message filling in the added feilds.

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Sat Aug 04, 2007 12:46 pm
by tarotamerica
There is a bug that when I fill in any user in the first field I get the "sorry, but no such user exists" message.

I can send PMs successfully to multiple people so long as I leave the first field blank.

I would like to find a way to remove the first field, and bring the "Find a username" function to the second field.

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Sun Aug 05, 2007 3:24 am
by theleetbeagle
I have created a very roundabout way to bypass the problem of not being able to use the TAB key properly.

What I've done is created a new Send PM window that uses a customized (stripped down) PM form. See link below:

http://www.wtata.com/forum/images/pm.gif

As you can see, the page header is gone along with the emoticons, etc. This was necessary so that TAB'ing once brings you directly to the username field. As an afterthought, you can put all that below the submit button and it will still work. I ended up doing this with the bbCode stuff.

Here's how:

First, I copied privmsg.php to privmsg_clean.php.

Inside privmsg_clean.php find:

$template->set_filenames(array(
'body' => 'posting_body.tpl')

replace with:

$template->set_filenames(array(
'body' => 'posting_body_clean.tpl')

Then inside privmsg_clean.php I replaced all instances of

includes/page_header

with

includes/page_header_clean

I then copied includes/page_header.php to includes/page_header_clean.php

Inside includes/page_header_clean.php replace the one instance of overall_header.tpl with overall_header_clean.tpl

Then copy overall_header.tpl to overall_header_clean.tpl.

Open overall_header_clean.tpl and remove everything (or at least remove all TAB'able hyperlinks, etc.).

Hopefully you're starting to get the idea...

Edit posting_body_clean.tpl so that it tabs properly by removing anything that is TAB'able (hyperlinks, images, etc) so that your goal is by pressing TAB once you get username field. TAB twice for plus sign. TAB thrice fo username field #2 and so on.

Put a link up on your board in the form of:

http://www.yoursite.com/forum/privmsg_c ... ?mode=post

This link will point to all the newly created _clean files which will result in the image I have above.

Best of all, you get to keep your original PM window.

For a fully working demo visit my site at http://www.wtata.com/forum - register and select the template liteSilver and you can test it out.

-Nick.

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Fri Aug 17, 2007 9:13 pm
by hmartin
PupChow wrote:1) Can the little + sign be to the right of the field right from the start? Instead of popping to the right after I added in a name / added another field.
This is the way it appears to me. Please PM me a screenshot and the browser you are using.
PupChow wrote:2) When previewing, is there any way to list all the receipients' name in a single line, instead of having one line for each name?
Again, this is the behavior I'm seeing. Please send a screenshot and I'll look and see what I can do.
nims wrote: Even I am facing the same problem, I sent PM to around 2000 members on my forum to check a new feature, but only few members got PM :(
I'm sorry to hear that, I've never seen similar behavior. Did you use the ACP or the regular PM interface?
tarotamerica wrote:I get a "Sorry, but no such user exists." message when I fill in the first field. I don't get this message filling in the added feilds.
What do you have "Die on nonexistent recipient" set to in the configuration ACP?

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Fri Aug 17, 2007 10:53 pm
by tarotamerica
hmartin wrote:
tarotamerica wrote:I get a "Sorry, but no such user exists." message when I fill in the first field. I don't get this message filling in the added feilds.
What do you have "Die on nonexistent recipient" set to in the configuration ACP?
I had it set on "no" but either yes or no yields the same result.

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Tue Aug 21, 2007 1:44 am
by beggers
Before I try installying this, could someone explain how to create the list of members to send PMs to? Can you save the list for use in the future?

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Sat Sep 01, 2007 7:24 pm
by hp_solomon
Having trouble sending PMs to all users, I have an activated users of more than 25000. When I try to send PMs to all users, the page times out after a few minutes. I already set max_execution_time to 600 in php.ini but still it wasn't able to send PMs to all users. I also edited the query to send the PMs to activated accounts only.

Anyone? Please help.

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Sun Sep 02, 2007 3:41 pm
by zuker
tarotamerica wrote:There is a bug that when I fill in any user in the first field I get the "sorry, but no such user exists" message.

I can send PMs successfully to multiple people so long as I leave the first field blank.

I would like to find a way to remove the first field, and bring the "Find a username" function to the second field.
I can't make it work fine. Somethings pm's are send to a couple of users , sometimes to anothers, using the same users

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Sun Sep 02, 2007 4:47 pm
by *Capmaster*
Got it installed ...almost. The installation requires files be downloaded from another site and moved into the Javascript folder on the server. The site's inaccessible.

Why didn't you just include the files in the mod .zip file? :roll:

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Wed Sep 19, 2007 6:19 am
by nims
hmartin wrote:
nims wrote: Even I am facing the same problem, I sent PM to around 2000 members on my forum to check a new feature, but only few members got PM :(
I'm sorry to hear that, I've never seen similar behavior. Did you use the ACP or the regular PM interface?
I used ACP to send the PMs

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Tue Oct 02, 2007 7:04 am
by hungrywolf
Hello,

I am trying to install this mod using EasyMod. But it doesn't seem to install.

I am a noob and if anyone can guide me through the steps I will be most grateful.

Thanks in advance.

Regards,
Derek

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Tue Oct 02, 2007 10:48 pm
by AllanTan
I have installed this Mod but i seem to be having a problem. I can't type anything when i try to send a PM. The area for typing seems to be shaded and i can't type in it. Please help. Attached is a screenshot:

Image

By the way i have also have Advanced BBCode Box v5.1.0 installed, would there be a conflict??

Please kindly help and if there's any info needed, just let me know.

Thanks

Allan :oops:

Re: [RC2] Multiple PM Recipients 0.6.1 (MMW)

Posted: Wed Oct 10, 2007 6:14 pm
by bmay33
Hi,

I installed this mod on a heavily modded phpbb2 forum. I went back and double checked all the files for errors etc but I continue to get error messages. It sent the message through to all members that I'm aware of (I have 18 pages of the same PM in my outbox waiting on people to open it) on the forum which has almost 2500 members. I uploaded the backup files in the meantime until this can be fixed.

All users are receiving this message when trying to access their PM boxes while the new modded files are installed..
Parse error: parse error, unexpected $ in /home/content/p/i/x/pixelgirls/html/privmsg.php on line 2375
(already checked it, and its the last line of the file.. nothing but the ?> is there.

Also getting the emailer.php error that was posted earlier in this topic as well.

I installed it manually since I'm using a custom style and a heavily modded forum.
Mods installed:(most manually)
Easymod
admin userlist
admin userlist IP addon
anti-bot
dhtml menu for ACP
multi BBCode
Resize posted images based on max width
Restrict Sig Size
Announcement Center
Expire Unactivated Users
Custom FAQ
Under 13 Rejection Mod
Only Active members can post URLs

Thanks in advance for any help!