Page 4 of 5

Posted: Sun Oct 01, 2006 9:38 am
by uncle.f
Check the file"admin/admin_forums.php".
Search for the string "approval block start" inside it.

If you find it, it means your files were modified and you should see new tick boxes in the "Forum Admin - > Management -> Edit", at least.

It could also be your language file(s). By default only the English language files are modified to include new messages. Normally, EasyMOD also modifies all other languages, but with the English messages, so you have to edit files in "language/lang_*" yourself. Not sure what iEM does with regards to those files (I never used iEM). Could be the source of the problem...

Posted: Sun Oct 01, 2006 10:24 am
by dfuzion
thanks for your fast reply !!
I can find your MOD in admin/forums so I uninstalled Approval and iEM MODs to put EM + your MOD and try again... maybe it'll work.

Hope I won't have to install phpBB from scratch :(

Thanks. Come back to you later.

Jerome

Posted: Sun Oct 01, 2006 10:26 am
by Aishah
is this feautre for approval for ALL posts ever posted?

Posted: Sun Oct 01, 2006 10:46 am
by uncle.f
Aishah wrote: is this feautre for approval for ALL posts ever posted?


It is approval for all posts, yes. But it can be enabled/disabled per forum.
If you need more granularity, you'll have to wait for this to be finished :-)

Posted: Sun Oct 01, 2006 10:48 am
by Aishah
uncle.f wrote:
Aishah wrote:is this feautre for approval for ALL posts ever posted?


It is approval for all posts, yes. But it can be enabled/disabled per forum.
If you need more granularity, you'll have to wait for this to be finished :-)

The new one to come is good. okay thanks!

p.s. why does it replace some of my words with beep?

Posted: Sun Oct 01, 2006 10:49 am
by uncle.f
dfuzion wrote: Hope I won't have to install phpBB from scratch :(


Unless you can roll-back the Approval MOD with iEM, you'd HAVE to install from scratch.

Anyway, shouldn't be a big deal, since as you have mentioned you only had Approval MOD installed and no other MODs, or did I get it wrong?

Posted: Sun Oct 01, 2006 10:51 am
by uncle.f
Aishah wrote: p.s. why does it replace some of my words with beep?


I have no idea what you talking about. 8O
What is "it" and what is "beep" ? :wink:
Can you be more specific, please?

Posted: Sun Oct 01, 2006 10:56 am
by Aishah
uncle.f wrote:
Aishah wrote:p.s. why does it replace some of my words with beep?


I have no idea what you talking about. 8O
What is "it" and what is "beep" ? :wink:
Can you be more specific, please?

e.e i'll type in sland/short words and some are replaced with *beep*

e.g. i typed 'come' as c u m and it went *beep*

Posted: Sun Oct 01, 2006 10:59 am
by dfuzion
uncle.f wrote: Unless you can roll-back the Approval MOD with iEM, you'd HAVE to install from scratch.


Yes... I go from scratch again...

Posted: Sun Oct 01, 2006 11:14 am
by uncle.f
Aishah wrote: e.e i'll type in sland/short words and some are replaced with *beep*

e.g. i typed 'come' as c u m and it went *beep*


That has nothing to do with this MOD. Check your "Word Censors" option in the Admin Control Panel.

Posted: Sun Oct 01, 2006 11:17 am
by Aishah
uncle.f wrote:
Aishah wrote:e.e i'll type in sland/short words and some are replaced with *beep*

e.g. i typed 'come' as c u m and it went *beep*


That has nothing to do with this MOD. Check your "Word Censors" option in the Admin Control Panel.
no it dont happen on my forum, it happens HERE on this forum

Posted: Sun Oct 01, 2006 11:20 am
by uncle.f
Aishah wrote: no it dont happen on my forum, it happens HERE on this forum


Well, then THEY have word censoring enabled on this forum. I have no relation to this forum's management. I am the same user as you (except that I published this MOD), so I am not sure why you asking me this :-)

Posted: Sun Oct 01, 2006 11:30 am
by Aishah
lol i'm not asking. just sayin asking saying if u kno wat i mean

Posted: Sun Oct 01, 2006 1:05 pm
by dfuzion
I installed again from scratch phpbb 2.0.21 (en/fr languages) + EM 0.3.0 english. All worked fine.

I try to install Approve MOD with EM but I've these warnings :
Error Detail

Warning

FIND FAILED: In file [language/lang_french/lang_faq.php] could not find:

$faq[] = array("Why can't I vote in polls?"

MOD script line #1541 :: FAQ :: Report


Error Detail

Warning

IN-LINE FIND FAILED: In file [language/lang_french/lang_main.php] could not find:

You can lock

MOD script line #1587 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/fiappleblue/modcp_body.tpl] could not find:

<input type="submit" name="unlock" class="liteoption" value="{L_UNLOCK}" />

MOD script line #1607 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/fiappleblue/overall_header.tpl] could not find:

a.topictitle:hover

MOD script line #1620 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/fiappleblue/simple_header.tpl] could not find:

a.topictitle:hover

MOD script line #1653 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/fiappleblue/viewforum_body.tpl] could not find:

<td class="row1" width="100%"><span class="topictitle">
{topicrow.GOTO_PAGE}</span></td>

MOD script line #1682 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/fiappleblue/viewtopic_body.tpl] could not find:

<td valign="top" nowrap="nowrap">{postrow.QUOTE_IMG}

MOD script line #1699 :: FAQ :: Report


Error Detail

Warning

FIND FAILED: In file [templates/fiappleblue/admin/forum_edit_body.tpl] could not find:

<td class="row2"><select name="forumstatus">
</tr>

MOD script line #1715 :: FAQ :: Report


Do I continue with install ? How can I correct these errors ?

Jerome

Posted: Sun Oct 01, 2006 3:18 pm
by uncle.f
I thought I asked in my first post in this topic not to post long code outputs ;)

Anyway, the first warning regarding lang_faq.php can be ingored. The result of this will be that in your French FAQ there will be no new question and answer regarding the Approval. You can manually add it afterwards. Just look into the English lang_faq.php. There is only one new line in it (search for 'Approval').

The second warning regarding lang_main.php can also be ignored. What it does, it finds the variable $lang['Mod_CP_explain'] and edits the value, so that the word 'approve' is inserted like this:

Was: "You can lock..."
Became: "You can approve, lock..."

This is only needed for the moderator's control panel. Again, you can edit French lang_main.php by hand and insert the French word for "approve" where the $lang['Mod_CP_explain'] variable is.

The rest of the warnings are caused by the fact that you have additional "fiappleblue" style installed on your board. EasyMOD is trying to modify the template files for all the installed styles, but Approval MOD only "knows" the default "subSilver" style, since I cannot write MOD to fit all the possible styles out there. "fiappleblue" style is different from "subSilver" in its structure, so EasyMOD fails to locate the right points of insertion in those templates. Unfortunately, this means that you will have to edit the "fiappleblue" files by hand (using the "logic" from the "approval.mod" file) if you want it to use it with the Approval MOD.

This problem exists for all MODs that modify styles, so it is not just Approval MOD related.