[BETA] WP-United: WordPress Integration (v0.9.5 04/06/2007)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

brokenantimatter wrote: Hey John I am glad to see you are still being highly productive and I also want to add your mod has helped me tremendously...even though it is also most unrecognizable now. Somewhere around the 20th or so I will upload it to the net for you to link to.


Oops... missed this...

Thanks very much, brokenantimatter. Looking forward to seeing the site... (it seems you have quite a following waiting for launch.)
phpBB<->WordPress Integration: www.wp-united.com
User avatar
yexusbeliever
Registered User
Posts: 586
Joined: Mon Dec 08, 2003 8:49 pm
Location: Olympus phpBB3

Post by yexusbeliever »

I so glad that you made an integration for phpBB. It looks so good and to me is unbelievable sometimes looking at it. So I do like to ask you a....

Personal question:

Why did you decide to make an Wordpress integration? Did someone inspire you to just do it or you had a need for it too?
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26938
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Post by Paul »

Hello,

I has installed this mod on a server with php 5.2.0, and mysql 5, and the ACP isn't work correctly.
It gives a white page after submitting the settings page.
Possible this is because this notice:

Code: Select all

Notice: Undefined variable: wizErrorMsg in /var/www/weblogland.nl/www/forum/admin/admin_wordpress.php on line 40
That line is:

Code: Select all

$wizErrorMsg - '';
And should be(I think)

Code: Select all

$wizErrorMsg = '';
After trying some things, the problem is the next line:

Code: Select all

$uriExists = uri_exists($data['wpUri']);
(Line 1181)
The function exists, but it looks like it doesn't work correctly with php5.

EDIT: Found it, the reason is this:

Code: Select all

$curlAvail = @curl_version();
When its not avaible, this check doesn't work, you should use function_exists() instead ;)

Also, the ACP page gives this error:

Code: Select all

Fatal error: Cannot use object of type stdClass as array in /var/www/weblogland.nl/www/forum/admin/page_footer_admin.php on line 38
And the footer isn't displayed.


EDIT2:
Some small things:
When you update the roles in ACP, the already registred user doesn't get the new role.
Also, a normal user, see still links to posts that he cannot edit (He hasn't writed) and he can also not add/edit categories for his blog.
When this changes, i will use this mod possible for one of my sites.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
Yautja_cetanu
Registered User
Posts: 72
Joined: Wed Nov 24, 2004 3:23 pm

Post by Yautja_cetanu »

Unfortunately with the new version I am still getting this error:
Error! The WP-United Connection could not be installed. This is probably due to one of the following being set incorrectly: (a) invalid path to WordPress, (b) invalid script path set for phpBB in board config. Please correct these and try again.



It doesn't work in Firefox, IE 6&7 and I'm using Mysql 5.0.26 and php 5.1.6

When I click Test URL it says "testing" then there is an Error on the page and "Detect" no longer works. I get this message:
Line: 350
Char: 4
Error: Object required
Code: 0
URL: http://www.thevr.co.uk/test/everything/ ... 00b8bbb19a




----------------

On a side note. I've had an idea to help keep the blogs more fully integrated with the forums that would have been reasonably easy with the blog mod. Basically would it be possible to access blog posts easily through the forums (And view them as if they were forum posts).

We would have a "Category" called for example "Cars". When anyone makes a blog post in that category it will also get posted as a topic in a Sub-forum "Car Blogs". People can then post and discuss that post like a normal forum topic, although they will also appear as comments on the blog.

Is that your "Cross-posting between forums and blogs feature"?
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

@Yexus: Thanks very much! A bit of both really. I needed a simple integrated page (like the good doctor), and did a quick cut-and-splice to get it onto the page. There seemed to be quite a bit of interest, so I decided to formalise it. Can I add your site to my integration gallery?

@paul999 - yes, nothing to do with php5, it relies on cURL. function_exists will surely work better... (I think I ws losing the wood for the trees)

The other is well spotted but just a php notice. None of these should be installation deal-breakers, but much appreciated... will fix ahead of the next release.

The third error is new - it's due to $userdata not being set back properly. I assume that this only happens on step 5 of the wizard, right? If it happens on every step then this is unexpected.

Currently, roles are arbitrated when you visit the blog, not when you change them in the ACP. So roles are always updated ;) The links to other posts is a "feature" of wordpress... all posts are always shown. If you have set up the user roles correctly, one canot edit others' posts.. I could certainly address this, but I don't see it as a big deal. All adds to the "community" nature of the blog!

I discuss per-user categories earlier in this thread and when they will be available. Hopefully soon!

@Yautja: What have you set as your URI and path to WordPress? Would you mind PMing me so we can do some testing?
Last edited by Jhong on Tue Feb 13, 2007 12:55 am, edited 1 time in total.
phpBB<->WordPress Integration: www.wp-united.com
German_AC
Registered User
Posts: 13
Joined: Fri Aug 18, 2006 3:30 pm

Post by German_AC »

Now it works!! :D :D

I tried Easy mod but it generates an error trying to modificate functions.php file, so I went to manual installation and I got it working fine.

Thanks again Jhong for your support and patience!!
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

Great! I'm glad it works... let me know how it goes.

J
phpBB<->WordPress Integration: www.wp-united.com
link470
Registered User
Posts: 79
Joined: Fri Mar 17, 2006 11:53 am

Post by link470 »

I posted the other day about the problems I was having with installing in IIS. Still encountering the same error message unfortunately :( Keep up the good work though, I'm sure it's coming!
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

Hi Link 470... can you PM me with the path to WP and URL to WP that you are using.. .perhaps we can do some debugging to see what's going on in your case?
phpBB<->WordPress Integration: www.wp-united.com
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26938
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Post by Paul »

@Jhong, i hasn't read the complety thread, so about that per user cats i didn't know.
The fatal error happes at the end of the wizard, and after saving the settings.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
German_AC
Registered User
Posts: 13
Joined: Fri Aug 18, 2006 3:30 pm

Post by German_AC »

Well, I have the integration working perfectly. Is there any way to show new posts from forum in blog page and viceversa?

Thanks
Yautja_cetanu
Registered User
Posts: 72
Joined: Wed Nov 24, 2004 3:23 pm

Post by Yautja_cetanu »

O.k I've pmed you
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

@paul999: Thanks. the install_wpu_connection function was restoring phpBB variables to/from the wrong scope... will be fixed in the next release.

@German: Not yet. I plan to release this once I have v1.0 out the door. I'm a stron gbelieer in the "right tool for the job", hence the integration... as such, I'm not so keen on filling forums with blog posts or vice versa. But I do plan to introduce this as a feature in the future as there is demand.
phpBB<->WordPress Integration: www.wp-united.com
JustJamesAus
Registered User
Posts: 20
Joined: Thu Oct 12, 2006 11:07 pm
Contact:

Post by JustJamesAus »

Hi Jhong, I've upgraded to 8.8.7 by copying the files across, wp rss now works better but still gives this error:
XML Parsing Error: mismatched tag. Expected: </link>.
Location: http://www.meetmethere.com.au/forums/blog.php?feed=rss2
Line Number 22, Column 3:</head>
--^

If you look at the page you can see it's adding the phpbb header:
http://www.meetmethere.com.au/forums/blog.php?feed=rss2

Do you prefer bug reports here or on the wp-united site?
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

Hi James,

Thanks for the report.... I see the problem...

Will release the fix in a short while with the next version with several new features. If you need the fix urgently, feel free to let me know and I can provide the fix.

Either-or is fine for me, although I do appreciate activity on my site... :)

BTW your blog looks very nice :D

J
phpBB<->WordPress Integration: www.wp-united.com
Post Reply

Return to “[2.0.x] MODs in Development”