[BETA] WP-United: WordPress Integration (v0.9.5 04/06/2007)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

@KeithFN

1. and 2. are not happening for me, so I'm reluctant to label them as bugs just yet....

Can you check your WordPress options and tell me what you have set for
"Blog address (URI)" and "WordPress address (URI)"

Some plugins won't work if they rely on their own global variables, but most decent ones will. This will be addressed in v0.9.x

You asked wehat was on the roadmap...

v0.8.8 was a major release, so I'll be sweeping up a few bugs for a while, but I do have big plans for v0.9.0. The major changes will, time-permitting, include:

- Avatars in blogs and coments
- auto-generated, paginated list on the index page with users' blogs, names, latest posts and avatars.
- per-user post categories
- auto-generated pages -- i.e. the mod can "suggest" a multi-user index page, without you having to make any tmeplate changes....
- use of the phpBB word censor in WordPress
- ability to rename blog.php, and put it anywhere you like... (i.e. you could call it "index.php" and put it in your site root).
- contrib to show latest WP posts on ezPortal page, or similar.


Post-v0.9.0 will focus on cleaning up the mod ready for a release candidate, and providing more admin tools to help installers, and to solve problems. These are (tentatively):
- a "make compatible" tool, that will analyse your WordPress install and attempt to auto-adjust the mod so that it plays nice.
- a "WP-United Connection" diagnostic, that lets you fine-tune the connection settings.
- an update tracker, that looks for new versions of WP-United, WordPress and phpBB.

And, no doubr, many other features too....
Last edited by Jhong on Tue Jan 23, 2007 6:27 pm, edited 1 time in total.
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

P.S. there is a (small) bug whereby trailing slashes after blog.php are only removed when the WordPress page is inside the phpBB header/footer.

I will release an updated version as soon as I can -- but unfortunately I am being bitten hard by the undersea cable break as a result of the 26 Dec earthquake in Taiwan, making it very difficult fo rme to upload files and even access my own sites.... so bear with me.
Deadfire
Registered User
Posts: 17
Joined: Thu Jan 13, 2005 6:39 pm
Location: Winnipeg, MB, CAN
Contact:

Post by Deadfire »

I was about to say I hit this error message when I try to access blog.php

Code: Select all

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/******/public_html/******/forums/wp-united/wpu-plugin.php on line 582
Now that these are lines 569-600 bolded is the line that is failing


Code: Select all

//
// 	WPU_BLOGNAME
//	---------------------
//	Returns the name of the current user's blog
//
function wpu_blogname($default) {
	global $wp_query, $wpSettings, $IN_WP_ADMIN, $user_ID;
	if ( (!empty($wpSettings['usersOwnBlogs'])) || ($IN_WP_ADMIN == 1) ) {
		$wpu_change_name = FALSE;
		if ( is_author() ) {	
			$authorID = $wp_query->query_vars['author'] ; 
			$wpu_change_name = TRUE;
		} elseif ( is_single() ) {
			$authorID = $wp_query->get_queried_object()->post_author;
			$wpu_change_name = TRUE;
		} elseif ( isset($_GET['author'] )) { 
			$authorID = (integer)$_GET['author']; 
			$wpu_change_name = TRUE;
		} elseif ( $IN_WP_ADMIN == 1 ) {
			$authorID = $user_ID; 
			$wpu_change_name = TRUE;
		}
		if ( $wpu_change_name ) {
			$blog_title = get_usermeta($authorID, 'blog_title');
			if ( empty($blog_title) ) {
				$blog_title = $default;
			}
			return $blog_title;
		}
	}
	return $default;
}
the line being the one causing the error is

Code: Select all

$authorID = $wp_query->get_queried_object()->post_author;
some advice would be helpful :)
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

Hello -- this was fixed in v0.8.8.1. Are you sure you downloaded the right version? If you downloaded form the website download page, you rpobably got he wrong version .... check the first post in this thread for the proper link.

J
Deadfire
Registered User
Posts: 17
Joined: Thu Jan 13, 2005 6:39 pm
Location: Winnipeg, MB, CAN
Contact:

Post by Deadfire »

Jhong wrote: Hello -- this was fixed in v0.8.8.1. Are you sure you downloaded the right version? If you downloaded form the website download page, you rpobably got he wrong version .... check the first post in this thread for the proper link.

J


I downloaded both because I figured it may have been that..however they are the same files
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

The contents of the files are different....
Deadfire
Registered User
Posts: 17
Joined: Thu Jan 13, 2005 6:39 pm
Location: Winnipeg, MB, CAN
Contact:

Post by Deadfire »

Jhong wrote: The contents of the files are different....


oh I know they are don't get me wrong, however I downloaded from your first post the first time(http://www.wp-united.com/download/wp_united_0881.zip) because it caused me that error I detailed I tried the other one and it gave the same error so I asumed they were the same

Now to clear this up I did download from the link on the first post which is what gave me that error(that currently doesn't work now...)

I'm sorry if this doesn't make sense but I've only followed what you wanted me too.
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

You're right -- it looks like I hav emade a ***-up with the files... things are difficult when I can't even access my own server ;)

I'll update in a few hours.....
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

OK -- v0.8.8.2 released!

Please download from the first page of this thread!
Last edited by Jhong on Thu Jan 25, 2007 1:33 am, edited 1 time in total.
JustJamesAus
Registered User
Posts: 20
Joined: Thu Oct 12, 2006 11:07 pm
Contact:

Post by JustJamesAus »

Awesome mod, absolutely beautiful. However, the latest release on the WordPress homepage is 2.1 - I'm doing a new install of WordPress so should I go for a previous release (2.0.x) or are you planning to update this mod to work with 2.1? No pressure, just thinking that if I install 2.0.x then I'll have to upgrade that and this mod in the near future...

What are your thoughts?
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

I haven't yet tested with 2.1 -- I haven't been able to download it!!!

It should work just fine, but I do need to test... maybe someone closer to Asia wants to host a WP 2.1 download for me?

But feel free to try, and PM me your experience with it.
Yautja_cetanu
Registered User
Posts: 72
Joined: Wed Nov 24, 2004 3:23 pm

Post by Yautja_cetanu »

I'm wondering, are you planning a phpbb3 version? I'm guessing converting your mod to phpbb3 will be fairly extensive?
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

Yautja_cetanu wrote: I'm wondering, are you planning a phpbb3 version? I'm guessing converting your mod to phpbb3 will be fairly extensive?


Yes, I certainly am.

One will be available after phpBB3 hits RC stage. There are a number of features (e.g. cross-posting between blogs and forums) that I'm holding back until then.
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

Post by Jhong »

Small bug that will be fixed in the next release:

A PHP warning could be presented on Step 5 of the Wizard on a fresh install of WordPress.

In the meantime, you can safely ignore it...

J
User avatar
Jhong
Registered User
Posts: 538
Joined: Thu Aug 10, 2006 6:53 pm
Location: In a theme sandwich
Contact:

v0.8.8.3 released!

Post by Jhong »

Version 0.8.8.3 released!

Changes:

-- Minor change to make it compatible with WordPress 2.1 (and below)
-- Improved (again) setting of Blog URI (now includes http:)
-- FIXED: Non-fatal error when installing WP-United Connection on a new WordPress install

To upgrade from a previous 0.8.8.x, just coipy over the new fileset and run through the Setup Wizard again.

Download on the first page!

J
phpBB<->WordPress Integration: www.wp-united.com
Post Reply

Return to “[2.0.x] MODs in Development”