[RC2] Statistics Mod 4.2.9

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply
User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Sun Dec 03, 2006 1:54 pm

---

King_S
Registered User
Posts: 7
Joined: Fri Dec 01, 2006 4:54 pm
Location: Simmerath

Post by King_S » Sun Dec 03, 2006 2:49 pm

@Wicher: Here is the Download Link:
AdInfinitum:
http://www.phpbb.de/moddb/download.php?id=187
I hope, you can help me ;)
King_S uses Bablefish to translate :D

User avatar
bum63
Registered User
Posts: 262
Joined: Tue Oct 10, 2006 8:36 pm

Post by bum63 » Sun Dec 03, 2006 2:54 pm

Hey Wicher
I installed this latest version v4.0.1d and everything works fine except 1 pack which is Gender, when I install Gender pack and click on stats all I get is page which says Gender pack by Niles and nothing more statistics page doesn't work at all so I installed older pack from version v4.0.1 and this one works but displays wrong number of male and female members
link

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Sun Dec 03, 2006 7:36 pm

bum63 wrote: Hey Wicher
I installed this latest version v4.0.1d and everything works fine except 1 pack which is Gender, when I install Gender pack and click on stats all I get is page which says Gender pack by Niles and nothing more statistics page doesn't work at all so I installed older pack from version v4.0.1 and this one works but displays wrong number of male and female members
link


There are two gender modules in this version, one for evils gender mod and one for niels gender mod.

If neither one of them are working properly, i suspect you are having a gender mod from some one else installed.
Look wich one you have installed and activate that one, and deactivate the other one.

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Sun Dec 03, 2006 7:37 pm

King_S wrote: @Wicher: Here is the Download Link:
AdInfinitum:
http://www.phpbb.de/moddb/download.php?id=187
I hope, you can help me ;)

I'll see what i can do.

User avatar
bum63
Registered User
Posts: 262
Joined: Tue Oct 10, 2006 8:36 pm

Post by bum63 » Sun Dec 03, 2006 8:14 pm

I use the first original I guess that's Niles Gender mod I mean it worked in older version of this mod, and I don't have them mixed up because I deleted evils gender mod from modules list: yes it is Niles mod

Code: Select all

## MOD Title:          Gender
## MOD Author:         Niels < ncr@db9.dk > (Niels Chr. Rød) http://mods.db9.dk
## MOD Description:    This mod will add a Gender field into
##                     users' profile, and display "Gender: |image|"
##                     in posts too. 
## MOD Version:        1.2.8

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Sun Dec 03, 2006 9:07 pm

@King_S: i looked at the files, but i dont know why its not showing the bars.
AdInfinitum has some very different css styles in it then subSilver.
Maybe that is what the problem here.
Perhaps you can contact the author of AdInfinitum and ask him what to do in this case.

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Mon Dec 04, 2006 9:54 am

I uploaded an updated last_created_topics.pak, i hope now its fixed.

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Mon Dec 04, 2006 9:57 am

bum63 wrote: I use the first original I guess that's Niles Gender mod I mean it worked in older version of this mod, and I don't have them mixed up because I deleted evils gender mod from modules list: yes it is Niles mod

Code: Select all

## MOD Title:          Gender
## MOD Author:         Niels < ncr@db9.dk > (Niels Chr. Rød) http://mods.db9.dk
## MOD Description:    This mod will add a Gender field into
##                     users' profile, and display "Gender: |image|"
##                     in posts too. 
## MOD Version:        1.2.8


Did you allready download the updated gender paks from the module list in the first post?

MarieMM
Registered User
Posts: 42
Joined: Wed Nov 29, 2006 10:03 pm
Contact:

Post by MarieMM » Mon Dec 04, 2006 10:08 am

Wicher wrote: I uploaded an updated last_created_topics.pak, i hope now its fixed.


You're getting closer!

It now does not display topics from hidden forums to users that are not logged in. But it does display them to users that ARE logged in, even though they do not have access to those forums.

Also, the time that the topic was started does not display when you're not logged in.

This is the situation both when I reload the statistics page as Admin, and as anonymous.

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Mon Dec 04, 2006 2:21 pm

I uploaded new version last_created_topics.pak again.
Time thing is fixed.

For the rest i am a bit puzzled because at my testboard it works all oke now.

http://www.detecties.com/TestphpBB

If you want you can register there, and then i can make you admin so you can also take a look at the forum permissions and what ever you want to look at.
user test with password test is a normal registered user.

MarieMM
Registered User
Posts: 42
Joined: Wed Nov 29, 2006 10:03 pm
Contact:

Post by MarieMM » Tue Dec 05, 2006 8:40 am

1. I found the problem with the moderators vs registered vs anonymous. The registered user that I was testing with, was actually set as moderator for one hidden forum. When I removed this status, the modules were hidden or shown as they should. My mistake, I'm sorry! However, is it possible to define moderators as those given the moderator rank/belonging to the moderator group, rather than those being moderator for one or several forums?

2. Displaying posts from hidden forums to anonymous users:
Does this have something to do with the modules being set to reload every 0 minutes? Does that mean that it reloads every time a user loads the page? I tried setting the problematic modules to reload evert 0 minutes, and now the hidden posts are only shown to those who should see them. My modules were set to reload every 360 minutes (perhaps by myself), I didn't understand this connection until now. If this is how it is intended, it might be a good idea to write somewhere that these modules must be set to reload every 0 minutes in order to display correct data.

Finally: I have installed another MOD that allows moderators to create topics to be posted automatically at a later time. The "posted date" of these topics is in the future, i.e. Dec-17-2006. Is it possible for your statistics to display topics that are posted "now" or earlier, only? For some reason these "topics from the future" are not displayed among the least popular topics for regular users (only to moderators), while they ARE displayed among the latest topics and posts (to all users). I realise that this could be a problem with the other MOD, so perhaps it isn't something you can or wish to solve.

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Tue Dec 05, 2006 12:56 pm

1 wrote: Since there is no moderater group standard in phpbb this is not a possibility. Standard there are no groups at all.
2 wrote: Older versions of this module all had set the update time to 360.
It should be no problem to have that at 360 because after 360 minutes the cache should be refreshed with new data.
3 wrote: This i dont know, i should have to see the mod before i can answer that. Maybe you have a download link for me?


Ps: i made you admin at my testboard.

MarieMM
Registered User
Posts: 42
Joined: Wed Nov 29, 2006 10:03 pm
Contact:

Post by MarieMM » Tue Dec 05, 2006 5:35 pm

1. OK, thanks.

2. Well, when I set it to 360 minutes, the posts from the hidden forums are shown to all members if the statistics page first was reloaded by a moderator. When I set it to 0 minutes, it reloads every time the page is loaded and so displays only the correct posts.

3. http://www.phpbb.com/phpBB/viewtopic.php?t=27036

User avatar
Wicher
Registered User
Posts: 1806
Joined: Wed May 07, 2003 10:33 pm
Location: Netherlands or Holland, your choice..
Contact:

Post by Wicher » Tue Dec 05, 2006 8:27 pm

MarieMM wrote: 2. Well, when I set it to 360 minutes, the posts from the hidden forums are shown to all members if the statistics page first was reloaded by a moderator. When I set it to 0 minutes, it reloads every time the page is loaded and so displays only the correct posts.


I updated the modules, all 7, along with lang_admin_statistics.php also downloadable in first post.

Post Reply

Return to “[2.0.x] MODs in Development”