[BETA] WYSIWYG - Rich Text Editor for posting HTML message

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
tomhead
Registered User
Posts: 3
Joined: Fri Mar 30, 2007 11:33 am

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by tomhead »

Bug when QUOTE a messagge or private message. Please help me. Thanks.

tomhead
Registered User
Posts: 3
Joined: Fri Mar 30, 2007 11:33 am

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by tomhead »

The text editor not visible when QUOTE the message or private message. The error is of javascript can you see in attachment. please help me. thank you.
Attachments
Rich Text Editor :: bug
Rich Text Editor :: bug
editor.gif (11.35 KiB) Viewed 2491 times

techiesbox.com
Registered User
Posts: 4
Joined: Thu Mar 22, 2007 12:31 am

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by techiesbox.com »

Hey Guyz,
Any one here to help me out from the same probs?? I Installed Hoteditor in my site that is http://www.techiesbox.com and getting the same problem of Images and Smilies.

I installed HotEditor on my FTP and did the correct installation as per the Installation Guide provided my ecardmax. Also the result was "Successfully Installed.

Problem:

When attaching the URL to insert a image in the text editor provided by hoteditor it shows the Image or Smiley in the Text box, but if we click on [Submit] or [Preview], The Images will disappear after submitting the post or even seeing the preview. It seems like something wrong in the path of the coding part in some PHP file.

I also contacted Tech Person from ecardmax by raising the Ticket there. a guy name anthony visited my site that is http://www.Techiesbox.com and checked the problem and asked me to reinstall the Editor. I did the installation twice and again i did the fresh installation and did the changes about the code like mentioned above. But no good results. its still the same.

The BIG problem i am facing is... even after uninstalling the editor (Hoteditor) and when i am trying to post a topic its only showing the [Subject] bar. Nothing elz!! Whats this problem again?? donno why this hoteditor is acting strange??? i did not done anything wrong with these ppl ... lol then why they are wasting my time??. Even HOTEDITOR ppl cant give the solution of this problem. They are still in confusion.

Plzzz Guyz. Help me Out. My time is wasting in clearing the bugs in ma site.

Want to check the problem? just visit me at http://www.techiesbox.com and try to post a topic as test in "Bugs 'n' Errors" Category. Any guest can Post in that Category.

Plz Help me Out.

Thanks in Advance.
ZED

User avatar
Bicalho
Registered User
Posts: 10
Joined: Mon Apr 02, 2007 9:36 pm

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by Bicalho »

Looks promissing!Will the next version have Youtube and Google Videos buttons?

mamylo
Registered User
Posts: 4
Joined: Wed Apr 11, 2007 11:15 pm

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by mamylo »

Hi everybody
I have a problem installing this mod
After installing, when i want to login to my ACP, it show an error about extension.inc
Can anybody help me?

User avatar
vbbgold
Registered User
Posts: 31
Joined: Sat Feb 19, 2005 2:45 am

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by vbbgold »

tomhead wrote: The text editor not visible when QUOTE the message or private message. The error is of javascript can you see in attachment. please help me. thank you.

I have the same problem.

When QUOTE or EDIT, some posts are not appear, just the title.

novazoo
Registered User
Posts: 1
Joined: Thu May 03, 2007 7:49 pm

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by novazoo »

Im sad because PHPBB have no wysiwyg text editor by default.
Im trying this HotEditor but i found some bugs installing this mod.

Click in "Edit post" and see, there is no message.
Sometimes the hotEditor doesnt appears too.
But the message is there, in someplace.
If you do not edit the "blank" space and try "preview"..
you finally can edit your message.

noob users doesnt understand these bugs.
They´re erasing all messages trying to edit these.

PHPBB version 3 ill come with a wysiwyg text editor?
Someone know how fix this bug?

thank's by the way! =)

User avatar
eCardMax.com
Registered User
Posts: 61
Joined: Thu Jan 01, 2004 11:10 am
Contact:

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by eCardMax.com »

Hello guys!

HotEditor Version 4.1 was released couple days ago. We improved a lot of things on this version. The best part of it is the feature built in HTML to BBCode and BBCode to HTML converter. That means when user design their post by using WYSIWYG Editor, Hoteditor will output the clean BBCode (it will auto correct the missing tag as well).

The link below will let you see Hoteditor V.4.1 DEMO
http://www.ecardmax.com/hoteditor/index.html

And here you can see Hoteditor V.4.1 with phpBB 2.0.22:
http://www.ecardmax.com/phpbb_2022/index.php

Another best thing is it will take you from 3 to 5 minutes to integrate Hoteditor V.4.1 to phpBB 2.0.22.
Download the new MOD here:
http://www.ecardmax.com/index.php?step=Hoteditor2phpbb

Regards,

nuzzosono
Registered User
Posts: 45
Joined: Sun May 28, 2006 9:38 am

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by nuzzosono »

what about the html button?

How does it work?

(i need to integrate some html code from radioblog)

tfinry
Registered User
Posts: 32
Joined: Sat Jun 10, 2006 10:20 pm
Contact:

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by tfinry »

eCardMax.com wrote: Hello guys!

HotEditor Version 4.1 was released couple days ago. We improved a lot of things on this version. The best part of it is the feature built in HTML to BBCode and BBCode to HTML converter. That means when user design their post by using WYSIWYG Editor, Hoteditor will output the clean BBCode (it will auto correct the missing tag as well).

The link below will let you see Hoteditor V.4.1 DEMO
http://www.ecardmax.com/hoteditor/index.html

And here you can see Hoteditor V.4.1 with phpBB 2.0.22:
http://www.ecardmax.com/phpbb_2022/index.php

Another best thing is it will take you from 3 to 5 minutes to integrate Hoteditor V.4.1 to phpBB 2.0.22.
Download the new MOD here:
http://www.ecardmax.com/index.php?step=Hoteditor2phpbb

Regards,



very nice work
the new editor is great now all the new topics will be in BBcode.

but i want to upgrade from ver3 to ver4.1 is that possible ??

Crazy-S
Registered User
Posts: 138
Joined: Wed Feb 07, 2007 12:41 am
Contact:

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by Crazy-S »

Is there A way I Can download the file and use without registering to your site?
Visit Crazy-Software.com for some great personalized gift making software!

Like Personalized candy Wrappers? Then visit Our Community

Peter77sx
Registered User
Posts: 3259
Joined: Wed Nov 09, 2005 2:51 pm

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by Peter77sx »

...

edinburgh
Registered User
Posts: 4
Joined: Tue Mar 20, 2007 4:20 am

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by edinburgh »

I' ve installed WYSIWYG - Rich Text Editor mod ver 4.1 with phpBB ver2.01

Everything is fine except the selected font...

I don't have language pack for my mother language

so i just used .ttf in my forum

But ,when I select my font, it doesn't appear correctly on the post..

why???

Thanks...

BE,Edin

P.S what's the difference between free and full version...what are the benefits????

psychopath_NL
Registered User
Posts: 13
Joined: Fri Jan 26, 2007 10:08 pm

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by psychopath_NL »

:cry: i cant install it cause the changes that i have to be make in overall_header cannot be done cause the files that i have to edit aren't there like in de subsilver header.

My header looks like this

Code: Select all

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html dir="{S_CONTENT_DIRECTION}">
<head>
<meta http-equiv="Content-Type" content="text/html; charset={S_CONTENT_ENCODING}">
<meta http-equiv="Content-Style-Type" content="text/css">
{META}
{NAV_LINKS}
<title>{SITENAME} :: {PAGE_TITLE}</title>
<link rel="stylesheet" href="templates/lpch_gta/{T_HEAD_STYLESHEET}" type="text/css">

<!-- BEGIN switch_enable_pm_popup -->
<script language="Javascript" type="text/javascript">
<!--
	if ( {PRIVATE_MESSAGE_NEW_FLAG} )
	{
		window.open('{U_PRIVATEMSGS_POPUP}', '_phpbbprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');;
	}
//-->
</script>
<!-- END switch_enable_pm_popup -->
</head>

<body bgcolor="#000000" text="{T_BODY_TEXT}" link="{T_BODY_LINK}" vlink="{T_BODY_VLINK}">

<a name="top"></a>

<table width="820px" cellspacing="0" cellpadding="10" border="0" align="center"> 
	<tr> 
		<td class="bodyline">
		<center>
<table width="800px" border="0" cellpadding="5" cellspacing="0">
	<tr>
		<td>
<div style="width: 800px; background-color: #000000;">
<center>
<a href="{U_INDEX}"><img src="templates/lpch_gta/images/banniere.jpg" border="5" alt="{L_INDEX}" style="border-color:#000000;" /></a>
<a href="{U_FAQ}" class="blanc">{L_FAQ}</a>
&nbsp;&nbsp;&nbsp;&nbsp;<a href="{U_SEARCH}" class="blanc">{L_SEARCH}</a>
&nbsp;&nbsp;&nbsp;&nbsp;<a href="{U_MEMBERLIST}" class="blanc">{L_MEMBERLIST}</a>
&nbsp;&nbsp;&nbsp;&nbsp;<a href="{U_GROUP_CP}" class="blanc">{L_USERGROUPS}</a>
&nbsp;&nbsp;&nbsp;&nbsp;<a href="{U_PROFILE}" class="blanc">{L_PROFILE}</a>
&nbsp;&nbsp;&nbsp;&nbsp;<a href="{U_PRIVATEMSGS}" class="blanc">{PRIVATE_MESSAGE_INFO}</a><br>
<a href="{U_LOGIN_LOGOUT}" class="blanc">{L_LOGIN_LOGOUT}</a>
&nbsp;&nbsp;&nbsp;&nbsp;<a href="{U_REGISTER}" class="blanc">{L_REGISTER}</a>
</center>
</div>

		<br />
So what do i do now?

User avatar
yexusbeliever
Registered User
Posts: 586
Joined: Mon Dec 08, 2003 8:49 pm
Location: Olympus phpBB3

Re: [BETA] WYSIWYG - Rich Text Editor for posting HTML message

Post by yexusbeliever »

excellent mod! Keep up the good work! :)

Post Reply

Return to “[2.0.x] MODs in Development”