[MODDB] ACP Site Announcement Centre v1.2.3

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Post by lefty74 » Wed Mar 07, 2007 10:42 pm

would you sending me or linking your index.php file here?
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

squeek
Registered User
Posts: 173
Joined: Sat Jan 20, 2007 12:43 am

Post by squeek » Wed Mar 07, 2007 10:52 pm

i sent it to you in PM :)

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Post by lefty74 » Wed Mar 07, 2007 11:08 pm

great, thanks :)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

squeek
Registered User
Posts: 173
Joined: Sat Jan 20, 2007 12:43 am

Post by squeek » Thu Mar 08, 2007 12:12 am

you were right, i removed the section from the install file where it tries to install the part:

Code: Select all

include($phpbb_root_path . 'includes/bbcode.'.$phpEx); 
and then reinstalled the MOD and now it works 100% this is a super MOD and it's just what im looking for :) thank you

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Post by lefty74 » Thu Mar 08, 2007 12:31 am

thats great, glad it works now and you like it.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by lefty74 » Mon Mar 19, 2007 10:01 pm

updated to v1.1.1

now includes preview (many thanks to eviL<3 for allowing me to use his code for bbcode.php)

Put it back to BETA as some people have experienced a problem with the redirect I use in the admin_announcement_centre.php.

The quick fix for that is
FIND

Code: Select all

if( isset($HTTP_POST_VARS['preview']) )
   {
         $sql = "UPDATE " . ANNOUNCEMENTS_LEFTY74_TABLE . " SET
            announcement_value = '" . str_replace("\'", "''", $new[announcement_text_draft]) . "'
            WHERE announcement_desc = 'announcement_text_draft'";
                        
         if( !$db->sql_query($sql) )
         {
            message_die(GENERAL_ERROR, "Failed to update general configuration for announcement_text_draft", "", __LINE__, __FILE__, $sql);
         }
         redirect(append_sid("admin/admin_announcement_centre.$phpEx"));
   } 
REPLACE WITH

Code: Select all

if( isset($HTTP_POST_VARS['preview']) )
   {
         $sql = "UPDATE " . ANNOUNCEMENTS_LEFTY74_TABLE . " SET
            announcement_value = '" . str_replace("\'", "''", $new[announcement_text_draft]) . "'
            WHERE announcement_desc = 'announcement_text_draft'";
                        
         if( !$db->sql_query($sql) )
         {
            message_die(GENERAL_ERROR, "Failed to update general configuration for announcement_text_draft", "", __LINE__, __FILE__, $sql);
         }
         //redirect(append_sid("admin/admin_announcement_centre.$phpEx"));
   }
   if( isset($HTTP_POST_VARS['preview']) )
   {
      $message = $lang['Preview'] . "<br /><br />" . sprintf($lang['Click_return_announcement'], "<a href=\"" . append_sid("admin_announcement_centre.$phpEx") . "\">", "</a>") . "<br /><br />" . sprintf($lang['Click_return_admin_index'], "<a href=\"" . append_sid("index.$phpEx?pane=right") . "\">", "</a>");
      message_die(GENERAL_MESSAGE, $message);
   }

cheers
       
I have not figured out why it works for some and not for others, if you have any idea I am all ears ;-)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

Jayci
Registered User
Posts: 2
Joined: Mon Apr 02, 2007 3:57 pm

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by Jayci » Mon Apr 02, 2007 4:01 pm

I came across the below error when installing your mod. I'm sure that I have made the 2 changes to bbcode.php as mentioned in the readme file.

Code: Select all

Parse error: parse error, unexpected T_VARIABLE in /homepages/3/d198523632/htdocs/phpBB2/includes/bbcode.php on line 767
Any help would be appreciated !
Thanks,

mr.wood
Registered User
Posts: 10
Joined: Tue Mar 27, 2007 3:06 pm

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by mr.wood » Mon Apr 02, 2007 6:05 pm

Works Great! Thanks a lot Lefty

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by lefty74 » Mon Apr 02, 2007 6:55 pm

Jayci wrote: I came across the below error when installing your mod. I'm sure that I have made the 2 changes to bbcode.php as mentioned in the readme file.

Code: Select all

Parse error: parse error, unexpected T_VARIABLE in /homepages/3/d198523632/htdocs/phpBB2/includes/bbcode.php on line 767
Any help would be appreciated !
Thanks,

Hi Jayci,

not sure out of the top of my head, could you paste the lines of code around line 767 please?
Or you could send me your bbcode.php file.
Whichever you prefer.
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by lefty74 » Mon Apr 02, 2007 6:56 pm

mr.wood wrote: Works Great! Thanks a lot Lefty


you are welcome, glad you like it :)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

User avatar
Duvaren
Registered User
Posts: 56
Joined: Mon Jan 22, 2007 8:50 am

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by Duvaren » Mon Apr 02, 2007 7:00 pm

Nice mod, I think I'll be installing this once it comes out of beta.

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by lefty74 » Mon Apr 02, 2007 8:12 pm

Duvaren wrote: Nice mod, I think I'll be installing this once it comes out of beta.

Hi, thanks,
that might take a while. Version 1.0.0 was submitted end of February, then the phpbb site was down so your guess is as good as mine when or if this gets validated :)

I can say tho it works on my site and I have seen it work at others.

The only reason I put this back from RC to beta as I got 2 reports where the preview showed errors. I included a fix which is not as nice as the original redirect but for the time being this solves the problem...

Up to you if you want to wait ;)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

Jayci
Registered User
Posts: 2
Joined: Mon Apr 02, 2007 3:57 pm

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by Jayci » Mon Apr 02, 2007 10:32 pm

lefty74 wrote:
Jayci wrote: I came across the below error when installing your mod. I'm sure that I have made the 2 changes to bbcode.php as mentioned in the readme file.

Code: Select all

Parse error: parse error, unexpected T_VARIABLE in /homepages/3/d198523632/htdocs/phpBB2/includes/bbcode.php on line 767
Any help would be appreciated !
Thanks,

Hi Jayci,

not sure out of the top of my head, could you paste the lines of code around line 767 please?
Or you could send me your bbcode.php file.
Whichever you prefer.


Thanks for the quick response Lefty. Its all good now : ) I missed a '.' when making changes to bbcode.php file :razz:

User avatar
lefty74
Registered User
Posts: 3649
Joined: Wed Sep 14, 2005 8:26 pm
Location: NL
Contact:

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by lefty74 » Mon Apr 02, 2007 10:38 pm

Jayci wrote: Thanks for the quick response Lefty. Its all good now : ) I missed a '.' when making changes to bbcode.php file :razz:


excellent, glad you got it to work :)
lefty74
zoocrew.eu - help us save our wildlife
My MODS | Due to lack of time I unfortunately am unable to work on my mods anymore, anyone who has ideas to improve them and would like to take any of them over, please PM me.

Coroner
Registered User
Posts: 123
Joined: Sat Sep 16, 2006 3:48 am
Contact:

Re: [BETA] ACP Site Announcement Centre v1.1.1

Post by Coroner » Tue Apr 03, 2007 12:19 pm

Thanks for directing me here! Very nice mod. Works great! Is there an easy way to remove the word "Site" from the header? I would rather have it simply say "Announcements"?

Please let me know!

Thanks!

Locked

Return to “[2.0.x] MODs in Development”