Page 20 of 22

Posted: Tue Mar 25, 2003 12:47 am
by Wagz
Oops, I figured out #2. Still have no clue about problem #1, though.

Thanks!
Wagz

Posted: Tue Mar 25, 2003 9:10 pm
by Thoul
Wagz wrote: 1. The phpBBIM link did not appear in the "General" area of the Administration Panel.


You might be looking in the wrong place. There should be a link in the User area, but not the General area. If you click Configuration under General and scroll to the bottom of that page, you should find a phpBB IM section down there.

Posted: Wed Mar 26, 2003 2:35 am
by Wagz
Thoul wrote:
Wagz wrote:1. The phpBBIM link did not appear in the "General" area of the Administration Panel.


You might be looking in the wrong place. There should be a link in the User area, but not the General area. If you click Configuration under General and scroll to the bottom of that page, you should find a phpBB IM section down there.


Ahhhh... that was it. Thanks much! Great Mod, Thoul!

Posted: Thu Mar 27, 2003 12:25 am
by Thoul
Hey everybody, I've started a poll (in my own forums, since the rules here say one topic a mod) about a feature I'm thinking about adding: sending IMs to users on other forums. You can find the poll here (no registration required to vote, so don't worry about that). The results will determine whether or not the feature is added.

Posted: Fri Mar 28, 2003 3:00 am
by khisanthax
out of curiousity, has anyone got this to work with a style other than subsilver?

Posted: Sun Mar 30, 2003 4:28 pm
by Shadow aok
yes, i have tryed with subsilver, fisubgreen, fiblack, smartDark and BlueDim

Posted: Sun Mar 30, 2003 9:44 pm
by Thoul
Version 0.5.6 Beta is now available from the site linked in the first post. It's got a few more BID List enhancements, but the most important changes are aimed at fixing some of the style problems people have had. Some files have been moved and/or split and the messenger can now use a different style than the rest of the forum. I also found a way to cut down on the duplicate smilies in the drop down list, so that's in this version too.

[Note: Several days after 0.5.5 was released, I found that the link to it on the site wasn't updated! This was fixed, but if anyone tried to get 0.5.5 and got 0.5.4 instead, that's why.]

Posted: Thu Apr 03, 2003 3:34 am
by khisanthax
I'm gonna love trying this out, thank you!

error

Posted: Thu Apr 03, 2003 10:47 pm
by teste87
I installed Ok this MOD, but when I click on Buddy Managemnet (bid.php) I receive the error Notice: Undefined variable: mode in c:\inetpub\wwwroot\FM204.2.10\bid.php on line 32

and in admin cp when I click in phpBB IM it doesn' t appears nothing .. I mean only appears look up user table, but withou any names or texts ... and the fields on the right .. why?

Posted: Thu Apr 03, 2003 11:33 pm
by khisanthax
I got this error when I clicked on buddy management:

phpBB : Critical Error

Could not get buddy list

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax near ' 50' at line 6

SELECT buddy.buddy_id, buddy.alert, buddy.alert_status, u.username FROM phpbb_buddy_list buddy, phpbb_users u WHERE buddy.user_id = 2 AND buddy.disallow = 0 AND buddy.user_ignore = 0 AND buddy.buddy_id = u.user_id ORDER BY u.username LIMIT , 50

Line : 160
File : /home/virtual/site48/fst/var/www/html/Forum/mods/bid/functions_bid.php

also, I still have the problem with the text, where it is white and the background of the field is white.

And I have two sets of settings in the admin panel that are blank, but I think that's more my fault

Re: error

Posted: Fri Apr 04, 2003 12:34 am
by Thoul
teste87 wrote: I installed Ok this MOD, but when I click on Buddy Managemnet (bid.php) I receive the error Notice: Undefined variable: mode in c:\inetpub\wwwroot\FM204.2.10\bid.php on line 32


Ok, here's a quick fix for this: open bid.php and find the line that reads define('IN_BUDDY', true);. On the next line, add $mode = '';.
teste87 wrote: and in admin cp when I click in phpBB IM it doesn' t appears nothing .. I mean only appears look up user table, but withou any names or texts ... and the fields on the right .. why?


Since the error message above contains "FM204.2.10," I'm guessing you're using FullyModded phpBB? It probably has the Enhanced Admin Lookup mod installed, which causes that problem. You can fix it by downloading phpBB IM (see links in the first post), unzipping it, and replacing your admin_im_users.php file with the file of the same name in the custom/ directory.

khisanthax:
Let's see if this will fix the first error: In bid.php, find this line:

Code: Select all

$start = ( isset($HTTP_GET_VARS['start']) ) ? intval($HTTP_GET_VARS['start']) : 0;
And replace it with this line:

Code: Select all

$start = ( isset($HTTP_GET_VARS['start']) ) ? intval($HTTP_GET_VARS['start']) : '0';
By the way, which settings were blank, if you remember?

Posted: Fri Apr 04, 2003 12:56 am
by khisanthax
okay, I still have the same problem as before when I go to buddy management, but what i noticed is that I can see the text in subsilver and phpxp2, however when I went to change the style I noticed that after I changed from one theme to another that the preference link was gone in the IM window no matter how many times I refreshed or exited the site and came back. odd.

Re: error

Posted: Fri Apr 04, 2003 1:11 am
by teste87
Since the error message above contains "FM204.2.10," I'm guessing you're using FullyModded phpBB? It probably has the Enhanced Admin Lookup mod installed, which causes that problem. You can fix it by downloading phpBB IM (see links in the first post), unzipping it, and replacing your admin_im_users.php file with the file of the same name in the custom/ directory.


The first problem is fixed... tnx very much ...

but the second continues .. i have already installed 0.5.6, the same of your first page link, but the bug remains...

Yes, i am using FM :lol:

Do you know why? :roll:

Send IM's just to one user....

Posted: Mon Apr 07, 2003 12:18 am
by iq3d
Hi

Great mod!
I am thinking of using it to allow visitors to my site to send me messages if I am online - rather than allowing them to chat between themselves. The messenger would then effectively become an instant enquiry box. Is this possible or has anyone done a mod to simplify everything down to this level?

Many thanks
Chris

Posted: Mon Apr 07, 2003 12:43 am
by Thoul
Sorry about not replying faster. I never got an email from the board telling me someone had posted here, so I didn't check the board for a few days. :oops:

khisanthax:
Okay, I'll have to take a closer look at the buddy management problem later, though I do have some ideas for fixing that. The preferences link thing is very weird, but I'll look into that, too.

teste87:
FM seems to include a mod that is causing the problem. If you look at phpBB IM's custom/lookup.txt, it tells how to fix the problem.

iq3d:
I don't know if anyone's done it, but it should be fairly easy to make that work. I'm guessing you wouldn't need the buddy list stuff in that case?