[DEV] Pafiledb [DOWNLOAD MOD] 0.0.9d

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
Mohd
Registered User
Posts: 263
Joined: Mon Jul 15, 2002 9:06 pm
Contact:

Post by Mohd »

Lucas1510 wrote: Hi Odin-NMA,

thank you for your answer.

The Problem, I have, is that the Admin-files are not showing in Admin-CP, from pafildb I see only the following:
  • Download
    • Cat manage title
    • File manage title
    • Befugnisse (Permissions)
And these entries (?) are missing (I looked into the code of the php-files):
  • admin_pa_license.php?license=add
    admin_pa_license.php?license=edit
    admin_pa_license.phplicense=delete

    admin_pa_settings.php

    admin_pa_ug_auth.php?mode=user
    admin_pa_ug_auth.php?mode=group

    admin_pa_fchecker.php

    admin_pa_custom.php?mode=add
    admin_pa_custom.php?mode=edit
    admin_pa_custom.php?mode=delete
But I can call the files: for example http://www.forum4winde.de/admin/admin_pa_settings.php works :?

Do you have an idea, why the entries (?) are missing? I uploaded all admin-files from the zip.

Lucas


you forgot to edit the file admin/index.php
see the install.txt
Visit My Site Mohd Web Site!
My Current mod is PaFileDb Integration 0.0.8
Demo: Click Here
No support via PM
MarK0
Registered User
Posts: 56
Joined: Fri Jan 09, 2004 6:42 am

Hello

Post by MarK0 »

Hello ... Nice mod ..

but there is something u 4 get to add ...


1- if we need to add some Theme for sell and price and put the link for the paypal or the html they give us .. .. it will be complate download there is some stuff need to add .. i dont no what do u think .. :D :wink:
User avatar
Lucas1510
Registered User
Posts: 47
Joined: Thu Sep 04, 2003 12:07 am
Location: Herne - Germany
Contact:

Post by Lucas1510 »

Mohd wrote: you forgot to edit the file admin/index.php
see the install.txt
Yes, that´s it. I edited all files but I forgot to edit admin/index.php.

Thank you :D
Odin-NMA
Registered User
Posts: 63
Joined: Wed Aug 28, 2002 11:18 am
Location: Valhalla
Contact:

Post by Odin-NMA »

Mohd, any idea why I can't make my mod work in the search results and stats results ? I even tried to add the F_I to those modules yet it didn't do anything..

Oh and how's work on this mod coming along ?
soz
Registered User
Posts: 25
Joined: Tue Feb 10, 2004 5:29 pm

Post by soz »

soz wrote:

Code: Select all

Couldnt add the settings into the database 

DEBUG MODE 

SQL Error : 1136 Column count doesn't match value count at row 1 

INSERT INTO phpbb_pa_cat VALUES('NULL', 'a', 'a', '0', '0', '0', '0') 

Line : 67 
File : /home/studentf/public_html/phpBB2/admin/admin_category.php
I get that error when ever i try and add a new catergory!


anyone?
Fearless
Registered User
Posts: 664
Joined: Mon Mar 31, 2003 6:16 am

Post by Fearless »

soz wrote:
soz wrote:

Code: Select all

Couldnt add the settings into the database 

DEBUG MODE 

SQL Error : 1136 Column count doesn't match value count at row 1 

INSERT INTO phpbb_pa_cat VALUES('NULL', 'a', 'a', '0', '0', '0', '0') 

Line : 67 
File : /home/studentf/public_html/phpBB2/admin/admin_category.php
I get that error when ever i try and add a new catergory!


anyone?


In SQL speak, it means that phpbb_pa_cat doesn't have the correct number of columns in order to insert the information. Double check to see if you installed the mod correctly.
soz
Registered User
Posts: 25
Joined: Tue Feb 10, 2004 5:29 pm

Post by soz »

The mod came installed with Minerva at www.flexion.org

and they have it working - so i really dunno!
soz
Registered User
Posts: 25
Joined: Tue Feb 10, 2004 5:29 pm

Post by soz »

Fearless wrote:
soz wrote:
soz wrote:

Code: Select all

Couldnt add the settings into the database 

DEBUG MODE 

SQL Error : 1136 Column count doesn't match value count at row 1 

INSERT INTO phpbb_pa_cat VALUES('NULL', 'a', 'a', '0', '0', '0', '0') 

Line : 67 
File : /home/studentf/public_html/phpBB2/admin/admin_category.php
I get that error when ever i try and add a new catergory!


anyone?


In SQL speak, it means that phpbb_pa_cat doesn't have the correct number of columns in order to insert the information. Double check to see if you installed the mod correctly.


checked the whol mod and everything seems to be in order!
Fearless
Registered User
Posts: 664
Joined: Mon Mar 31, 2003 6:16 am

Post by Fearless »

What are the colums present in your database at the moment ?
soz
Registered User
Posts: 25
Joined: Tue Feb 10, 2004 5:29 pm

Post by soz »

don't worry fixed that now, but i have another problem

i have the main catergory, and then a catergory in that and then a catergory in that, and files in there:

Main
--Topic
----Files - Work.pdf

When looking at the downloads page, it says there are 0 files in the Main catergory and 1 in the view all files, but this isn't right!

and also the reorder catergories doesn't work
User avatar
Lucas1510
Registered User
Posts: 47
Joined: Thu Sep 04, 2003 12:07 am
Location: Herne - Germany
Contact:

Post by Lucas1510 »

Hello,

pafiledb runs without problems at my forum, but when I am not logged in and try to download a file, there comes the login-screen. When I then enter my name & PW I get an error:

Code: Select all

Warning: module(./pafiledb/modules/pa_.php): failed to open stream: No such file or directory in /is/htdocs/forum4w/pafiledb/includes/functions_pafiledb.php on line 45
functions_pafiledb.php wrote: $this->module_name = $module_name;

require_once($phpbb_root_path . 'pafiledb/modules/pa_' . $module_name . '.'.$phpEx);
eval('$this->modules[' . $module_name . '] = new pafiledb_' . $module_name . '();');

if (method_exists($this->modules[$module_name], 'init'))


The red part is line 45, do you have an idea why this happens?

Oh, and after I press the "Back"-Button in my Browser I am logged (?) in :?
User avatar
Lucas1510
Registered User
Posts: 47
Joined: Thu Sep 04, 2003 12:07 am
Location: Herne - Germany
Contact:

Post by Lucas1510 »

No idea? :oops:
Fearless
Registered User
Posts: 664
Joined: Mon Mar 31, 2003 6:16 am

Post by Fearless »

It sounds like the script is redirecting to a wrong or non-existant page. Isn't there a way in PHP of displaying what the value of $module_name ?
Odin-NMA
Registered User
Posts: 63
Joined: Wed Aug 28, 2002 11:18 am
Location: Valhalla
Contact:

Post by Odin-NMA »

Sounds like you didn't follow every step in the installation, go back and check that you did..
Fearless
Registered User
Posts: 664
Joined: Mon Mar 31, 2003 6:16 am

Post by Fearless »

This is weird. I've just done a clean install of this mod and it works near perfect. Most of the bugs of version 0.0.9a are gone. If you're experiecing any problems, I suggest you do a clean install also as there might be a problem with updating.
Locked

Return to “[2.0.x] MODs in Development”