Page 3 of 63

Posted: Fri Nov 29, 2002 4:21 am
by LaZeR
squall wrote: I need just clean up some code, complete the style file, and worte the readme file


Great! Keep up the good work :)

Posted: Fri Nov 29, 2002 1:44 pm
by Hades
Why don't the two of you compare what you have done already and put your two projects together.

It would take half the time of each of you and produce a better finished product rather than several buggy products (no insults intended... I just don't see the point in duplicating effort). :)

Posted: Fri Nov 29, 2002 1:55 pm
by Mohd
MJ made it for his forum FM, but I don't think that he mad the modification that I made because I have changed the whole file to use everything that phpbb use (db class system, template system, sessions, others)

Posted: Sun Dec 01, 2002 11:11 pm
by LaZeR
How's this one coming? :)

Posted: Mon Dec 02, 2002 3:17 am
by LordOden
lol we may never know

Posted: Tue Dec 03, 2002 7:03 am
by Mohd
Sorry guys for not let you know this week was very bad for me I couldn't even work on computer because I have 4 exam in UNI. and I had to study for them.
good news that I finished from them know and I will work on the mod know.

Posted: Tue Dec 03, 2002 8:02 am
by MJ
hey squall, I say we get together and mix'n'blen what we both got done.....if you got time 2nite ?? ....I'll hit you @ FM with PM now also!!

Hold tight peeps, release is sooner then you realise!!! hehehe

Posted: Tue Dec 03, 2002 8:19 am
by Mohd
Ok MJ I will send the file to you on your forum may be today but admin still not finished yet (damn it is too long)

Posted: Wed Dec 04, 2002 10:03 pm
by LaZeR
Glad to see you guys hooking up to get this mod out :wink: We're still interested and patiently waiting :)

Posted: Fri Dec 06, 2002 4:53 am
by Mohd
Sorry guys for let you waitting, admin section will be ready very soon, I need to modify the custom field file and it will be release.

If some one could make some image for this mod I will be very glad

Posted: Sun Dec 08, 2002 3:21 pm
by Mohd
first release see the first post : download link

Posted: Sun Dec 08, 2002 4:32 pm
by rikke
download don't work

Posted: Sun Dec 08, 2002 8:50 pm
by Mohd
I don't know what is wrong with url I am sure that I uploaded the file and I have test but don't worry I will move to another place just wait

Posted: Mon Dec 09, 2002 8:09 am
by LaZeR
Glad to see this one. I have had a few issues. First off I went through all files and matched up the $dbprefix from the default:

Code: Select all

$dbprefix = "pafiledb";
To

Code: Select all

$dbprefix = "phpbb_pafiledb";
And I also renamed all pafiledb tables to this in phpMyAdmin. I like all my tables associated with phpbb prefixed as such thus they get included in the database size totals. :wink: Now I don't feel this is of any issue to the following problems, just thought I would mention it. Database communications seem fine.

Problems:

(1) When addin a file in the ADMIN section and using the "Upload a file to the server" function and then after uploading, I get:
The file test.zip has been uploaded! The URL to the file is http://www.oasisforum.valcato.net/phpbb ... n_file.php
Click Here to place this URL in the Download URL field.


Always happens this way thus I can never get the actual URL as its supposed to work but rather this for any file: http://www.oasisforum.valcato.net/phpbb ... n_file.php requiring me to manually input the correct URL location and file in.

(2) All the paFileDB's admin functions where placed all throughout my ADMIN Panel thus making it very difficult to figure out which functions belonged to this mod and where they were thus I solved this for now by editing all the Admin entries in the pafiledb/lang/english.php with paFileDB words at the beginning of each title thus atleast they are all together and at the bottom in Admin index.

(3) The "Email to friend" functions works well except for one very minor issue. After sending the email, there is a broken image to the left of: Thank you! Your e-mail has been sent to Me's e-mail address. which is due to a wrong URL of: http://www.oasisforum.valcato.net/phpbb ... s/info.gif -Notice the double // also in this.

UPDATE: I just corrected this issue by changing the following code found in pa_email_body.tpl From:

Code: Select all

    <p align="center"><img src="styles/{STYLE}/images/info.gif" border="0"></p>
TO:

Code: Select all

    <p align="center"><img src="pafiledb/styles/default/images/info.gif" border="0"></p>
(4) The following part of the code to add in overall_header.tpl shows:

Code: Select all

<img src="templates/fisubsilver/images/icon_mini_download.gif"
Should be:

Code: Select all

<img src="templates/subSilver/images/icon_mini_download.gif"
For default subSilver ofcourse :wink:

All in all it works well for the main part and function other than the items I noted, most troublesome is the 1st one. 8)

Oops. Forgot to mention you need to include instructions saying to CHMOD the /pafiledb/upload DIR to 777

Posted: Mon Dec 09, 2002 8:18 am
by Napoleon
squall wrote: first release see the first post : download link


w00t! Thanx, I REALLY needed this MOD. Image