Page 38 of 63

HELP ME

Posted: Fri Sep 12, 2003 9:36 am
by procomp
GUS, when I add an archive for the ADMINISTRATION PANEL, it adds normal without problems appears all normal one. but, when I add for: UPLOAD USERS, it send the archive for the ftp, but nao appears nothing http://www.samba420.net/forum/dload.php , is one bug? what it can be? somebody can help me? urgent!

I verified and the information goes pro bank. but when it is added by users or administrators but it saw site ( http://www.samba420.net/forum/dload.php ... ser_upload ) does not appear in the section downloads: (

Posted: Fri Sep 12, 2003 12:04 pm
by playerfr
sorry i dont want to spam but i posted my message in support as i did not saw this Post before. I have a little problem with uploading, explained in my message here :

http://www.phpbb.com/phpBB/viewtopic.php?t=135561


Thanks alots

Posted: Fri Sep 12, 2003 3:54 pm
by Earthk
I didn't know that this is a beta and installed it. It doesn't seem to work.

This is what I've done:

1. Download v0.09b from http://217.148.161.219/~nlwebheb/files/ ... 0.0.9b.zip

2. Fix the error
"Fatal error: Cannot redeclare get_extension() (previously declared in
functions_attach.php...." by commenting the get_extention function as
adviced in a past post.

3. Since I've run the pafiledb_installer.php, I deleted all references of the
script in mySQL database and re-run it again with the corrected pafiledb_mysql.sql mentioned in another post.

I don't think this is ready for actual use, but why did some sites actually
are using it without any problems? I forgot the links so I can't put it
here.

Re: HELP ME

Posted: Fri Sep 12, 2003 4:13 pm
by procomp
procomp wrote: GUS, when I add an archive for the ADMINISTRATION PANEL, it adds normal without problems appears all normal one. but, when I add for: UPLOAD USERS, it send the archive for the ftp, but nao appears nothing http://www.samba420.net/forum/dload.php , is one bug? what it can be? somebody can help me? urgent!

I verified and the information goes pro bank. but when it is added by users or administrators but it saw site ( http://www.samba420.net/forum/dload.php ... ser_upload ) does not appear in the section downloads: (


anyone?

my version is 0.0.9b :(

Re: HELP ME

Posted: Fri Sep 12, 2003 6:24 pm
by Frold
procomp wrote:
procomp wrote:GUS, when I add an archive for the ADMINISTRATION PANEL, it adds normal without problems appears all normal one. but, when I add for: UPLOAD USERS, it send the archive for the ftp, but nao appears nothing http://www.samba420.net/forum/dload.php , is one bug? what it can be? somebody can help me? urgent!

I verified and the information goes pro bank. but when it is added by users or administrators but it saw site ( http://www.samba420.net/forum/dload.php ... ser_upload ) does not appear in the section downloads: (


anyone?

my version is 0.0.9b :(


and it is full of bugs read this thread....

Posted: Fri Sep 12, 2003 8:13 pm
by Fearless
Earthk wrote: 2. Fix the error
"Fatal error: Cannot redeclare get_extension() (previously declared in
functions_attach.php...." by commenting the get_extention function as
adviced in a past post.

I don't think this is ready for actual use, but why did some sites actually
are using it without any problems? I forgot the links so I can't put it
here.


Error 2 is a conflict with the file attachment mod, I think. As for sites already using the mod, I think they are using earlier versions (such as 0.0.8 ).

Posted: Sat Sep 13, 2003 6:30 am
by Frold
Fearless wrote:
Frold wrote:1. When I approve a file in ACP the field file_dlurl in this tabel phpbb_pa_files get a wrong url. The wrong url is www.domain.com/100000000000 .
The URL should be. www.domain.com/[file_dir]/[unique_name]
Has this bug something to do with this in pafiledb/includes/fuctions.php

Code: Select all

function gen_unique_name($file_type)
{
   global $pafiledb_config;
   
   srand((double)microtime()*1000000);   // for older than version 4.2.0 of PHP

   do
   {
      $filename = md5(uniqid(rand())) . $file_type;
   }
   while( file_exists($pafiledb_config['upload_dir'] . '/' . $filename) );
   
   return $filename;
}

Posted: Sat Sep 13, 2003 6:38 am
by Frold
Fearless wrote:
Earthk wrote:2. Fix the error
"Fatal error: Cannot redeclare get_extension() (previously declared in
functions_attach.php...." by commenting the get_extention function as
adviced in a past post.

I don't think this is ready for actual use, but why did some sites actually
are using it without any problems? I forgot the links so I can't put it
here.


Error 2 is a conflict with the file attachment mod, I think. As for sites already using the mod, I think they are using earlier versions (such as 0.0.8 ).


find pafiledb/icludes/fuctions.php

Code: Select all

function get_extension($filename)
{
	$extension = strrchr(strtolower($filename), '.');
	$extension[0] = ' ';
	$extension = strtolower(trim($extension));
	if (is_array($extension))
	{
		return ('');
	}
	else
	{
		return ($extension);
	}
}
replace with
//function get_extension($filename)
//{
// $extension = strrchr(strtolower($filename), '.');
// $extension[0] = ' ';
// $extension = strtolower(trim($extension));
// if (is_array($extension))
// {
// return ('');
// }
// else
// {
// return ($extension);
// }
//}

Posted: Sun Sep 14, 2003 12:57 am
by procomp
Hi guyes,

the problem of the users to send are that necessary TO AUTHORIZE the archive however, are not sending archive bigger of the one than 4mb, as make pra to configure or to incapacitate this? it wanted to send archives of 20mb, can help me? it presents the error: "Please complete all the required fields" .. but is it is the size of the archive...

please, help me!!!!!

http://www.samba420.net/forum/dload.php

tks

Posted: Thu Sep 18, 2003 11:14 pm
by xmulder
any development on this?

Posted: Fri Sep 19, 2003 1:33 am
by Fearless
I'm sorry that I can't help. I've gone back to to studying programming analysis at night school and I need to concentrate on that. Besides, I don't have enough notions in Object Orientated programming to really delve into the code. I'll simply content myself with making a diagram and seeing how the whole script is put together.

I encourage you to help out Mohd with the development of this mod, much as MJ initially did, if you have any notions. It would be a good idea to concentrate on making the existing features work like category deletion and updating category information.

Posted: Fri Sep 19, 2003 8:56 am
by PhilippT
i fixed the most of the bug on my forum but the download path bug is to much for me....


have someone fix it ?

Posted: Fri Sep 19, 2003 12:49 pm
by Frold
If this mod isn´t in developing by mohd I think this post should been locked.... There are to many bugs and this mod has been en developing for nearly a year...

Posted: Fri Sep 19, 2003 1:28 pm
by Mohd
umm, I see, I can complete this mod only in one day, but I have my real life issue coz web is not everything and I am still students in university and I have to take care of my future, and the modding thing is only a hobbie for me, so that is why I can't just work on it all the day. :D

keep your eye on my site coz I don't visit her regulary.

Posted: Fri Sep 19, 2003 1:59 pm
by Frold
Yes I understand I´m a student too.... but we are many users who have tried to fix this mod, but there are too many bugs!

And this mod has been in "beta" mode for such a long time - too long I have to say...That's not normal for a phpbb mod...

Therefore I don´t think the subject for this post should be [DEV] Pafiledb [DOWNLOAD MOD] 0.0.9b.
If a phpbb user is downloading a mod under development they think there soon will be a new release with fixed bugs reported in this forum - but nothing happens!!