[BETA] ADD_ON to Profile in Photo MOD

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Bradman
Registered User
Posts: 84
Joined: Mon Nov 11, 2002 6:39 am
Location: Ledyard, CT
Contact:

some things I noticed

Post by Bradman »

First off, I'm a n00b, so what I'm pointing out may or may not be correct. :wink:
I installed the mod and it works great, I like it a lot. But here's a few little things I noticed...

Code: Select all

## Included Files: photo.gif, photoinprofile.zip (required) 
The photoinprofile.zip file wasn't included, and the one I found is profilephoto_mod.zip. Not a big deal though as it's quite clear that AcydBurn's mod has to be done first.

In *PART_1.txt,

Code: Select all

# 
#-----[ UPLOAD ]------------------------------------------ 
#

          photo.gif to /images/photo.gif
You may want to note that this is off of the root directory, not the phpBB2 (or whatever else it may be named) directory.

A bit farther down...

Code: Select all

# 
#-----[ FIND ]------------------------------------------ 
# 

 class="gen"><b>{memberrow.USERNAME}</b></a></span></td>  ## yours may be different 

## {L_USERNAME} is the important part
Looks like you copied and pasted the last line from the previous step, but didn't edit out the L_?

Next step...

Code: Select all

# 
#-----[ AFTER, ADD ]------------------------------------------ 
# 

<td class="{memberrow.ROW_CLASS}" align="center" width="3%"><span class="gen">{memberrow.photo}<b><br>
Shouldn't the <br> be <br />?

Next file, *PART_2.txt, same thing with the <br> and <br /> here

Code: Select all

# 
#-----[ AFTER, ADD ]------------------------------------------ 
#

<br>{postrow.Has_Profile_Photo}    ##This can be added wherever you like to suit your taste
And the last thing I saw, when viewing the member list, the background image on the bottom row is now one cell short after the pic colum is added. I changed mine from 8 to 9 here...

Code: Select all

<!-- END memberrow -->
	<tr> 
	  <td class="catbottom" colspan="9" height="28">&</td>
Might want to mention changing this also.
Again, I'm new at this, so I might be wrong about these things. Either way, I hope I helped.
crazyd1415
Registered User
Posts: 63
Joined: Mon May 13, 2002 3:41 am

Post by crazyd1415 »

ok, i figured out how to do a random profile with picture and gender to display on any php page on your site. All you gotta do is dl fetch all from http://clanunity.net/portal.php. you gotta mod it a little to do it but if you know even a lil php it shouldnt be hard to figure out. If anyone had dl the gender mod and profile mod and want it to display on any php page on your site and have dl the fetch all mod and need feel free to pm me.
Threatcon
Registered User
Posts: 131
Joined: Tue Dec 10, 2002 5:38 am
Location: Florida
Contact:

Post by Threatcon »

Works good!! :D Thankx!! :D

Only one problem though.... Easy fix... When adding this line in memberlist.php

Code: Select all

$photo = ( $row['user_photo'] ) ? '<img src="/images/photo.gif" width="16" height="12" border="0">' : '';
Should be...

Code: Select all

$photo = ( $row['user_photo'] ) ? '<img src="images/photo.gif" width="16" height="12" border="0">' : '';
Just remove the / before "images/photo.gif"

Flawless!! For 2.0.3 that is!! 8)
User avatar
Lumix
Registered User
Posts: 39
Joined: Mon Dec 16, 2002 4:16 pm
Location: Belgium
Contact:

Post by Lumix »

Tested it on 2.04,

The mod wors perfectly, but your addon...

part1:
In memberlist the foto doesn't show up, and you get a picture missing in your rechtbottomcorner or your table.
So now I de-installed part1

part2:
works just fine ;)

questions:
1)part1: Can you fix that?
2)part2: How come I get: Profile Photo, but my language in Dutch, where can I change that?
3)part2: It links to profile yes, but it doesn't scroll down to Profile Photo (for me it's dutch there...), but your just at the top of the profile. Can you change that?
crazyd1415
Registered User
Posts: 63
Joined: Mon May 13, 2002 3:41 am

Post by crazyd1415 »

1. bout the photo not showing up i think threatcon answered it but if what he said dont work you can just type in the full url of where the picture is located and that should work.
2. just type that in Dutch whenever it shows up
3. I dont know. I use to know.
User avatar
Groove
Registered User
Posts: 26
Joined: Tue Oct 15, 2002 5:32 am

Post by Groove »

Is anyone running the Photo Mod + Addon successfully on phpBB 2.0.4?

And does anyone know if it works with Sub Forums:

http://www.phpbb.com/phpBB/viewtopic.php?t=42505 ?

TIA


Groove
MJ
Registered User
Posts: 180
Joined: Thu Jan 03, 2002 10:20 pm
Contact:

Post by MJ »

Yes this works on 2.0.4 with SubFolders MOD installed...

I've added link to profile photo from memberlist icon, included camera image into templates/*/images folder and added language support..nice little add-on! ;)

New version: 1.0.1

Click here to download
Last edited by MJ on Sun Jul 20, 2003 3:15 am, edited 1 time in total.
Bradman
Registered User
Posts: 84
Joined: Mon Nov 11, 2002 6:39 am
Location: Ledyard, CT
Contact:

Post by Bradman »

Ok, I am upgrading from 1.0.0 to 1.0.1 and I have one question. (remember, I'm still a n00b and don't know php) It looks like phpbb 2.0.3 code is being used in the instructions and it doesn't match the new 2.0.4 code. This is from part 2 of the instructions...

Code: Select all

# 
#-----[ FIND ]------------------------------------------ 
#

$sql = "SELECT u.username, u.user_id, u.user_posts, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_regdate, u.user_msnm, u.user_viewemail, u.user_rank, u.user_sig, u.user_sig_bbcode_uid, u.user_avatar, u.user_avatar_type, u.user_allowavatar, u.user_allowsmile,u.user_allow_viewonline, u.user_session_time, p.*,  pt.post_text, pt.post_subject, pt.bbcode_uid
FROM " . POSTS_TABLE . " p, " . USERS_TABLE . " u, " . POSTS_TEXT_TABLE . " pt
        WHERE p.topic_id = $topic_id
And this is what is actually there...

Code: Select all

$sql = "SELECT u.*, p.*,  pt.post_text, pt.post_subject, pt.bbcode_uid
	FROM " . POSTS_TABLE . " p, " . USERS_TABLE . " u, " . POSTS_TEXT_TABLE . " pt
	WHERE p.topic_id = $topic_id
Then the instructions say...

Code: Select all

# 
#-----[ FIND, INLINE ]------------------------------------------ 
#

 u.user_from,

# 
#-----[ AFTER, ADD ]------------------------------------------ 
#

 u.user_photo,
Can I assume (with my limited understanding...) that this step can be ignored? It looks to me like the "SELECT u.*, part would include the u.user_photo. Comments, please. :)
Benneh
Registered User
Posts: 35
Joined: Wed Feb 19, 2003 3:47 pm
Location: England

Post by Benneh »

This mod sounds like what I've been looking for to create a more interesting profile for my users. Is there a demo or an example of this mod in action? Either the original mod or the one you’re developing. So I can see it before I install.

*edited*

nevermind, I've just install the photo mod. works great :)
tallis
Registered User
Posts: 8
Joined: Fri Dec 07, 2001 3:45 am

Post by tallis »

Bradman wrote: Can I assume (with my limited understanding...) that this step can be ignored? It looks to me like the "SELECT u.*, part would include the u.user_photo. Comments, please. :)


Correct.
Young David
Registered User
Posts: 12
Joined: Wed Nov 20, 2002 7:29 pm

Post by Young David »

I just installed this mod and when I want to add a pic it says:
Your uploaded file is too large or corrupted


While I am sure the file size is okay and not corrupt ...
Bradman
Registered User
Posts: 84
Joined: Mon Nov 11, 2002 6:39 am
Location: Ledyard, CT
Contact:

Post by Bradman »

tallis wrote: Correct.


Thank you much.
User avatar
MoonClamp
Registered User
Posts: 62
Joined: Fri Dec 13, 2002 6:20 pm
Location: London
Contact:

Post by MoonClamp »

Just found this and may give it a try, does anyone think there would be an easy way to turn the picture into a thumbnail using gd and set it as a clickable avatar like on a few forums I have seen?
romans1423
Registered User
Posts: 1552
Joined: Sat Nov 02, 2002 4:44 pm
Location: Connersville, IN
Name: Rick Beckman
Contact:

Post by romans1423 »

MJ,
I tried downloading your file (1.0.1), but all I get is an empty ZIP file. :(
Just thought I'd let you know.
User avatar
GurlzLubme
Registered User
Posts: 880
Joined: Wed Sep 01, 2004 11:21 am
Location: New York

Post by GurlzLubme »

anyone running this on 2.0.10?
Locked

Return to “[2.0.x] MODs in Development”