Page 2 of 3

some things I noticed

Posted: Sun Jan 19, 2003 7:51 am
by Bradman
First off, I'm a n00b, so what I'm pointing out may or may not be correct. :wink:
I installed the mod and it works great, I like it a lot. But here's a few little things I noticed...

Code: Select all

## Included Files: photo.gif, photoinprofile.zip (required) 
The photoinprofile.zip file wasn't included, and the one I found is profilephoto_mod.zip. Not a big deal though as it's quite clear that AcydBurn's mod has to be done first.

In *PART_1.txt,

Code: Select all

# 
#-----[ UPLOAD ]------------------------------------------ 
#

          photo.gif to /images/photo.gif
You may want to note that this is off of the root directory, not the phpBB2 (or whatever else it may be named) directory.

A bit farther down...

Code: Select all

# 
#-----[ FIND ]------------------------------------------ 
# 

 class="gen"><b>{memberrow.USERNAME}</b></a></span></td>  ## yours may be different 

## {L_USERNAME} is the important part
Looks like you copied and pasted the last line from the previous step, but didn't edit out the L_?

Next step...

Code: Select all

# 
#-----[ AFTER, ADD ]------------------------------------------ 
# 

<td class="{memberrow.ROW_CLASS}" align="center" width="3%"><span class="gen">{memberrow.photo}<b><br>
Shouldn't the <br> be <br />?

Next file, *PART_2.txt, same thing with the <br> and <br /> here

Code: Select all

# 
#-----[ AFTER, ADD ]------------------------------------------ 
#

<br>{postrow.Has_Profile_Photo}    ##This can be added wherever you like to suit your taste
And the last thing I saw, when viewing the member list, the background image on the bottom row is now one cell short after the pic colum is added. I changed mine from 8 to 9 here...

Code: Select all

<!-- END memberrow -->
	<tr> 
	  <td class="catbottom" colspan="9" height="28">&</td>
Might want to mention changing this also.
Again, I'm new at this, so I might be wrong about these things. Either way, I hope I helped.

Posted: Mon Jan 20, 2003 3:32 am
by crazyd1415
ok, i figured out how to do a random profile with picture and gender to display on any php page on your site. All you gotta do is dl fetch all from http://clanunity.net/portal.php. you gotta mod it a little to do it but if you know even a lil php it shouldnt be hard to figure out. If anyone had dl the gender mod and profile mod and want it to display on any php page on your site and have dl the fetch all mod and need feel free to pm me.

Posted: Tue Jan 21, 2003 10:42 am
by Threatcon
Works good!! :D Thankx!! :D

Only one problem though.... Easy fix... When adding this line in memberlist.php

Code: Select all

$photo = ( $row['user_photo'] ) ? '<img src="/images/photo.gif" width="16" height="12" border="0">' : '';
Should be...

Code: Select all

$photo = ( $row['user_photo'] ) ? '<img src="images/photo.gif" width="16" height="12" border="0">' : '';
Just remove the / before "images/photo.gif"

Flawless!! For 2.0.3 that is!! 8)

Posted: Thu Jan 23, 2003 4:47 pm
by Lumix
Tested it on 2.04,

The mod wors perfectly, but your addon...

part1:
In memberlist the foto doesn't show up, and you get a picture missing in your rechtbottomcorner or your table.
So now I de-installed part1

part2:
works just fine ;)

questions:
1)part1: Can you fix that?
2)part2: How come I get: Profile Photo, but my language in Dutch, where can I change that?
3)part2: It links to profile yes, but it doesn't scroll down to Profile Photo (for me it's dutch there...), but your just at the top of the profile. Can you change that?

Posted: Fri Jan 24, 2003 5:14 am
by crazyd1415
1. bout the photo not showing up i think threatcon answered it but if what he said dont work you can just type in the full url of where the picture is located and that should work.
2. just type that in Dutch whenever it shows up
3. I dont know. I use to know.

Posted: Thu Jan 30, 2003 5:13 am
by Groove
Is anyone running the Photo Mod + Addon successfully on phpBB 2.0.4?

And does anyone know if it works with Sub Forums:

http://www.phpbb.com/phpBB/viewtopic.php?t=42505 ?

TIA


Groove

Posted: Thu Jan 30, 2003 7:54 pm
by MJ
Yes this works on 2.0.4 with SubFolders MOD installed...

I've added link to profile photo from memberlist icon, included camera image into templates/*/images folder and added language support..nice little add-on! ;)

New version: 1.0.1

Click here to download

Posted: Mon Feb 24, 2003 1:41 am
by Bradman
Ok, I am upgrading from 1.0.0 to 1.0.1 and I have one question. (remember, I'm still a n00b and don't know php) It looks like phpbb 2.0.3 code is being used in the instructions and it doesn't match the new 2.0.4 code. This is from part 2 of the instructions...

Code: Select all

# 
#-----[ FIND ]------------------------------------------ 
#

$sql = "SELECT u.username, u.user_id, u.user_posts, u.user_from, u.user_website, u.user_email, u.user_icq, u.user_aim, u.user_yim, u.user_regdate, u.user_msnm, u.user_viewemail, u.user_rank, u.user_sig, u.user_sig_bbcode_uid, u.user_avatar, u.user_avatar_type, u.user_allowavatar, u.user_allowsmile,u.user_allow_viewonline, u.user_session_time, p.*,  pt.post_text, pt.post_subject, pt.bbcode_uid
FROM " . POSTS_TABLE . " p, " . USERS_TABLE . " u, " . POSTS_TEXT_TABLE . " pt
        WHERE p.topic_id = $topic_id
And this is what is actually there...

Code: Select all

$sql = "SELECT u.*, p.*,  pt.post_text, pt.post_subject, pt.bbcode_uid
	FROM " . POSTS_TABLE . " p, " . USERS_TABLE . " u, " . POSTS_TEXT_TABLE . " pt
	WHERE p.topic_id = $topic_id
Then the instructions say...

Code: Select all

# 
#-----[ FIND, INLINE ]------------------------------------------ 
#

 u.user_from,

# 
#-----[ AFTER, ADD ]------------------------------------------ 
#

 u.user_photo,
Can I assume (with my limited understanding...) that this step can be ignored? It looks to me like the "SELECT u.*, part would include the u.user_photo. Comments, please. :)

Posted: Mon Feb 24, 2003 2:11 am
by Benneh
This mod sounds like what I've been looking for to create a more interesting profile for my users. Is there a demo or an example of this mod in action? Either the original mod or the one you’re developing. So I can see it before I install.

*edited*

nevermind, I've just install the photo mod. works great :)

Posted: Mon Feb 24, 2003 7:01 pm
by tallis
Bradman wrote: Can I assume (with my limited understanding...) that this step can be ignored? It looks to me like the "SELECT u.*, part would include the u.user_photo. Comments, please. :)


Correct.

Posted: Mon Feb 24, 2003 8:56 pm
by Young David
I just installed this mod and when I want to add a pic it says:
Your uploaded file is too large or corrupted


While I am sure the file size is okay and not corrupt ...

Posted: Wed Feb 26, 2003 5:56 pm
by Bradman
tallis wrote: Correct.


Thank you much.

Posted: Fri Mar 21, 2003 11:27 pm
by MoonClamp
Just found this and may give it a try, does anyone think there would be an easy way to turn the picture into a thumbnail using gd and set it as a clickable avatar like on a few forums I have seen?

Posted: Sat Mar 22, 2003 2:35 am
by romans1423
MJ,
I tried downloading your file (1.0.1), but all I get is an empty ZIP file. :(
Just thought I'd let you know.

Posted: Wed Oct 27, 2004 3:24 pm
by GurlzLubme
anyone running this on 2.0.10?