Photo Album v2

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP »

iorhael wrote: I am back into the easymod installer but I can't figure out what to add as my path....my phpbb board is located at:

www.drk-writing.com/northwesternesse/TheFellowship

Can you help me out here?

Try this link now. The permissions you changed must have done the trick. Just stick with the default settings unless there is a problem during the install. I am heading to bed now, but I don't imagine that you will have a problem. I can stay up for a bit to see how the EM Install turns out:

http://www.drk-writing.com/northwestern ... nstall.php
iorhael wrote: BTW, I am not a programmer (you probably figured that one out already ;o!) I was a technical writer for many years and now am trying to learn as much as I can about web design. So I'm familiar with some of this stuff, but when it comes to coding, I'm pretty ignorant.

Anyway, just wanted to let you know my background.

Very few phpBB Admins are programmers so you are in good company. If you use EM to install your MODs and learn a few tricks that I can teach you, you really will be able to install a lot of MODs to your board and you will quickly begin to understand phpBB quite a bit in a very short time. I've installed over 720 MODs on my board using EM. I doubt if I would have installed 50 if I had to install them all manually...
iorhael wrote: Does EM make it easy then to install the calendar and other programs?

There are 4 default parts to the calendar and a few add-on and patch MODs too. You probably will want to install 3 of the 4 parts of the calendar, 1-3. To do this, it often takes people hours when they choose to install it manually. You can install the whole thing in a matter of minutes when you use EM. You can guess which I would recommend...

EM makes good backups of all the modified files so if the MOD hoses your board, you can quickly roll back the changes and be back to normal in nothing flat. EM doesn't make human errors, so the best you can do if you don't make any mistakes when applying the code manually is what EM did in a matter of minutes. No matter how good or careful you are, you will make a mistake every once in a while. EM will never have that bad day. EM maintains a history of all your installed MODs that you can reference for future problems or just to satisfy a curiousity. Also if you keep all of your MOD backups, you can roll back dozens of MOD installs in a short period of time in order to find a strange bug. I once had to roll back over 20 MODs to track down a strange bug that even the MOD author was not aware of. I doubt many others could have recovered so easily...

Bottom line, I think it's silly to do the brain-dead activity of cutting and pasting code into your board when you have a good utility like EM to install the code for you. I will never understand why anyone would choose to apply their code manually...

If you are curious, here is a list of all the MODs that I have installed on my board using EM:

EM MOD Install List

If you didn't apply your overall_header.tpl code to your subSilver template, you can do that too using the MOD code. For your summertime template, you will want to use the code I provided in my previous post...

Image
NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP »

iorhael wrote: I am about ready to fix the code and install the button but the photo album install instructions said to put that button (Upload Pic) into the EnglishLanguage folder of the Images file in the Templates. Yet the other top-level buttons (Groups, etc) are just in the Images folder itself. So what I'm wondering is if this a button meant when the user is actually in the album, and whether there is *another* button somewhere for the Main menu? Or is this the only button that the album function needs.

You can store the button icons images anywhere you want, but you would need to modify the path to point to the proper place. Most of the template images go into the template/images folder because the images may be different for each template. I have 12 templates installed on my board, so the buttons are varying colors, sizes, and shapes for each template. I wouldn't be able to store them all in the phpBB images folder because they all have the same name. So it is best to store all of your template images in your templatename/images folder to keep each unique, unless of course you never plan to install more than one template on your board...
iorhael wrote: I hope this makes sense. You've been so much help already...I'm sorry to keep bugging you with questions....if I knew you personally I'd make you cookies :):)

Don't worry about me. If I didn't want to help, I wouldn't. The pay certainly isn't enough to keep me here against my will. I have been known to accept virtual cookies though. Chocolate chip or Peanut Butter are my favorites...

I really need to go to bed, so if I don't hear an update from you on how the EM install went in a few minutes, I will have to wait until I wake up later on. It would be nice to go to bed on a success story though...

Image
iorhael
Registered User
Posts: 18
Joined: Mon Oct 17, 2005 12:00 am

Post by iorhael »

NR,

I am getting the same error message I got earlier after I set my password:

Directory listing: your FTP Path should start with one of the directories listed below
FTP Error: A file listing could not be obtained. This usually indicates solution 4 listed above.


I tried both the full link and also just northwesternesse/TheFellowship...am tearing my hair out here...I can't seem to get past this point.
NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP »

Send me a PM and I will try to walk you through it. If you have AIM, you can reach me at NightriderXP1 too...

Image
clubchill
Registered User
Posts: 90
Joined: Fri Oct 21, 2005 10:50 am

Post by clubchill »

what if a user wants to upload more than one pic? Will they have thumbnails scattered throughout the gallery, or will pics be consolidated in a slide show for each user?

Just curious as to how this mod handles multiple uploads by the same user.

Thanks
GrooveCollection
Registered User
Posts: 157
Joined: Sat Apr 16, 2005 2:40 pm

Post by GrooveCollection »

Yihaaaah

I'm a happy man.
the red crosses are gone !!! 8)

After trying a lot of things. (clearing caches, changing settings etc..) it still was there.

The solution was very simple. I found it here: http://smartor.is-root.com/viewtopic.php?t=2014

When I turned the Hotlink prevention off it was good
johnnylawson
Registered User
Posts: 1
Joined: Fri Oct 21, 2005 7:57 pm

Post by johnnylawson »

I would love to use this mod but I have a question.

1. Can I change the server / location to have the photos uploaded to another server other then where my phpbb boards are.
Example if my boards are at www.demosite.com but I want the uploads to be housed at www.uploadsitedemo.com - is there anyway for this to be configured and would it work?
agent00shoe
Registered User
Posts: 373
Joined: Sat Feb 12, 2005 9:39 pm

Post by agent00shoe »

Does this have some type of configurable quota or limit on how many pictures members can upload?
GrooveCollection
Registered User
Posts: 157
Joined: Sat Apr 16, 2005 2:40 pm

Post by GrooveCollection »

agent00shoe wrote: Does this have some type of configurable quota or limit on how many pictures members can upload?

yes, both :D
webmaster jim
Registered User
Posts: 6
Joined: Fri Oct 21, 2005 11:26 am

viewprofile

Post by webmaster jim »

Hi,

I installed this mod yester day whith the latest release of phpBB and everything exept viewprofile works!

http://www.birgittawidegren.com/korsordslexikon/forum

Help please!
MVH - Webmaster Jim
My portfolio Portfolio
Forum for recipes Recipe Banks Cook Book
E-Cards Postcard
Photo gallery Gallery
webmaster jim
Registered User
Posts: 6
Joined: Fri Oct 21, 2005 11:26 am

Re: Linking to Album photos in Posts

Post by webmaster jim »

Ii tryed this little mod as well, but i get red isted of a image and not the full path...

it seams that the {PIC_FILENAME} doesent get a walue!?

Koyaanis wrote: Well, I took some suggestions that others had posted. Since those suggestions already broke the security issue of offsite hot-linking to images in the images and thumbs folders, I thought I'd go one more step and change the the link to the full-size display too. This way a simple right-click on image, copy image address (available in most browsers) is now functional. Here's my changes to the /templates/subSilver/album_page_body.tpl code. I also took the liberty to make some cosemtic changes to the way the direct-link strings are displayed to make it easier for new-comers to know which address-strings need to be copied and pasted into their posts.

File: /templates/subSilver/album_page_body.tpl

Code: Select all

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr>
	<td class="nav"><span class="nav"><a href="{U_INDEX}" class="nav">{L_INDEX}</a> -> <a class="nav" href="{U_ALBUM}">{L_ALBUM}</a> -> <a class="nav" href="{U_VIEW_CAT}">{CAT_TITLE}</a></span></td>
  </tr>
</table>

<table width="100%" cellpadding="2" cellspacing="1" border="0" class="forumline">
  <tr>
	<th class="thTop" height="25">{PIC_TITLE}</th>
  </tr>
  <tr>
	<td class="row1" align="center"><img src="http://YOUR-DOMAIN/phpBB/album_mod/upload/{PIC_FILENAME}" border="0" vspace="10" alt="{PIC_TITLE}" title="{PIC_TITLE}" /></td>
  </tr>
  <tr>
	<td class="row2"><table width="90%" align="center" border="0" cellpadding="3" cellspacing="2">
	  <tr>
		<td width="25%" align="right"><span class="genmed">{L_POSTER}:</span></td>
		<td><span class="genmed"><b>{POSTER}</b></span></td>
	  </tr>
	  <tr>
		<td valign="top" align="right"><span class="genmed">{L_PIC_TITLE}:</span></td>
		<td valign="top"><b><span class="genmed">{PIC_TITLE}</span></b></td>
	  </tr>
	  <tr>
		<td valign="top" align="right"><span class="genmed">{L_PIC_DESC}:</span></td>
		<td valign="top"><b><span class="genmed">{PIC_DESC}<br><br><hr align="left" width="70%" color=#F0FFFF size=2></span></b></td>
	  </tr>
	  <tr>
		<td valign="top" align="right"><span class="genmed">Link Direct to Image:</span></td>
		<td valign="top"><span class="genmed"><font color="#00008B">[img]http://YOUR-DOMAIN/phpBB/album_mod/upload/{PIC_FILENAME}[/img]</font><hr align="left" width="70%" color=#F0FFFF size=2"></span></td>
	  </tr>
	  <tr>
		<td valign="top" align="right"><span class="genmed">Link Direct to Thumbnail:</span></td>
		<td valign="top"><span class="genmed"><font color="#00008B">[img]http://YOUR-DOMAIN/phpBB/album_mod/upload/cache/{PIC_FILENAME}[/img]</font><hr align="left" width="70%" color=#F0FFFF size=2></span></td>
	  </tr>
	  <tr>
		<td align="right"><span class="genmed">{L_POSTED}:</span></td>
		<td><b><span class="genmed">{PIC_TIME}</span></b></td>
	  </tr>
	  <tr>
		<td align="right"><span class="genmed">{L_VIEW}:</span></td>
		<td><b><span class="genmed">{PIC_VIEW}</span></b></td>
	  </tr>
	  <!-- BEGIN rate_switch -->
	  <tr>
		<td valign="top" align="right"><span class="genmed"><a href="{U_RATE}">{L_RATING}:</a></span></td>
		<td><b><span class="genmed">{PIC_RATING}</span></b></td>
	  </tr>
	  <!-- END rate_switch -->
	  <!-- BEGIN comment_switch -->
	  <tr>
		<td align="right"><span class="genmed"><a href="{U_COMMENT}">{L_COMMENTS}:</a></span></td>
		<td><b><span class="genmed">{PIC_COMMENTS}</span></b></td>
	  </tr>
	  <!-- END comment_switch -->
	</table></td>
  </tr>
  <tr>
	<td class="catbottom" align="center" height="28"><span class="cattitle">&laquo; <a href="{U_PREVIOUS}" class="cattitle">{L_PREVIOUS}</a>&nbsp;-&nbsp;<a href="{U_NEXT}" class="cattitle">{L_NEXT}</a> &raquo;</span></td>
  </tr>
</table>

<br />

<!--
You must keep my copyright notice visible with its original content
-->
<div align="center" class="copyright">Powered by Photo Album {ALBUM_VERSION} &copy; 2002-2003 <a href="http://smartor.is-root.com" target="_blank">Smartor</a></div>
Be sure to change "YOUR-DOMAIN/phpBB/" to your own required address. It's in 3 places, at the beginning and 2 more in the middle.

Linking to images this way, bypassess the annoying refresh-every-time that happened to posts linked to Album images (as well as when viewing album images) because they weren't being cached locally. Plus a MOD I installed to limit-image-width wasn't working if linked to the Album pages (using other tweaks that were posted). This circumvents all those annoyances. Until some better way comes up to link direct to the images for posting, I'll just have to put up with the security problem of off-site linking.
MVH - Webmaster Jim
My portfolio Portfolio
Forum for recipes Recipe Banks Cook Book
E-Cards Postcard
Photo gallery Gallery
Smoothice
Registered User
Posts: 42
Joined: Sat Feb 19, 2005 8:02 am

Post by Smoothice »

Is there a way to upload a large file and have it create both the thumbnail picture and a reduced size picture. The reason for this is that when I take pictures with my digital camera they are 2 megs in size, I have to use a imagereducer program to reduce every image. I know the thumbnails are created automatically, so it shouldn't be too much of a problem to code the piece needed to create a resized main image.

If this is possible and I have just missed it please let me know. We are using this as a family website and would like a nice easy method for all of our family accross the country be able to upload pictures without having everyone resize them.

Smoothice
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Post by Martin Truckenbrodt »

Hello,
Smartor Photo Album FAQ: http://smartor.is-root.com/viewtopic.php?t=14680

Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
PHK
Registered User
Posts: 31
Joined: Sun Jul 31, 2005 10:22 am

Post by PHK »

Okay ....

how do I remove the "Users Personal Galleries >> Your Personal Gallery" all together. I don't want these categories since I don't want all members to be able to create photo galleries.

I want something a little more structured and something more simple.

I want to use the "Public Categories" as the main photo albums for users who have galleries and set up permissions for only those select users to use those photo albums. I don't want any other categories, or a lot of galleries, only a select few.

Can anyone point me to the correct files to edit? I have be unlucky in my search for where the code resides.
User avatar
Martin Truckenbrodt
Registered User
Posts: 3045
Joined: Sun Mar 23, 2003 6:22 pm
Location: Franconia
Name: Martin Truckenbrodt
Contact:

Post by Martin Truckenbrodt »

Hello,
IMO it would be better for you to disable the Public galleries and only to allow Personal galleries. Look at the possible features in the ACP.

Bye Martin
Free tutorial: Installing MODs in phpBB 3.0
Advanced Block MOD - Prevent spam on your phpBB 3.0 board with Stop Forum Spam, BotScout, Akismet, Project Honey Pot and several IP-RBL and Domain-RBL DNS blacklists!
My MODs
Use the official phpBB Ideas to vote missing core features!!!
Locked

Return to “[2.0.x] MODs in Development”