[ABD] Approve Mod

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
safeTsurfa
I've Been Banned!
Posts: 1959
Joined: Sat May 08, 2004 10:21 am
Location: United Kingdom
Contact:

Post by safeTsurfa » Wed Jun 16, 2004 8:41 am

Maybe you all have conflicts with other MODs or something? I have 2.0.8 and v.1.0.9 of this MOD, and it works just dandy.
safeTsurfa
Need help? First READ THIS
Personal projects: My Mods

Elad Repooc
Registered User
Posts: 8
Joined: Tue Dec 09, 2003 9:11 am

Post by Elad Repooc » Wed Jun 16, 2004 8:44 am

i only use xtrem styles...
well, i'm going to install a fresh phpbb and install the approve mod to see what happens :)

Elad Repooc
Registered User
Posts: 8
Joined: Tue Dec 09, 2003 9:11 am

Post by Elad Repooc » Wed Jun 16, 2004 8:56 am

ok, i've just quickly installed a new phpbb 2.0.8a and the approve mod 1.1.0 in it
i got exactly the same problems

i'm gonna give a try to 1.0.9

Elad Repooc
Registered User
Posts: 8
Joined: Tue Dec 09, 2003 9:11 am

Post by Elad Repooc » Wed Jun 16, 2004 9:43 am

it's ok with 1.0.9 8)

btw, thanks for this wonderful MOD

AceMan
Registered User
Posts: 337
Joined: Thu Nov 15, 2001 6:47 am
Contact:

Post by AceMan » Thu Jun 17, 2004 9:21 pm

can you assist me in debugging the 1.1.0? URLs & examples would be helpful

User avatar
uncle.f
Registered User
Posts: 253
Joined: Thu Mar 25, 2004 11:42 am
Location: Purple Yonder
Contact:

Post by uncle.f » Fri Jun 18, 2004 3:51 pm

First of all thank you very much for developing such an excellent MOD.

I can confirm the following bugs with PHPBB 2.0.8a and Approve MOD 1.1.0:

* Approving posts in the "posts" part in administration panel doesn't work (in front it works)

* Removing auto-approval of the topic in the admin panel doesn't work (in front works)

* I am using the notification to approve posts by email. Using the approve link has no effect, unless I log-on to PHPBB first. (I guess that does make sense after all, but I wonder if there is a way to force a login using an HTML link??).

* Cannot comment on auto-approving user (we do not use this feature here)

---------------------------------------------------------------------

Very useful MOD, unfortunately does not fully work. I did fresh install of PHPBB 2.0.8a without any MODs. After that I unzipped all the files from the Approve MOD directory called "phpBB2.0.8a" and run the SQL queries from the "mysql_schema.sql". Nothing else added or removed.

Would somebody be kind enough to provide the link to 1.0.9 version which is supposed to work better?

Thanks!

AceMan
Registered User
Posts: 337
Joined: Thu Nov 15, 2001 6:47 am
Contact:

Post by AceMan » Fri Jun 18, 2004 9:21 pm

1.0.9 works (but isn't efficient & fast), i'll rezip the thing with preserve directories, i'll be doing 1.1.1 with bugfixes shortly, thx for the reports!

AceMan
Registered User
Posts: 337
Joined: Thu Nov 15, 2001 6:47 am
Contact:

Post by AceMan » Fri Jun 18, 2004 9:25 pm

1.0.9 um..

http://www.synace.com/projects/phpBBmod ... .1.0.9.zip

The full edited files were for 2.0.6, so you'll have to edit these manually.

update on 1.1.1: I've almost fixed the bugs in index, gonna add 1 more query to fix post counts, then i'll move on to viewforum.

User avatar
uncle.f
Registered User
Posts: 253
Joined: Thu Mar 25, 2004 11:42 am
Location: Purple Yonder
Contact:

Post by uncle.f » Mon Jun 21, 2004 10:58 am

Thank you very much for a feedback!
I guess I'll wait for the new version then...

I do not want to rush you in any way or to put any pressure on you, but do you have any rough idea or a guesstimate on when we could possibly test the new version?

Thanks again!

jayb
Registered User
Posts: 9
Joined: Mon Jan 19, 2004 2:10 am

Bugs

Post by jayb » Mon Jun 28, 2004 2:00 am

AceMan wrote: can you assist me in debugging the 1.1.0? URLs & examples would be helpful
There is a bug somewhere in the new code updating "viewforum.php" and "index.php". The problem is the Last Post date and username is not correct on any post waiting for approval. Instead it lists a post that was made a week ago in some cases and in other cases a few days ago. This did not start happening until I did the updates posted. When I removed all new updates the problem dissappeared.

natchswing
Registered User
Posts: 2
Joined: Tue Mar 16, 2004 11:18 pm

Post by natchswing » Tue Jun 29, 2004 4:37 pm

[EDIT]: EasyMod couldn't move templates and my manual moving went to wrong folder. Fixed.
-
natch

AceMan
Registered User
Posts: 337
Joined: Thu Nov 15, 2001 6:47 am
Contact:

Re: Bugs

Post by AceMan » Thu Jul 01, 2004 4:44 pm

jayb wrote:
AceMan wrote:can you assist me in debugging the 1.1.0? URLs & examples would be helpful
There is a bug somewhere in the new code updating "viewforum.php" and "index.php". The problem is the Last Post date and username is not correct on any post waiting for approval. Instead it lists a post that was made a week ago in some cases and in other cases a few days ago. This did not start happening until I did the updates posted. When I removed all new updates the problem dissappeared.


i've addressed this issue, next version will show properly again.

BrianW
Registered User
Posts: 21
Joined: Tue Jun 25, 2002 5:53 am

Post by BrianW » Sun Jul 11, 2004 11:05 pm

Any support with Approve Mod 1.1.0 and CH 2.0.4?

I've installed Approve Mod 1.1.0 on our forum and there was a spot for every code but this for index.php and the mod fails to work correctly :boggle:
The place where the below code is to be entered is deleted out and I have no idea where to place it and what else to do to make it work correctly :-/

Code: Select all

//
// Begin Approve_Mod Block : 1.1.0_index_2
//

							if ( !empty($approve_forums_last_posts[$j]) )
							{
								if ( $approve_forums_last_posts[$j] == ANONYMOUS )
								{
									$last_post = create_date($board_config['default_dateformat'], $forum_data[$j]['post_time'], $board_config['board_timezone']) . '<br />';
									$last_post .= $lang['Guest'] . '  ' . '<a href="' . append_sid("viewforum.$phpEx?"  . POST_FORUM_URL . '=' . $forum_data[$j]['forum_id']) . '"><img src="' . $images['icon_latest_reply'] . '" border="0" alt="' . $lang['View_latest_post'] . '" title="' . $lang['View_latest_post'] . '" /></a>';
								}
								else
								{
									$last_post = $approve_forums_last_posts[$j];
								}
							}
							
//
// End Approve_Mod Block : 1.1.0_index_2
//
Other than that, it seems to work correctly, untill I finally try to make a post with a user who is moderated and then I get the error, but the post is there and says awaiting notification but I get no notice that it was made :(
Fatal error: Call to undefined function: from() in /home/therunes/public_html/forums/posting.php on line 1061

Code: Select all

								$emailer = new emailer($board_config['smtp_delivery']);
[LINE 1061]						$emailer->from($board_config['board_email']);
								$emailer->replyto($board_config['board_email']);
								$emailer->use_template('privmsg_notify', $to_userdata['user_lang']);
Great mod bud, can't wait to fully use it :)

tedist_god
Registered User
Posts: 13
Joined: Tue May 11, 2004 3:41 pm

Post by tedist_god » Wed Jul 14, 2004 8:13 pm

I dont know if this mod does this but i am going to ask anyway.. can i only make one section of my forum have approval for example i would like all of my forums to work without aproval except a forum called "game reviews" is this possible and i couldnt find a link on the first page for the actual mod they seem to have all gone dead, any help...
thx,

ted

AceMan
Registered User
Posts: 337
Joined: Thu Nov 15, 2001 6:47 am
Contact:

Post by AceMan » Wed Jul 14, 2004 10:36 pm

my server goes up/down from time to time (the soft raid HPT37x controller bonks out on me sometimes and freezed the box)...

it should be back up now.. but yes, this mod would perform as your needs suggest.

Locked

Return to “[2.0.x] MODs in Development”