[ALPHA] 0.0.4 User Control Panel for phpBB 2.0.4

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply
president
Registered User
Posts: 169
Joined: Thu Apr 04, 2002 11:31 pm

Post by president »

khisanthax wrote: hehe, if yer mockin' me, it's all good =)

I don't know, I had a problem before and it was the same thing, I think it has to do with my browser caching the pages and getting them confuddled??? It's slightly annoying . . . thanks for the help though, sincerely


I wasn't trying to sound like an ass. I figured it might have been your cache settings alright.

EwaldB wrote: Hello president!

What's about [ALPHA] 0.0.6 ?? :wink:

Wish you a nice day!
Ewald


what happened to 0.0.5?
EwaldB
Registered User
Posts: 39
Joined: Sun Mar 02, 2003 2:50 pm

Post by EwaldB »

OK! I accept Final 1.0 :)
Just asking...
khisanthax
Registered User
Posts: 443
Joined: Sun Mar 02, 2003 1:49 am

Post by khisanthax »

I wasn't trying to sound like an ass. I figured it might have been your cache settings alright.


oh I know, I was just kidding with you
User avatar
Rakshasas
Registered User
Posts: 54
Joined: Thu Jan 16, 2003 11:19 pm
Location: Ontario, Canada

Post by Rakshasas »

Hey, this mod is great! Was easy to install, even on a non-subSilver theme. I definitely have to watch this thread because I love this mod. Great work.
khisanthax
Registered User
Posts: 443
Joined: Sun Mar 02, 2003 1:49 am

Post by khisanthax »

so far I've added netclectics minical without a hitch, but now I'm trying to add the ignore hack but it's not quite working. I took the everything in the form and pasted it over. But no text shows up, which lines of code do I have to add to usercp.php for the text to show up? The define parameters or something else?
president
Registered User
Posts: 169
Joined: Thu Apr 04, 2002 11:31 pm

Post by president »

khisanthax wrote: so far I've added netclectics minical without a hitch, but now I'm trying to add the ignore hack but it's not quite working. I took the everything in the form and pasted it over. But no text shows up, which lines of code do I have to add to usercp.php for the text to show up? The define parameters or something else?


eh.. sorry i don't know. I'll look into making an ignore user feature for this mod.
khisanthax
Registered User
Posts: 443
Joined: Sun Mar 02, 2003 1:49 am

Post by khisanthax »

okay, I was just thinking that it would be easier to just include the one already made, but alright, thanks
Schumi
Registered User
Posts: 177
Joined: Wed Dec 18, 2002 8:09 pm

Post by Schumi »

When I run bud_install.php, I get the following error:

Code: Select all

Warning: Failed opening '/www/htdocs/v033658/bud_install.php' for inclusion (include_path='.:..') in Unknown on line 0
User avatar
Grema
Registered User
Posts: 36
Joined: Tue Feb 25, 2003 3:16 pm

Post by Grema »

What's this about? :(
After the installation,i tried to go to UCP,but i got this message
Fatal error: Cannot redeclare get_db_stat() in ./includes/functions.php on line 24

I'm completle shure that i've done all right,'cause i checked it up a few times.What is this and how to fix that problem&((
khisanthax
Registered User
Posts: 443
Joined: Sun Mar 02, 2003 1:49 am

Post by khisanthax »

what I did, and backup before you do this, is change include() to include_once() and that fixed it for me. back up your files first, I'm in NO way responsible for the after effects =)
User avatar
Grema
Registered User
Posts: 36
Joined: Tue Feb 25, 2003 3:16 pm

Post by Grema »

and where exactly i do this?))
khisanthax
Registered User
Posts: 443
Joined: Sun Mar 02, 2003 1:49 am

Post by khisanthax »

oops, sorry, it's in functions.php
khisanthax
Registered User
Posts: 443
Joined: Sun Mar 02, 2003 1:49 am

Post by khisanthax »

see, I think that the ucp is a great idea. And I would like to add or tie in things like: recent announcements. I'm using napoleons quiz mod on my site so I'd like to add a recent quizes part too. is there any way that I can do this myself simply by copying and pasting over the tpls and some code or does it have to be re-written so I can add stuff as time goes along?
User avatar
jvini
Registered User
Posts: 300
Joined: Tue Sep 24, 2002 11:20 pm
Contact:

Post by jvini »

Haven't had time to sift through previous posts, but here are some 'modules' I'd love to see...

- Private Messages (Recent, Replied, etc.)
- Your Information (box with profile info, with avatar, total posts, etc.)
- Points System Module (inside the 'your info' box)
- Album Module (last pic posted; personal gallery info)
- Last post in selected forum (in Admin-defined forum, latest post)

I know not all this could be implemented, but just feeding ideas! :D

Great mod, great potential!
Josh Windu
Registered User
Posts: 377
Joined: Sun Jul 14, 2002 3:14 am
Location: Australia
Contact:

Post by Josh Windu »

Great mod guys!!!
Just installed on my boards well done!

to add the buddy image on viewprofile:

Code: Select all

Open: 
includes/usercp_viewprofile.php

Find:
$www = ( $profiledata['user_website'] ) ? '<a href="' . $profiledata['user_website'] . '" target="_userwww">' . $profiledata['user_website'] . '</a>' : '&'

Add after:
$buddy_img = ( '<a href="buddycp.php?mode=add&t='.$topic_id.'&u='.$profiledata['user_id'].'"><img src="' . $images['icon_buddy'] . '" alt="Add user to Your Buddy List" title="Add user to Your Buddy List" border="0" /></a>');

Find:
'WWW' => $www,

Add after:
'ADD_BUDDY' => $lang['add_buddy'],
'BUDDY_IMG' => $buddy_img,


open: 
templates/subsilver/profile_view_body.tpl

Find:
	<td class="catLeft" align="center" height="28"><b><span class="gen">{L_CONTACT} {USERNAME} </span></b></td>
  </tr>
  <tr> 
	<td class="row1" valign="top"><table width="100%" border="0" cellspacing="1" cellpadding="3">

Add after:
<tr> 
  <td valign="middle" align="right" nowrap="nowrap"><span class="gen">{ADD_BUDDY}</span></td>
<td class="row1" valign="middle" width="100%"><b><span class="gen">{BUDDY_IMG}</span></b></td>
   </tr>


Open:
language/lang_english/lang_main.php

Find:
$lang['sub_to_thread'] = 'Subscribe to this Thread';

Add after:
$lang['add_buddy'] = 'Add Buddy:';

EOM
I dont know if it has been done already but there it is if you need to know ;)
Last edited by Josh Windu on Sun Mar 30, 2003 4:52 am, edited 2 times in total.
Nitrotech - Alpha stage... Your own fully customisable forum! and site!
Post Reply

Return to “[2.0.x] MODs in Development”