[BETA] Lottery Mod

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
Antony
Registered User
Posts: 529
Joined: Wed Feb 12, 2003 9:06 am

Post by Antony »

Sorry, about the btea testing.

I ran it on my test baord because it was beta.
Threatcon
Registered User
Posts: 131
Joined: Tue Dec 10, 2002 5:38 am
Location: Florida
Contact:

Post by Threatcon »

Hey MJ, need to fix the part where you don't have enough points to buy a ticket. Says something that doesn't make sense! LOL

The updated worked good Zarath! Nice, thankx!! 8) :D
younghistorians
Registered User
Posts: 368
Joined: Mon Sep 16, 2002 9:17 pm
Location: YoungHistorians.com
Contact:

Post by younghistorians »

hey zarath-
why are they shutting em down?
Zarath
Registered User
Posts: 736
Joined: Fri Dec 06, 2002 9:01 am
Contact:

Post by Zarath »

NM, they unlocked it. However, I do need help getting my mods into "phpBB standards" so they can be released into this database. I personally don't have enough time. So if anyone wants to help, I'm willing to take it. :)
younghistorians
Registered User
Posts: 368
Joined: Mon Sep 16, 2002 9:17 pm
Location: YoungHistorians.com
Contact:

Post by younghistorians »

i might be able to. PM me with what i need to do.
MJ
Registered User
Posts: 180
Joined: Thu Jan 03, 2002 10:20 pm
Contact:

Post by MJ »

Zarath, I've found two typos in the Lottery zip I sent to you! (One Threatcon noted!)

Also bug seems to be same user winner draw after draw!

And if you want help, you know where to find me ;)
Zarath
Registered User
Posts: 736
Joined: Fri Dec 06, 2002 9:01 am
Contact:

Post by Zarath »

MJ, the version of the lottery you sent me, does that conform to phpBB standards? or just the lang files? :|
MJ
Registered User
Posts: 180
Joined: Thu Jan 03, 2002 10:20 pm
Contact:

Post by MJ »

only language, really need to get the template data out of the php files and into templates, I didnt do that yet, I can if you like?
www.pittt.tk
Registered User
Posts: 167
Joined: Tue Mar 18, 2003 7:33 pm

Post by www.pittt.tk »

just thought I'd say I have had no probems with this mod another success zarath well done
check out http://www.pittt.tk

A msg board with loads of mods
User avatar
Suede
Registered User
Posts: 342
Joined: Sat Dec 14, 2002 7:40 pm

Post by Suede »

same here!
User avatar
Serial^Killer
Registered User
Posts: 22
Joined: Wed Mar 12, 2003 8:25 pm

Post by Serial^Killer »

Same Here :)
Zarath
Registered User
Posts: 736
Joined: Fri Dec 06, 2002 9:01 am
Contact:

Post by Zarath »

-> MJ.

If you can, that would be great. Thanks. Email it to me once you're done. :)
Antony
Registered User
Posts: 529
Joined: Wed Feb 12, 2003 9:06 am

Post by Antony »

Is it possible to alter the outcome?
;)
User avatar
mrtaz4u
Registered User
Posts: 246
Joined: Mon Nov 11, 2002 4:55 am
Location: new york
Contact:

Post by mrtaz4u »

my phpmyadmin under my forum has
config_value

but according to the lottery_install.php

it tries to find config_values.

here is the error

Running :: create table `phpbb_lottery` (`id` INT UNSIGNED NOT NULL AUTO_INCREMENT, `user_id` INT (20) NOT NULL, PRIMARY KEY(`id`), INDEX(`user_id`)) -> COMPLETED

Running :: INSERT INTO config VALUES ('lottery_cost', '1') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_ticktype', 'single') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_length', '500000') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_reset', 'off') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_status', 'off') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_name', 'Lottery') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_base', '500') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_start', '0') -> FAILED ---> Column count doesn't match value count at row 1

Running :: INSERT INTO config VALUES ('lottery_lastwon', '') -> FAILED ---> Column count doesn't match value count at row 1

thanks

taz
User avatar
scoobie
Registered User
Posts: 237
Joined: Sun May 12, 2002 6:07 pm

Post by scoobie »

try changing config to phpbb_config (or whatever your table prefix is)

INSERT INTO phpbb_config VALUES ('lottery_cost', '1')
You can have it all if you like... but you can pay for it the rest of your life.
Locked

Return to “[2.0.x] MODs in Development”