[DEV] NewsSync (Usenet -> phpBB Sync)

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
reco
Registered User
Posts: 8
Joined: Sun May 25, 2003 9:04 pm
Contact:

Post by reco »

reco wrote: Hi,

I have installed PNphpBB2 as part of my postnuke intergration. I have setup newssync in a subdirectory of:

postnuke/modules/PNphpBB2/newssync/

When I try and run anything there is just a white screen and nothing happens. I see in a previous post you are considering supporting PNphpBB2 with Newssync. I at least would much appreciate this and I'm sure many would as this is a great tool

Thanks


Do you have any more new on this Wineknow?

Cheers
wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow »

I hope to start a new beta round over the next week or so.
It will include a number of enhancements including support for PNphpBB2
-k
reco wrote:
reco wrote:Hi,

I have installed PNphpBB2 as part of my postnuke intergration. I have setup newssync in a subdirectory of:

postnuke/modules/PNphpBB2/newssync/

When I try and run anything there is just a white screen and nothing happens. I see in a previous post you are considering supporting PNphpBB2 with Newssync. I at least would much appreciate this and I'm sure many would as this is a great tool

Thanks


Do you have any more new on this Wineknow?

Cheers
reco
Registered User
Posts: 8
Joined: Sun May 25, 2003 9:04 pm
Contact:

Post by reco »

wineknow wrote: I hope to start a new beta round over the next week or so.
It will include a number of enhancements including support for PNphpBB2
-k



Much appreciated your support for PNphpBB2. Look forward to trying it out and intergrating it into my site.

And also thankyou very much for the quick response. 2 minutes - thats what I call support :)

regards
Steve.W
http://www.alienexistence.com
UK UFO Petition : Seeking truth into UFO visitation to Planet Earth.
LongSteve
Registered User
Posts: 2
Joined: Thu Jul 17, 2003 2:09 pm

Post by LongSteve »

Thanks very much for the reply. I'll keep watching this topic. Do you post here when a new release is available?

Thanks again for a great piece of software though. You usually can't please all the people all the time. But since I can offer our small company a web forum and usenet server with the private groups kept in sync, I can get very close.

Thanks,

Steve
VANuker
Registered User
Posts: 3
Joined: Fri Jul 18, 2003 2:35 pm

Post by VANuker »

I'm using newssync 1.0.4 and had been using it successfully for some time now. I installed a new hard drive in my linux server the other day but kept /var/www on the old, original hard drive, but when I started everything back up newssync no longer works.

When I run newssync I get the following now:

[root@www newssync]# php -q newssync.php

NewsSync for phpBB version 1.0.4
(c) copyright 2003 wineknow.com
WARNING: could not set memory limit to 100M

Syncing: usenet:rec.arts.comics.misc with phpBB:Misc
- NNTP ERROR: connection error
- NNTP ERROR: connection failed
Unrecoverable Error with nntp server...quitting


That's not much to go on, but there's nothing wrong with my news server, which is running on another server. I connect to it all the time via my news reader. Since I made no changes to /var/www or to newssync_config.php I'm a little at a aloss why this error would be occuring now. I did run 'newssync.php?checkconfig=1' and got

NewsSync for phpBB version 1.0.4
(c) copyright 2003 wineknow.com
WARNING: could not set memory limit to 100M

-- Current PHP version: 4.2.3
-- phpBB version 2.0.3
-- Local time offset for phpBB is -5 GMT
-- Using Interface Type: apache -- phpNUKE integration enabled Warning: Could not set memory limit to 100M only allocated
-- Checking max_execution_time override...ok

* Checking file permissions
-- checking for write access in ./data directory...ok

* Checking database:
-- newssync_data table installed in database....ok

* Configured newsgroup syncs:
[snipped]

Configuration check sucessfull.


Any ideas what I should be checking next?
wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow »

this indicates that your server cannot connect to the nntp server.
can run a usenet client on your server to see if you can connect?
try that first...
if you can't you have some sort of netowrking problem
if you can, then double check the config file....

-k
VANuker wrote: yncing: usenet:rec.arts.comics.misc with phpBB:Misc
- NNTP ERROR: connection error
- NNTP ERROR: connection failed
Unrecoverable Error with nntp server...quitting
qnx
Registered User
Posts: 69
Joined: Fri Mar 28, 2003 6:03 am

Post by qnx »

VANuker wrote: - NNTP ERROR: connection error
- NNTP ERROR: connection failed
Unrecoverable Error with nntp server...quitting


do a quick test from your webserver to your news server.
On your webserver, run

telnet your_news_server 119

and post the result.
VANuker
Registered User
Posts: 3
Joined: Fri Jul 18, 2003 2:35 pm

Post by VANuker »

qnx wrote:
VANuker wrote: - NNTP ERROR: connection error
- NNTP ERROR: connection failed
Unrecoverable Error with nntp server...quitting


do a quick test from your webserver to your news server.
On your webserver, run

telnet your_news_server 119

and post the result.


That's really odd. I get a connection error. Wonder what could be causing that because I can connect to my news server from every other system on my network.
wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Post by wineknow »

VANuker wrote: That's really odd. I get a connection error. Wonder what could be causing that because I can connect to my news server from every other system on my network.


one of two reasons:
a) the newsserver is blocking your ip address (or has not authorized your ip address - depending on config
b) your server does not allow outgoing traffic on that port

try to connect to a different "known working" nntp server to cross out item b.

-k
Zorro-the-Cat
Registered User
Posts: 5
Joined: Wed Jul 23, 2003 9:21 pm

Urgent: Does NewsSync honor the X-No-Archive tag?

Post by Zorro-the-Cat »

Folks,

I have been running this wonderful script for a while now and use it to archive a newsgroup in my forum.

Today, I have gotten a request from a participant of the newsgroup who asks me to delete his postings since he uses the X-No-Archive tag in his messages. I've checked on Google and found that his postings don't appear there, so Google honors the tag.

I want to respect his wish because I don't want trouble with the newsgroup's members.

Problem #1: How can I delete his postings permanently from my forum? I've been going through most of these 28 pages here (whew) and read that deleted messages seem to "come back" as long as they still sit on the news server.

Problem #2: How can I convince NewsSync not to import messages with the X-No-Archive tag? I've found one occurrence in the code but can't make much of it since I'm no PHP expert.

I'm running NewsSync version 1.01b2 currently.

Any help would be much appreciated.

Thanks,
Zorro
wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Re: Urgent: Does NewsSync honor the X-No-Archive tag?

Post by wineknow »

Zorro-the-Cat wrote: Folks,

I have been running this wonderful script for a while now and use it to archive a newsgroup in my forum.

Today, I have gotten a request from a participant of the newsgroup who asks me to delete his postings since he uses the X-No-Archive tag in his messages. I've checked on Google and found that his postings don't appear there, so Google honors the tag.

I want to respect his wish because I don't want trouble with the newsgroup's members.

Problem #1: How can I delete his postings permanently from my forum? I've been going through most of these 28 pages here (whew) and read that deleted messages seem to "come back" as long as they still sit on the news server.

Problem #2: How can I convince NewsSync not to import messages with the X-No-Archive tag? I've found one occurrence in the code but can't make much of it since I'm no PHP expert.

I'm running NewsSync version 1.01b2 currently.

Any help would be much appreciated.

Thanks,
Zorro


interesting. I will take a look and hopefully be able to add it to the new beta cycle coming up in a week or so. I will keep you posted.'
-k
Zorro-the-Cat
Registered User
Posts: 5
Joined: Wed Jul 23, 2003 9:21 pm

Post by Zorro-the-Cat »

Wow. That's what I call a quick reply.

I managed to delete all posts manually by running

Code: Select all

DELETE FROM phpbb_posts WHERE post_username="firstname lastname";
but I'm afraid I'll have to do this daily.

I'll be checking back here regularly. Thanks for your answer.

Zorro
wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

Ignoring: X-No-archive messages

Post by wineknow »

Zorro-the-Cat wrote: Wow. That's what I call a quick reply.

I managed to delete all posts manually by running

Code: Select all

DELETE FROM phpbb_posts WHERE post_username="firstname lastname";
but I'm afraid I'll have to do this daily.

I'll be checking back here regularly. Thanks for your answer.

Zorro


For everyone that is archiving newsgroups, you should honour the X-No-Archive bit. Currently newssync "forgot" about this.

So you need to add the following to your code [note that this has not been fully test]

In newssync.php:

under the lines:

Code: Select all

	// read message headers
	$allHeaders = readOverview($ns, $mygroup,1);
add the following:

Code: Select all

				foreach ($allHeaders as $akey => $aheader) {
					if (strlen($aheader->xnoarchive) > 1) {
						LogIt("-- Ignoring X-No-Archived Message: " . $aheader->subject, 2);
						unset($allHeaders[$akey]);
					}
				}
this is a quick fix but should do as advertised. If anyone has trouble with this, please let me know.

this will be built-into the next release.

-k
Zorro-the-Cat
Registered User
Posts: 5
Joined: Wed Jul 23, 2003 9:21 pm

Post by Zorro-the-Cat »

Trying it now. Will let you know asap.

Thanks for your quick help; it is very much appreciated.

Zorro
wineknow
Registered User
Posts: 299
Joined: Tue Mar 04, 2003 5:20 pm
Location: Calgary, Alberta, Canada
Contact:

NewsSync 1.5.0 beta -- and new topic

Post by wineknow »

I have decided to split this forum at this point as it is getting quite large.
Please goto topic: NewsSync 1.5 Beta

Please only discuss version 1.0.x in this topic.
thanks,
-k
Post Reply

Return to “[2.0.x] MODs in Development”