[ABD] Activity MOD

A place for MOD Authors to post and receive feedback on MODs still in development. No MODs within this forum should be used within a live environment! No new topics are allowed in this forum.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: MOD Development Forum rules

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Locked
Jypsy
Registered User
Posts: 7
Joined: Fri Jun 13, 2003 4:01 pm
Location: Milwaukee, WI
Contact:

well I installed it, and........

Post by Jypsy »

Well i installed the mod last night and suddenly im getting this error.

phpBB : Critical Error

Could not query config information

DEBUG MODE

SQL Error : 1146 Table 'a00i1ch9._bbconfig' doesn't exist

SELECT * FROM _bbconfig

Line : 176
File : /web2/a00i1ch9/docs/phpBB2/common.php


im somewhat confused now.
mrsingh816
Registered User
Posts: 22
Joined: Sun Jul 06, 2003 1:42 am
Contact:

Post by mrsingh816 »

hello, can someone tell me if this mod has been coded to make flash games work with the scoring system?
Dinosaur Gas
Registered User
Posts: 71
Joined: Thu Jul 11, 2002 11:56 pm
Contact:

Post by Dinosaur Gas »

mrsingh816 wrote: hello, can someone tell me if this mod has been coded to make flash games work with the scoring system?


Not yet, the author is working on it though.
Image
Jypsy
Registered User
Posts: 7
Joined: Fri Jun 13, 2003 4:01 pm
Location: Milwaukee, WI
Contact:

Post by Jypsy »

dinosaur, did you ever encounter the problem i posted above? or hear of what could have caused it?
darrenc
Registered User
Posts: 18
Joined: Thu Jan 09, 2003 3:02 am
Contact:

Re: well I installed it, and........

Post by darrenc »

Jypsy wrote: Well i installed the mod last night and suddenly im getting this error.

phpBB : Critical Error

Could not query config information

DEBUG MODE

SQL Error : 1146 Table 'a00i1ch9._bbconfig' doesn't exist

SELECT * FROM _bbconfig

Line : 176
File : /web2/a00i1ch9/docs/phpBB2/common.php


im somewhat confused now.


Hi Jypsy, that error message is telling you that that particicular table is not present in your data base, did you up date your sql DB with the supplied tables?

also, if you have updaped your DB did you remove the phpbb from the
INSERT INTO phpbb_config VALUES ('use_point_system', '0');
INSERT INTO phpbb_config VALUES ('use_gamelib', '1');
INSERT INTO phpbb_config VALUES ('games_path', 'games');
INSERT INTO phpbb_config VALUES ('gamelib_path', 'gamelib');
INSERT INTO phpbb_config VALUES ('use_gk_shop', '0');


you need to either leave them as is, or change the phpbb to the prefix you are using eg
INSERT INTO jypsy_config VALUES ('use_point_system', '0');
INSERT INTO jypsy_config VALUES ('use_gamelib', '1');
INSERT INTO jypsy_config VALUES ('games_path', 'games');
INSERT INTO jypsy_config VALUES ('gamelib_path', 'gamelib');
INSERT INTO jypsy_config VALUES ('use_gk_shop', '0');


the error that is showing is looking at you phpbb2 tables as having no prefix, so I would suggest removing the phpbb_ from sql script so it looks like this
CREATE TABLE phpbb_ina_data (
version varchar(255) default NULL
) TYPE=MyISAM;

INSERT INTO phpbb_ina_data VALUES ('v1.0.0');

INSERT INTO config VALUES ('use_point_system', '0');
INSERT INTO config VALUES ('use_gamelib', '1');
INSERT INTO config VALUES ('games_path', 'games');
INSERT INTO config VALUES ('gamelib_path', 'gamelib');
INSERT INTO config VALUES ('use_gk_shop', '0');

CREATE TABLE phpbb_ina_games (
game_id smallint(5) NOT NULL auto_increment,
game_name varchar(25) default NULL,
game_path varchar(255) default NULL,
game_desc varchar(255) default NULL,
game_charge int(11) unsigned default '0',
game_reward int(11) unsigned NOT NULL default '0',
game_bonus smallint(5) unsigned default '0',
game_use_gl tinyint(3) unsigned default '0',
game_flash tinyint(1) unsigned NOT NULL default '0',
win_width smallint(6) NOT NULL default '0',
win_height smallint(6) NOT NULL default '0',
KEY game_id (game_id)
) TYPE=MyISAM;

CREATE TABLE ina_scores (
game_name varchar(255) default NULL,
player varchar(40) default NULL,
score int(10) unsigned NOT NULL default '0',
date int(11) default NULL
) TYPE=MyISAM;


someone correct me if I'm wrong
darrenc
Registered User
Posts: 18
Joined: Thu Jan 09, 2003 3:02 am
Contact:

Post by darrenc »

or you could need the under score.. I'm still learning myself, but have come accross errors like that when I was first starting out and solved them by simply changing the prefix to the one my phpbb2 board is using..

INSERT INTO _config VALUES ('use_point_system', '0');
INSERT INTO _config VALUES ('use_gamelib', '1');
INSERT INTO _config VALUES ('games_path', 'games');
INSERT INTO _config VALUES ('gamelib_path', 'gamelib');
INSERT INTO _config VALUES ('use_gk_shop', '0');
Jypsy
Registered User
Posts: 7
Joined: Fri Jun 13, 2003 4:01 pm
Location: Milwaukee, WI
Contact:

well i tried to add the code you suggested.

Post by Jypsy »

i tried to add the code into mysql, but now its telling me when i attempt to:

Error

SQL-query :

INSERT INTO config VALUES ('use_point_system', '0')

MySQL said:

Table 'a00i1ch9.config' doesn't exist

so i attempted to change the

INSERT INTO _config VALUES ('use_point_system', '0');
INSERT INTO _config VALUES ('use_gamelib', '1');
INSERT INTO _config VALUES ('games_path', 'games');
INSERT INTO _config VALUES ('gamelib_path', 'gamelib');
INSERT INTO _config VALUES ('use_gk_shop', '0');

into the format that I use which is phpbb_config......

and then this error pops up.

Error

SQL-query :

INSERT INTO phpbb_config VALUES ('use_point_system', '0')

MySQL said:

Duplicate entry 'use_point_system' for key 1


Sorry guys im just not getting this, is there a way to CLEAN OUT the tables that this script generated and then try adding the tables again? otherwise im completely open to suggestion!
thanks!
darrenc
Registered User
Posts: 18
Joined: Thu Jan 09, 2003 3:02 am
Contact:

Post by darrenc »

yep, you can clean them out, some of the table updates went through the first time, now that you're putting them in 2nd time, but have only changed a couple of them, it's trying to re-insert tables that are already there..

ok, have you actually viewed your board since updating the tables again?


using the phpbb prefix was right if that's what your board is using, with the duplicate ones, you can remove them from the query as they've already been done

I must also add, I'm using this mod and it's working a treat, no problems so far..
Last edited by darrenc on Mon Jul 07, 2003 2:41 pm, edited 1 time in total.
Jypsy
Registered User
Posts: 7
Joined: Fri Jun 13, 2003 4:01 pm
Location: Milwaukee, WI
Contact:

Post by Jypsy »

Well i really am not good at creating SQL code.....could someone modify the install script that was with the mod so it removes the code?

Sorry to be such a bother, but I dont want to screw something else up :)

oh yeah i tried to view the site and it gave me the exact same error.
darrenc
Registered User
Posts: 18
Joined: Thu Jan 09, 2003 3:02 am
Contact:

Post by darrenc »

hehe, not me, not yet anyway..hehe

I'm sure one of these gurus can help you out though, I just took another look at your error, I'd actually say it's a typo in the pages, not the DB, there is no such table "bbconfig" in phpbb2.. sorry to give you the run around..hehe :P

but I'd go looking through the codes that you changed and see if you can spot it..
Jypsy
Registered User
Posts: 7
Joined: Fri Jun 13, 2003 4:01 pm
Location: Milwaukee, WI
Contact:

Post by Jypsy »

Hmmm i dont see anything in common.php.......


Let me go deeper, Ill let you know if i find anything, until then, any suggestions are GREATLY appreciated.
Napoleon
Registered User
Posts: 413
Joined: Thu Jul 18, 2002 11:31 am

Post by Napoleon »

If you have phpMyAdmin then I can help walk you through the SQL commands, send me a PM or E-mail to setup a chat date. :) If not then I'll make that un-installer for you. :P
Jypsy
Registered User
Posts: 7
Joined: Fri Jun 13, 2003 4:01 pm
Location: Milwaukee, WI
Contact:

Post by Jypsy »

thanks a lot for your help napoleon!
everything is now up and running 10 times better than it was! 8 :D
Napoleon
Registered User
Posts: 413
Joined: Thu Jul 18, 2002 11:31 am

Post by Napoleon »

Great! Glad I could help. :D
Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions »

napolean....

is this out for 2.0.4??
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)
Locked

Return to “[2.0.x] MODs in Development”