Trouble with anti-bot MOD and databases

This forum is now closed as part of retiring phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Post Reply
mattbussey
Registered User
Posts: 30
Joined: Sun May 14, 2006 4:37 am
Contact:

Trouble with anti-bot MOD and databases

Post by mattbussey » Wed Jan 24, 2007 8:02 pm

Howdy,
I'm trying to install the database for using the anti-bot MOD. The MOD says to do this:

CREATE TABLE `phpbb_anti_bot_quest_config` (
`config_name` VARCHAR( 255 ) NOT NULL ,
`config_value` VARCHAR( 255 ) NOT NULL ,
PRIMARY KEY ( `config_name` )
);

I'm trying to do that using phpbbhacks.com but when I run the db_update.php file that it creates, I get the following error:


Warning: main(./extension.inc): failed to open stream: No such file or directory in /home/brewersr/public_html/db_update.php on line 23

Warning: main(./extension.inc): failed to open stream: No such file or directory in /home/brewersr/public_html/db_update.php on line 23

Warning: main(): Failed opening './extension.inc' for inclusion (include_path='.:/usr/local/lib/php') in /home/brewersr/public_html/db_update.php on line 23

Warning: main(./common.): failed to open stream: No such file or directory in /home/brewersr/public_html/db_update.php on line 24

Warning: main(./common.): failed to open stream: No such file or directory in /home/brewersr/public_html/db_update.php on line 24

Warning: main(): Failed opening './common.' for inclusion (include_path='.:/usr/local/lib/php') in /home/brewersr/public_html/db_update.php on line 24

Fatal error: Call to undefined function: session_pagestart() in /home/brewersr/public_html/db_update.php on line 29

Can someone help me out?

Thanks

User avatar
EnjoyNIRVANA!
Registered User
Posts: 376
Joined: Mon Apr 18, 2005 12:57 pm
Location: Germany
Contact:

Post by EnjoyNIRVANA! » Wed Jan 24, 2007 8:17 pm

If that error appears right after you´ve opened the db_update.php then it is the wrong directory.
It hasn´t anything to do with the CREATE TABLE part...

Try to make a new directory called install and put your db_update.php in there. I´m sure that´ll help.

Post Reply

Return to “[2.0.x] MOD Requests”