phpbb 2.0.4 - is it for real?

The 2.0.x discussion forum has been locked; this will remain read-only. The 3.0.x discussion forum has been renamed phpBB Discussion.
DoubleDoom
Registered User
Posts: 844
Joined: Wed Jun 26, 2002 6:48 pm

phpbb 2.0.4 - is it for real?

Post by DoubleDoom » Wed Dec 11, 2002 1:24 am

Just wondering if the phpbb 2.0.4 is going to make it to release or if its something you are tinkering with?

Only reason i ask is that i downloaded the latest beta of it and it was soon apparant that a couple of my mods are going to need a little re-writing to bring them in line with the 2.0.4 code and i know that a number of other mods are too.

User avatar
chAos
Former Team Member
Posts: 4032
Joined: Wed Jan 16, 2002 7:05 am
Location: Seattle, WA, US

Post by chAos » Wed Dec 11, 2002 1:57 am

AFAIK, 2.0.4 is on its way, but i dunno much more.

DanielT
Former Team Member
Posts: 3324
Joined: Tue Aug 27, 2002 10:55 am
Contact:

Post by DanielT » Wed Dec 11, 2002 7:41 am

if you get on the area51 CVS page and download the latest 2.0.x files, then when you downloaded it then look in the docs folder and find the readme file and you can see whats going to be changed between this verison and 2.0.4 (its a lot!)

~edit nm, shame they took the doc's dir out now :(

DoubleDoom
Registered User
Posts: 844
Joined: Wed Jun 26, 2002 6:48 pm

Post by DoubleDoom » Wed Dec 11, 2002 4:47 pm

Yes. I noticed the long list of changes in the changelog and there have been 4 more in todays version.

It looks like the sub-forum mod going to need some rewritten code. I also see that niels yellow card mod and rawleys & gatekeeps supermod code is going to need updating too.

I'm keeping a close eye so i can get my mods updated as quickly as possible

User avatar
SHS`
Former Team Member
Posts: 6615
Joined: Wed Jul 04, 2001 9:13 am
Location: Yellow Beach, Nine Dragons, Hong Kong
Name: Jonathan Stanley
Contact:

Post by SHS` » Wed Dec 11, 2002 6:26 pm

There's always the patch file, then you only have to fix the patching errors. :D
Jonathan “SHS`” Stanley • 史德信
Image

DanielT
Former Team Member
Posts: 3324
Joined: Tue Aug 27, 2002 10:55 am
Contact:

Post by DanielT » Wed Dec 11, 2002 6:35 pm

SHS` wrote: There's always the patch file, then you only have to fix the patching errors. :D


i like to wait for phpbbhacks to bring out the changed file stuff (so it looks like a mod), then i can just edit it line by line

Acyd Burn
Consultant
Consultant
Posts: 5830
Joined: Wed Dec 05, 2001 8:31 pm
Location: Behind You
Name: Meik Sievertsen

Post by Acyd Burn » Wed Dec 11, 2002 7:05 pm

8)

DoubleDoom
Registered User
Posts: 844
Joined: Wed Jun 26, 2002 6:48 pm

Post by DoubleDoom » Wed Dec 11, 2002 7:10 pm

SHS` wrote: There's always the patch file, then you only have to fix the patching errors. :D


Yes but i was thinking of the mods i have created or maintain where the instructions will need re-writing

FX
Registered User
Posts: 254
Joined: Thu Aug 01, 2002 9:29 pm
Location: France
Contact:

Post by FX » Wed Dec 11, 2002 8:53 pm

for seen that this version is there before the 2.2

whofarted
Registered User
Posts: 387
Joined: Tue Apr 09, 2002 8:19 am
Location: Lost, If found return to St.Louis, MO

Post by whofarted » Wed Dec 11, 2002 11:42 pm

eeeh, are you guys going to be using $_GET $_POST etc. on the next release?

I ask because my www host is running php 4.0.6 & it doesn't use that yet. Will there be any soulution for this :?:

/me shakes nervously :cry:
you smell something? :)

MT39503
Registered User
Posts: 31
Joined: Tue Aug 06, 2002 12:15 am

Post by MT39503 » Wed Dec 11, 2002 11:42 pm

For thoes not wanting to download and extract:
Fixed cross-browser scripting issue with highlight param
Back-ported highlighting code from phpBB 2.2
Add session id validation to posting, profile, email, voting - Edwin van Vliet <- FINISH ME!
Added {S_HIDDEN_FIELDS} template var to profile_send_email.tpl
Added "intval" fix for flood check, may resolve some issues
Added missing index to post_id for search_wordmatch
Fixed spelling error in search add words preventing use of stopword list
Fixed issue with search common words not being run
Introduce viewtopic resync patch by Ashe
Replace a for n in templating code
Fixed ordering in memberslist
Fixed group_id sequence issues with pgsql and msaccess <- FINISH ME!
Fixed assumption of word censors in user notification
Fixed incorrect display of quotes in user management fields
Fixed entry of special chars in all profile fields - note this may cause temporary issues
Fixed incorrect display of quotes when using avatar gallery
Fixed missing username in email sent to users when admin activated
Added check for non-empty smiley code and url in smiley admin
Prevent display of -- sig seperator in emails when no board sig exists
Fixed URL propagated sid issues with jumpbox
Fixed wrong mode name check (polldelete) in functions_post
Added missing root path to l10n image path check
Remove validation of fields when deleting a user
Fixed sort mode select box in memberslist to default to current mode
Deny inline topic review listing to users without auth_read permissions
Prevent display of topic notification checkbox if user cannot read forum
Remove incorrect pre-pending of IP to uploaded avatars
Fixed deletion of uploaded avatars when changing to remote/gallery
Added check for non-blank line during install schema/basic sql ops
Added sort ordering to Top Ten poster listing by request
Fixed incorrect error report when altering case of username
Added jumpbox output to modcp {JUMPBOX} will now work
Fixed non-updating of users with MOD levels when deleting a forum
Remove email to group moderator when approving new members
Fixed non-handling of HTML in poll options
Fixed non-deletion of polls when deleting forum and its posts
Fixed moved shadow topic from being bumped upon reply
Changed field size of timezone to decimal(5,2) where applicable
Fixed missing sid append to URL when redirecting to newest reply
Fixed missing slashes in private IP preg check
Fixed session not setting userdata['user_id'] to ANON as appropriate
Added check for non-empty name in disallow admin
Fixed validation of SSL website addresses in profile
Fixed inability of admins to upload avatars via user admin panel
Fixed non-deletion of private message text upon full box overwrite
Fixed incorrect error message in smiley admin
Fixed incorrect alt-text for "Stop Watching Topic" image
Temporary fix for missing lang strings in forum admin - translators should update their packages if not done already
Use selected localisation during later stages of installation
Fixed non-check of permissions when deleting a topic via Moderator Control Panel
Fixed non-update of banlist upon user deletion
Check approved users boxes by default in usergroup approve form
Fixed non-appending of sid to backup meta refresh
Fixed non-notification of no support for certain databases in backup/restore
Added $images var to message die global declaration
Fixed wrong string, Private_message in Private Messaging
Add mail send result to error output
Fixed non-appending of sid to Mozilla nav bar menu items
Fixed incorrect profile linking from MSNM url in private messaging
Grammatical errors in English lang_main fixed - Cluster
Allow deletion of avatar and simultaneous upload/linking/gallery selection
Fixed non-updating of user rank when changing from special to normal rank in rank admin
Changed user topic notification default in schemas to 0 (off)
Fixed non-XHTML compliant img tags in privmsg.php
Fixed non-deletion of announcements and polls when removing forum contents in forum admin
Fixed non-pruning of watched topics table when pruning related topics
Enable GET redirect on logout
Added check for IE6.x to viewtopic ICQ indicator javascript
Fixed empty username quoting with MS-SQL
Fixed BBCode url, magic url and img tags to allow most chars beyond domain names
Prevent parsing of -ve size values in BBCode size tag
Back ported HTML handler from 2.2, this may impact some boards which allow complex HTML - existing parser remains but commented out
Fixed parsing of word censors to not censor words within < and > tag delimiters
Fixed database utilities failing to backup data with MySQL
Fixed signature parsing in User Admin
Fixed missing class="post" tags in subSilver Admin templates
Fixes for paths under Apache2
Added wrap text with tag support for posting in Mozilla 1.1+
Fixed use of missing CSS classes in modcp_split, group_info_body, error_body and agreement
Fixed ability of users to edit polls even after they have received votes
Fixed header Location to be absolute URL as per HTTP 1.1 spec - noted by PhilippK
Added additional session_id checks to MCP, topic subscription, PM and similar items
Fixed colour select box in posting_body to reset to Default colour after selection
Altered PM icon to show new image until messages have been read
Fixed incomplete deletion of PMs when removing the associated user
Fixed unread and new PM user counters to decrement appropriately in all situations
Fixed possible cross-site scripting issue with username search
Fixed some problems with gzip in combination with newer PHP versions and Mozilla
Fixed wrong maxlength in modcp_split.tpl subject field
Fixed inability to edit username of guest poster - vHiker
Fixed ability for guests to post with certain registered usernames


Mind you, these are the changes from 2.0.3 to 2.0.4. If anyone else wants others, just ask!

User avatar
psoTFX
Former Team Member
Posts: 7425
Joined: Tue Jul 03, 2001 8:50 pm

Post by psoTFX » Thu Dec 12, 2002 12:02 am

Is 2.0.4 for real?

Yes, it's just a bugfix release ... the 2.0.x line is feature frozen. Releases on this branch exist to fix bugs, introduce some performance improvements, etc.

This particular release (as indicated by the Changelog above) contains a large number of bug fixes. This should result in this being the most stable, secure, bug free version yet.

When will it be released?

Hopefully early next week, but that could slip to late next week (it's already slipped from this week to next)

What does it fix?

As noted above, lots of things.

Will I have to remod my board?

We will be releasing (as we have in the past) three versions of 2.0.4; full package, changed files only and patch file. Please note however that a large number of files have changed in this release so it is quite likely that a fair amount of remodding of your boards will be required. However, I suspect it'll be worth it.

What about templates and language files?

There are a couple of minor template updates (as noted in the Changelog above). Templates will need to be altered to cope with these changes. There are no changes to language files in 2.0.4 so your existing packages (if fine with 2.0.3) will be fine here.

Will there be a phpBB 2.0.5?

Quite possibly yes, as noted above the phpBB 2.0.x line is feature frozen but new releases are made to fix bugs and other issues. There are no plans to stop these releases for the forseable future.

What about 2.2?

2.2 is completely seperate, it's the next major release of phpBB2 and introduces a raft of fundamental changes. These changes include a return to more static processing. 2.0.x is often compared against other boards ... where it can look slow, the major reason is not poor code, poor database design, etc. it's purely that we do nearly everything dynamically ... this results in admin changes affecting all posts/users without any further action but requires more work at runtime.

When will 2.2 be released?

Hopefully 1st quarter 2003.

Will I be able to upgrade to 2.2 from 2.0.x?

Yes, of course you will ... we value our users and won't leave you out in the cold :)

Eek, it seems 2.2 requires X function in PHP!

phpBB 2.2 will require, at a minimum PHP 4.1.0 to operate. We took this decision following two polls (see Feature Discussion forum here) whereupon it became clear most users would be unaffected by this requirement.

PHP 4.1.0 will have been available for over a year when phpBB 2.2 is released. It is (in our humble opinions) therefore not unacceptable to assume providers (still running < PHP 4.1.0) will have taken a long overdue step in upgrading their PHP versions.

I don't want to change to 2.2 it looks 'orrible! Do I have to?

Of course not, no. Unlike the change from phpBB 1.x to phpBB 2.0 we will more than likely maintain downloads of phpBB 2.0.x (and periodically release updates as/when required). phpBB 1.x was flawed in a number of basic areas which meant that maintaining it was just infeasible, to fix the problems completely would've required a lot of work. Hence it was decided that support would be discontinued. The situation with phpBB 2 is different.

Where can I see phpBB 2.2?

The development board (which is phpBB 2.1 ... the .1 indicates the unstable development branch of 2.2) can be found @ http://area51.phpbb.com/phpBB22/ Keep in mind this is a work in progress so don't expect fully operational, all signing, all dancing action :D

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Post by SamG » Thu Dec 12, 2002 1:18 am

whofarted wrote: eeeh, are you guys going to be using $_GET $_POST etc. on the next release?

I ask because my www host is running php 4.0.6 & it doesn't use that yet. Will there be any soulution for this :?:

/me shakes nervously :cry:

A large host I use and am very happy with continues to have "no plans" to upgrade from PHP 4.0.6 ... there are days when I just want to sit down and :cry: too.

Nothing is ever simple ... :D

Drummer4Life05
Registered User
Posts: 545
Joined: Sun Jul 28, 2002 1:52 am
Location: \\phpbb\forum
Contact:

Post by Drummer4Life05 » Thu Dec 12, 2002 1:59 am

Thanks pso! You covered everything!
Nicely done. :-)

User avatar
SHS`
Former Team Member
Posts: 6615
Joined: Wed Jul 04, 2001 9:13 am
Location: Yellow Beach, Nine Dragons, Hong Kong
Name: Jonathan Stanley
Contact:

Post by SHS` » Thu Dec 12, 2002 2:10 am

SamG wrote: A large host I use and am very happy with continues to have "no plans" to upgrade from PHP 4.0.6 ... there are days when I just want to sit down and :cry: too.

Nothing is ever simple ... :D


<borderline-off-topic>

As PSO says... by the time phpBB2.2 is out, PHP4.3.x and PHP4.2.x will probably be what's in use, with slakcer hosts latching onto 4.1.x.

Anyone still using 4.0.x will be like a host using 3.x.....

Simple answer is vote with your feet, change hosts if they don't upgrade. :D

</borderline-off-topic>

/me thinks PSO should have been a bit more vague and put 1H '03. ;)

M1, M2, M3, M4.. *stuff* ... Final :mrgreen:
Jonathan “SHS`” Stanley • 史德信
Image

Locked

Return to “2.0.x Discussion”