[Release] Terayon 4.0.25 (phpBB 3.0.12)

For style authors to post and receive feedback on 3.0.x styles still in development. Any development styles you wish to use on your live board should be installed with caution!
Ideas Centre
spiderwebfx
Registered User
Posts: 3
Joined: Wed Mar 28, 2012 3:37 am

Re: [Release] Terayon 4.0.18 (phpBB 3.0.10)

Post by spiderwebfx » Thu Mar 29, 2012 6:20 am

The admin control panel link is in the middle at the bottom?

User avatar
lithosphere
Registered User
Posts: 136
Joined: Tue Aug 08, 2006 3:02 am
Location: Canada

Re: [Release] Terayon 4.0.18 (phpBB 3.0.10)

Post by lithosphere » Thu Mar 29, 2012 7:27 am

yes
I have wasted my hours -Leonardo Da Vinci

charliee
Registered User
Posts: 166
Joined: Sun Nov 06, 2011 2:49 am

Re: [Release] Terayon 4.0.18 (phpBB 3.0.10)

Post by charliee » Tue Apr 03, 2012 3:52 pm

Hi, trying to help a fellow with a customized version of teyron but i have one major issue, all images for threads and such wont load.
I downloaded the style onto a local webserver and fiddled around, got it working after i imported imageset from a downloaded copy of teyron.

I have no uploaded the entire teyronfolder to the host and installed it, the style works BUT it wont load any images from imageset :/

Any idea why it works locally but not with the host?

Both prosilver and subsilver2 works ok.
Regards
Charliee


Problem fixed, seems it didnt work when i exported the style but when i made a copy from local folder to host folder it worked and all images loaded.

User avatar
lithosphere
Registered User
Posts: 136
Joined: Tue Aug 08, 2006 3:02 am
Location: Canada

Re: [Release] Terayon 4.0.18 (phpBB 3.0.10)

Post by lithosphere » Tue Apr 03, 2012 9:48 pm

Apologies for the delayed response, I'm glad to read you resolved the problem, best regards :)
I have wasted my hours -Leonardo Da Vinci

BlueCollar
Registered User
Posts: 67
Joined: Sun Dec 05, 2010 11:54 pm

Re: [Release] Terayon 4.0.18 (phpBB 3.0.10)

Post by BlueCollar » Wed Apr 04, 2012 6:10 pm

I am adding a MOD to my page. This MOD adds a link to the menu bar. However, I cannot find the code for the menu bar. Normally I would think the menu bar code is in overall_header.html but I cannot seem to find it. Can anyone direct me to where the code for the menu bar is for this style?

User avatar
lithosphere
Registered User
Posts: 136
Joined: Tue Aug 08, 2006 3:02 am
Location: Canada

Re: [Release] Terayon 4.0.18 (phpBB 3.0.10)

Post by lithosphere » Wed Apr 04, 2012 9:31 pm

Hello the menu code looks like this

Code: Select all

<div class="navmenu">
			<ul class="topmenu">
			<li><a href="{U_INDEX}" accesskey="h">{L_INDEX}</a></li>		
			<li><!-- IF U_RESTORE_PERMISSIONS --><a href="{U_RESTORE_PERMISSIONS}">{L_RESTORE_PERMISSIONS}</a><!-- ENDIF --></li>
			<li><a href="{U_FAQ}" title="{L_FAQ_EXPLAIN}">{L_FAQ}</a></li>
			<!-- IF not S_IS_BOT -->
			<!-- IF S_DISPLAY_MEMBERLIST --><li><a href="{U_MEMBERLIST}" title="{L_MEMBERLIST_EXPLAIN}">{L_MEMBERLIST}</a></li><!-- ENDIF -->			
			<!-- IF not S_IS_BOT and S_USER_LOGGED_IN --><!-- IF S_DISPLAY_PM --><li><a href="{U_PROFILE}" title="{L_PROFILE}" accesskey="e">{L_PROFILE}</a><a href="{U_PRIVATEMSGS}">{PRIVATE_MESSAGE_INFO}</a></li><!-- ENDIF --> <!-- ENDIF -->
			<!-- IF not S_USER_LOGGED_IN and S_REGISTER_ENABLED and not (S_SHOW_COPPA or S_REGISTRATION) --><li><a href="{U_REGISTER}">{L_REGISTER}</a></li><!-- ENDIF -->
			<li><!-- IF U_MCP --><a href="{U_MCP}">{L_MCP}</a></li><!-- ENDIF -->
			<li><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="x">{L_LOGIN_LOGOUT}</a></li>
			<!-- ENDIF -->

			<!-- IF not S_USER_LOGGED_IN and not S_IS_BOT -->
			<div class="loginbox" align="right">
			<li>
			<form method="post" action="{S_LOGIN_ACTION}">	
				<fieldset class="quick-login">
				<input type="text" value="" name="username" id="username" size="16" class="inputboxlogin" title="{L_USERNAME}" />
				<input type="password" value="" name="password" id="password" size="16" class="inputboxlogin" title="{L_PASSWORD}" />
				<input type="submit" name="login" value="{L_LOGIN}" class="button2" />
				{S_LOGIN_REDIRECT}
				</fieldset>
				</form>	
			</li>
			</div>
			<!-- ENDIF -->
			</ul>	
		</div>
The code is located in the overall_header.html file, roughly around line 129

You can insert your link/menu addition in-between or after any of the <li></li>

i.e;

Code: Select all

<li><!-- IF U_MCP --><a href="{U_MCP}">{L_MCP}</a></li><!-- ENDIF -->
<li><!-- YOUR MOD --><a href="MOD LINK">MOD LINK NAME</a></li><!-- END OF MOD LINK -->
<li><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="x">{L_LOGIN_LOGOUT}</a></li>

Code: Select all

<li><!-- IF U_MCP --><a href="{U_MCP}">{L_MCP}</a></li><!-- ENDIF -->
<li><a href="{U_LOGIN_LOGOUT}" title="{L_LOGIN_LOGOUT}" accesskey="x">{L_LOGIN_LOGOUT}</a></li>
<li><!-- YOUR MOD --><a href="MOD LINK">MOD LINK NAME</a></li><!-- END OF MOD LINK -->


etc...

Hope this info helps good luck ;)
I have wasted my hours -Leonardo Da Vinci

Xorys
Registered User
Posts: 1
Joined: Tue Aug 07, 2012 5:28 pm

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by Xorys » Tue Aug 07, 2012 5:32 pm

Hello,

I have a problem with your theme, I would like to change the font colors, I have modified the file theme/colour.css but changes are not visible.

I also wanted to change the banner so that it is in one picture because now there is the logo that is 400px left, changing this value to 1100px changes are not visible either.

User avatar
lithosphere
Registered User
Posts: 136
Joined: Tue Aug 08, 2006 3:02 am
Location: Canada

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by lithosphere » Tue Aug 07, 2012 11:25 pm

Hiya, you'll need to make changes in the content.css common.css and colours.css.

Regarding the banner image you'll need to go into the \styles\Terayon4\imageset\imageset.cfg file and either edit or remove this line.

Open Imageset.cfg and locate

Code: Select all

img_site_logo = logo1.png*188*400
You can insert your own size preferences and name of your banner image.

You can change the background image of where the banner isw locate by editing or removing the bg_header.jpg image. Located here styles\Terayon4\theme\images\bg_header.jpg

You can make some more changes to the top area if you open the common.css and change the code

common.css around line 245

Code: Select all

.headerbar {
	background-color: #3D4558;
	background-image: url("{T_THEME_PATH}/images/bg_header.jpg");
	color: #FFFFFF;
	height: 188px;
	margin: 5px;	
}
Hope this info helps, good luck ;)
I have wasted my hours -Leonardo Da Vinci

charliee
Registered User
Posts: 166
Joined: Sun Nov 06, 2011 2:49 am

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by charliee » Wed Aug 08, 2012 6:48 pm

Hiy having a minor issue with getting classifieds to work with terayon, have made the edits and it all seems to work but 2 buttons gets misplaced, have made the same edits as with prosilver and the same template-files as prosilver is used but for some reason the reset and submit buttons are placed differently in terayon then in prosilver.

Have included an image to show what i mean, terayon to the left and prosilver to the right, anyone got an idea what i need to change so reset/submitbuttons are placed bellow the image and not to the right of the image?

http://oi49.tinypic.com/2888qja.jpg
Regards
Charliee

User avatar
lithosphere
Registered User
Posts: 136
Joined: Tue Aug 08, 2006 3:02 am
Location: Canada

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by lithosphere » Thu Aug 09, 2012 2:22 am

Hi can you tell me which mod this is for? I haven't tested the theme with any of the available classifieds type mods/addons.

I'm not sure where to begin to look with a bit more info, mainly the name of the mod, also I can see its in part of the UCP but not sure which area etc..anyways when you can send me the info and I'll look into the mod and see what I can do to make Terayon 4 more compatible, thanks.
I have wasted my hours -Leonardo Da Vinci

charliee
Registered User
Posts: 166
Joined: Sun Nov 06, 2011 2:49 am

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by charliee » Fri Aug 10, 2012 1:48 am

The mod is classifieds 1.2.0 and the specific page is "post ad", link to that page is.
localhost/buysell/manage_ad.php?mode=create_ad

Link to the mod.
http://www.phpbb.com/community/viewtopi ... &t=2097006

DereksDontRun
Registered User
Posts: 5
Joined: Tue Jul 31, 2012 10:16 pm

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by DereksDontRun » Mon Aug 13, 2012 8:06 pm

Hi - thanks for an ace theme, i think it's pretty cool.

I'm presently trying to implement it to my site (and want to be happy with it before swapping over) but I have a couple questions - basically I like the graphics but I find the user profile-block (avatar, name, rank, joined date, etc.) quite large. So tall that if there is only a couple lines in the reply it causes the page to be padded out a LOT, especially when the signature area starts below this block no matter how little text is typed.

Is it possible to have the sig starting under the post text instead of under the profile block? If so, any tips what to change? I'm guessing it's all in the viewtopic_body.html and can see the signature section, but don't want to start moving it about without knowing where would be best.

Also, is the white area under the email, pm, etc. icons meant to be there? looks like a bug. Does the postie2 and postie3 images need altering to remove the white?

I've created a quick sketch from a screen-grab to try and explain this:
http://www.dereksdontrun.com/images/terayon_info.jpg


Also, I quite like the way prosilver has the user profile block to the right of the text, is there any way to easily switch the block from the left of the forum-post to the right?

thanks for any assistance, DDR

User avatar
Hippie459MN
Registered User
Posts: 889
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by Hippie459MN » Mon Aug 13, 2012 8:42 pm

DereksDontRun wrote:Also, is the white area under the email, pm, etc. icons meant to be there? looks like a bug. Does the postie2 and postie3 images need altering to remove the white?

I've created a quick sketch from a screen-grab to try and explain this:
http://www.dereksdontrun.com/images/terayon_info.jpg

thanks for any assistance, DDR
Wow, I have been using this for a while now and until you mentioned this, I never noticed the white areas that you mention before but there they are...

Image

Any quick way to fix this? I am going to take a peak around later and if I find something I will post back.

User avatar
Hippie459MN
Registered User
Posts: 889
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by Hippie459MN » Mon Aug 13, 2012 8:55 pm

Well, I found a fix for my rank image issue but not sure how it will work with bigger rank images.

EDIT: Posted the fix for this here - http://www.phpbb.com/community/viewtopi ... #p13173152
Last edited by Hippie459MN on Mon Aug 13, 2012 11:19 pm, edited 1 time in total.

DereksDontRun
Registered User
Posts: 5
Joined: Tue Jul 31, 2012 10:16 pm

Re: [Release] Terayon 4.0.19 (phpBB 3.0.10)

Post by DereksDontRun » Mon Aug 13, 2012 9:18 pm

I think the proper fix is an edit to postie2.jpg and postie3.jpg - they're the background images for the panels and both have a white-strip at the bottom. Stretching the image wouldn't look right as it would make the diagonals a weird angle - but cloning the bottom section to extend the pattern down over the white would work. I was going to do for my own site but thought I'd wait for a reply from Lithosphere in case they're meant to be there and if not, if he has the original art-assets so can create it "properly"

Locked

Return to “[3.0.x] Styles in Development”

Who is online

Users browsing this forum: No registered users and 8 guests