Installing New Mods w/AutoMOD on MAMP server

Archive of support for the automated MOD installation tool codenamed "Blinky". For support questions regarding AutoMOD please visit here.
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: IF YOU NEED SUPPORT FOR AUTOMOD PLEASE VISIT THE APPROPRIATE LOCATION HERE.
Locked
rjhorsley
Registered User
Posts: 5
Joined: Sun Oct 25, 2009 1:52 am

Installing New Mods w/AutoMOD on MAMP server

Post by rjhorsley » Sun Oct 25, 2009 2:00 am

Okay, so I need a little assistance. I've installed MAMP on my Mac (G5, running 10.5.8) and everything's solid, all up-to-date MySQL, Apache, PHP, the whole works. I then installed the latest phpBB package, all fine. Then I successfully installed AutoMOD on that. Made sure the appropriate permissions for the right directories were set. So far, so good.

Then I went and downloaded a zip file of a hack I want to install using AutoMOD. I downloaded it, unzipped it, and dropped the file into the store/mods folder, still all good. Go to AutoMOD's panel, and there is my mod ready for install.

I click on it, and get a screen that asks for FTP host, username, password, port, etc. I *do* have FTP access activated in Mac's system preferences for Sharing, so that's ready to go.

So I gave it my ftp address (I've tried both the direct numeric IP--10.0.1.3--as well as just 'localhost'), my username (going off MAMP I figured my username is the same as my username for my Mac), and password (ditto). The port number is 8888 and it already had the appropriate filepath to the phpbb directory as /phpBB/

But when I submit all this, I get back the response "Connection Failed Error connecting to the server." Nothing seems to fix this issue, so I'm clearly making some mistake in how to set this up. In AutoMOD's configuration panel, I've tried things like Direct instead of FTP (it refuses and says that since the file directory is not writable, Direct is not an option).

Can someone give me a hand on identifying the issue here?

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: Installing New Mods w/AutoMOD on MAMP server

Post by A_Jelly_Doughnut » Wed Oct 28, 2009 1:47 am

Are you sure FTP is on port 8888? I don't think I've ever seen a server with FTP on anything other than port 21. I'm guessing 8888 is where your Apache server is running to avoid common ISP restrictions on port 80.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

User avatar
Sajaki
Registered User
Posts: 1354
Joined: Mon Mar 02, 2009 1:41 pm
Name: Andreas
Contact:

Re: Installing New Mods w/AutoMOD on MAMP server

Post by Sajaki » Sun Nov 01, 2009 9:19 am

Mamp defaults on port 8888 for Apache and 8889 for mysql. But it can also use the default apache 80 and mysql 3306 ports.

For the Automod local ftp settings, they should be like this :
the ip address is 127.0.0.1 (that's localhost)
the user is your mac user, password.
path : the absolute hd path to your phpbb directory. i'm using Zend pdt, so that's /usr/local/zend/apache2/htdocs/phpbb3

Image

if you use direct mode, and it says direct is not writable, change the permissions to /store/mods to :
Image
and apply to enclosed items.

then just place your unzipped mod in /store/mods and proceed to install.

i always use direct mode on localhost btw, never had issues.
Last edited by Sajaki on Sun Dec 13, 2009 7:48 pm, edited 1 time in total.

User avatar
Sajaki
Registered User
Posts: 1354
Joined: Mon Mar 02, 2009 1:41 pm
Name: Andreas
Contact:

Re: Installing New Mods w/AutoMOD on MAMP server

Post by Sajaki » Sun Dec 13, 2009 7:47 pm

post updated ^

Locked

Return to “[3.0.x] AutoMOD”