Not copying files properly

Archive of support for the automated MOD installation tool codenamed "Blinky". For support questions regarding AutoMOD please visit here.
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: IF YOU NEED SUPPORT FOR AUTOMOD PLEASE VISIT THE APPROPRIATE LOCATION HERE.
Locked
User avatar
AntiThesis
Registered User
Posts: 26
Joined: Fri Jan 04, 2008 6:34 am

Not copying files properly

Post by AntiThesis »

I'm having some issues running Automod on the latest phpBB (3.07-PL1).

First off, when I upload a mod using Automod I get install errors:
The directory ./../store/mods/hilit_from_search_engine/_edited could not be created
(as an example - this happens with all mods)

I've discovered that doing a chmod 777 on the directory in /store/mods allows automod to make the changes without these errors but that's hardly a solution.

After that, clicking install runs without error and automod says files have been copied to the appropriate directory. However, on inspection, they're just dumped in the forum root and left there.

Again, manual copy into the correct directories works but it's sorta taking out the auto from automod :)

As always, any help would be greatly appreciated.
Happiness is a state of mind.
Dementia Community
PhpBB > VB
User avatar
Sam
Former Team Member
Posts: 2082
Joined: Thu Jan 22, 2009 3:59 am
Location: Sacramento, CA
Name: Sam Thompson
Contact:

Re: Not copying files properly

Post by Sam »

Typically why you would be getting the errors would be due to the fact that the directory permissions are incorrect, and as you discovered, chmod-ing the directories to 777 usually fixes things.

How are the files dumped in the forum root? Do you have a link to the original MOD? It is possible the MODX is incorrect.
User avatar
AntiThesis
Registered User
Posts: 26
Joined: Fri Jan 04, 2008 6:34 am

Re: Not copying files properly

Post by AntiThesis »

SyntaxError90 wrote:Typically why you would be getting the errors would be due to the fact that the directory permissions are incorrect, and as you discovered, chmod-ing the directories to 777 usually fixes things.
Yeah, I would definitely say it is something permission based. I can tell you the following:

/store/mods is chmodded to 777
The full path is /var/www/dementia/data/public_html/forums
dementia is the ftp user and also the owner of everything from /public_html to /public_html/forums/*
dementia is also part of the www-data group running apache
How are the files dumped in the forum root?
I'll paste a run from a mod install rq:

After upload, the folder is created:
drwxr-xr-x 3 www-data www-data 4096 2010-05-18 16:03 Anti_double_post_v2.0.4
Going to install, using either ftp or simple socket and the following settings:

Path to phpbb: public_html/forums/
The directory ./../store/mods/Anti_double_post_v2.0.4/_edited could not be created
The directory ./../store/mods/Anti_double_post_v2.0.4/_edited/adm/style could not be created
The directory ./../store/mods/Anti_double_post_v2.0.4/_edited/includes/acp could not be created
After I chmod the directory itself to 777 I can install and it shows:
root/install/install_adp.php install/install_adp.php Success
root/language/en/mods/anti_double_post.php language/en/mods/anti_double_post.php Success
root/language/en/mods/permissions_anti_double_post.php language/en/mods/permissions_anti_double_post.php Success
Buuut the files are just sitting in public_html/forums:
-rw-r--r-- 1 dementia dementia 2852 2010-05-18 16:08 anti_double_post.php
-rw-r--r-- 1 dementia dementia 1096 2010-05-18 16:08 install_adp.php
-rw-r--r-- 1 dementia dementia 1236 2010-05-18 16:08 permissions_anti_double_post.php
Moving the files manually immediately fixes the problem :)
Do you have a link to the original MOD? It is possible the MODX is incorrect.
This is with every mod I have tried so far - from ones done by mods to other randoms (including of course, Anti Double Post).

Thanks very much for the assist :)
Happiness is a state of mind.
Dementia Community
PhpBB > VB
Locked

Return to “[3.0.x] AutoMOD”