MOD upload issues

Archive of support for the automated MOD installation tool codenamed "Blinky". For support questions regarding AutoMOD please visit here.
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: IF YOU NEED SUPPORT FOR AUTOMOD PLEASE VISIT THE APPROPRIATE LOCATION HERE.
Locked
loadedmind
Registered User
Posts: 15
Joined: Thu Oct 01, 2009 12:51 pm

MOD upload issues

Post by loadedmind » Thu Jan 17, 2013 4:52 pm

Hey all. First off, thanks for providing this open forum for discussing these issues. Really appreciate it.

I'm using the latest version of phpBB3 as of this post (3.0.11) and have recently installed AutoMOD.

My server configuration is all manual. I purchased the server and had a hookup with a local hosting provider to be able to rack it in their facility and use their network free of charge, fortunately. The OS underneath is CentOS 6. I don't have phpMyAdmin or anything installed, but I can certainly do this if the need arises.

The issue I'm having is that I'm not only unable to pull the file from the AutoMOD tab within phpBB3 using the Browse button (error is "Could not upload attachment to ./../store/mods/acp_add_user_mod_1_1_1.zip), but I'm also unable to view the MOD as an option to install if I scp the file over to the store/mods directory.

I have the typical Linux permissions set on files and folders, 0644 & 0755, respectively. I've tried chmod'ing the zip and the directory from the zip but it still will not recognize the MOD. I don't have FTP configured on the server because I'm security paranoid, but if I need to setup vsftpd for this all to work, I suppose that would be a possibility - if only long enough to install the MOD and turn it back off again.

What configuration/permissions do I need to have in place for AutoMOD to work properly? I realize since I may have what many might consider to be an atypical setup of phpBB3, I might run into more funky issues than the rest so I thought I'd start at the source.

Any/all guidance would be much appreciated.

User avatar
tumba25
Former Team Member
Posts: 4430
Joined: Wed Jun 06, 2007 6:42 am
Location: Kokkola, Finland.
Name: Jari Kanerva
Contact:

Re: MOD upload issues

Post by tumba25 » Thu Jan 17, 2013 8:04 pm

PHP needs permission to read and write to your files and directories. The exact permissions need depends on what PHP runs as. If it runs as www-data or something similar then you need 777 for directories and 666 for files.

But if PHP runs as the file owner (you) then 700 and 600 should be fine. If your security settings allows 755/644 then your should also be able to use that.
Need a mod/extension created/installed, other custom-coded solution or a server admin? https://tumba25.net

loadedmind
Registered User
Posts: 15
Joined: Thu Oct 01, 2009 12:51 pm

Re: MOD upload issues

Post by loadedmind » Thu Jan 17, 2013 8:46 pm

How would I know what php runs as? I've tried 755/644 and 777/777 and neither seem to allow me to see the MOD available from the AutoMOD tab. Maybe I'm missing something?

User avatar
Lumpy Burgertushie
Registered User
Posts: 66240
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: MOD upload issues

Post by Lumpy Burgertushie » Fri Jan 18, 2013 4:39 am

if you uploaded the zip file then you will not see from the automod tab.

you need to unzip it first, then upload it to the store/mods folder.

also, considering your server setup I would be surprised if automod is going to be able to do it's job without making changes to the server setup. quite often automod has problems even with the more standard shared hosting setups.

first, setup your file permissions so they are equivalent to this: phpBB3 Chmod Permissions
check the automod configuration and make the best choice there based on your server setup and/or change your server setup accordingly.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: MOD upload issues

Post by Oyabun1 » Tue Feb 26, 2013 9:29 am

If you are only looking at installing one or two MODs a manual install would probably be a lot quicker than trying to solve the issues you are having with AutoMOD.

See:
[Tutorial] How to install a MODX modification
And/or Opening MODs and Installing MODs

You will need to use appropriate tools to make any manual changes and transfer files, see Tools needed to set up and customise phpBB.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

Locked

Return to “[3.0.x] AutoMOD”