AutoMOD doesn't write to files

Archive of support for the automated MOD installation tool codenamed "Blinky". For support questions regarding AutoMOD please visit here.
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTICE: IF YOU NEED SUPPORT FOR AUTOMOD PLEASE VISIT THE APPROPRIATE LOCATION HERE.
Locked
TheDani
Registered User
Posts: 315
Joined: Tue Apr 10, 2012 12:48 pm

AutoMOD doesn't write to files

Post by TheDani » Sun Mar 03, 2013 6:07 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? http://screammagazine.com/scream2013/forum/
Who do you host your board with? ProISP
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Please select your answer
Is registration required to reproduce this issue? Yes.
Do you have any MODs installed? Yes
What MODs do you have installed?
What styles do you currently have installed? Artodia Mobile and SEO, Cooperative, IDLaunch_Black, subsilver2, ggValentine, proglass_red
What language(s) is your board currently using? uk
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
When did your problem begin? Don't know
Please describe your problem. When I run AutoMOD, I first upload the package, then click to Install it. It sais MOD installed on green background, but nothing has happened. When I check the install.xml file, I see it hasn't written anything, so I have to keep installing all MODs manually.

I thought perhaps it's a permission issue, but then it should fire an error and not tell me all is ok? File permissions=755 for most files, owner/group of files=ftp/ftp.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: AutoMOD doesn't write to files

Post by Oyabun1 » Sun Mar 03, 2013 8:41 pm

What are your AutoMOD Configuration settings?

Note that AutoMOD will not automatically install MODs into styles it does not have instruction for (MODs will have instructions fro prosilver and some may have instructions for subsilver2, very few will have instructions for styles other than those.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

TheDani
Registered User
Posts: 315
Joined: Tue Apr 10, 2012 12:48 pm

Re: AutoMOD doesn't write to files

Post by TheDani » Sun Mar 03, 2013 8:50 pm

AutoMOD 1.0.2
Direct / .zip / yes / 0644 / 0755 / No

It's not only files in styles/ folder it doesn't write to. It doesn't write to any files.

User avatar
Lumpy Burgertushie
Registered User
Posts: 64567
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: AutoMOD doesn't write to files

Post by Lumpy Burgertushie » Sun Mar 03, 2013 8:53 pm

your server may not allow direct access for writing to the files.

try ftp settings and see if it works.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

TheDani
Registered User
Posts: 315
Joined: Tue Apr 10, 2012 12:48 pm

Re: AutoMOD doesn't write to files

Post by TheDani » Sun Mar 03, 2013 10:33 pm

I tried now. Connection to ftp was successful. But when I try to delete an uninstalled MOD, I get this error message "There was an error deleting the selected MOD. The file ./../store/mods/phpbb_smartfeed_2_2_25/br.xml could not be removed". And when I try to install it instead, I get "One or more install actions failed. Please review the actions below, make any adjustments and retry. You may continue with the installation even though some of the actions failed. This is not recommended and may cause your board to not function correctly.
The directory ./../store/mods/phpbb_smartfeed_2_2_25/_edited/adm/style could not be created
The directory ./../store/mods/phpbb_smartfeed_2_2_25/_edited/includes could not be created
...."


That happens with at least two different MODs, but not with all.

User avatar
Lumpy Burgertushie
Registered User
Posts: 64567
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: AutoMOD doesn't write to files

Post by Lumpy Burgertushie » Sun Mar 03, 2013 10:49 pm

make sure the store folder is set to 777 chmod


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

TheDani
Registered User
Posts: 315
Joined: Tue Apr 10, 2012 12:48 pm

Re: AutoMOD doesn't write to files

Post by TheDani » Sun Mar 03, 2013 11:20 pm

store folder is already 777.

TheDani
Registered User
Posts: 315
Joined: Tue Apr 10, 2012 12:48 pm

Re: AutoMOD doesn't write to files

Post by TheDani » Mon Mar 04, 2013 1:07 pm

I just detected by ftp that some of the subfolders in store/mods/ are 755 while others are 777. When I try to change any of the ones that are 755 to 77, I get "Operation not permitted", but I'm free to change the ones that are 777 to anything that are in the same folder. Any idea why I cant chmod some of the folders ?

User avatar
Lumpy Burgertushie
Registered User
Posts: 64567
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: AutoMOD doesn't write to files

Post by Lumpy Burgertushie » Mon Mar 04, 2013 2:13 pm

is your site hosted on windows or linux?

if on windows then chmod does not apply and you would have to get your host to set your permissions for you.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

TheDani
Registered User
Posts: 315
Joined: Tue Apr 10, 2012 12:48 pm

Re: AutoMOD doesn't write to files

Post by TheDani » Mon Mar 04, 2013 2:20 pm

Linux, proisp.no. I am able to chmod most of the folders in mods/store (which itself is 777). F.ex. I can chmod boardwatch_1-0-4/, forumrunner/, genders_1_0_2/ and other MOD folders with FileZilla. But a few folders within the same parent folder is for some reason 755 and I can't chmod them! That includes automod-1.0.2/, phpbb_smartfeed_2_2_25/tapatalk-phpbb3/ and others.

"Response: 550 CHMOD 777 tapatalk-phpbb3: Operation not permitted"

User avatar
Lumpy Burgertushie
Registered User
Posts: 64567
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: AutoMOD doesn't write to files

Post by Lumpy Burgertushie » Mon Mar 04, 2013 7:01 pm

ok, first , you should not have a folder named "automod-1.0.2". when you install automod properly, it does not create a folder of that name and you should not be uploading a folder of that name to install automod.

then,

the only folder that should be 777 is the one named store.

the mods folder should be 755 and any and all folders within the mod folder should be 755
all the files within those other folders are normally 644 as are all phpbb files.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

TheDani
Registered User
Posts: 315
Joined: Tue Apr 10, 2012 12:48 pm

Re: AutoMOD doesn't write to files

Post by TheDani » Mon Mar 04, 2013 9:52 pm

ok, thanks for advice. store is 777, and mods + all subfolders are set to 755. Should I delete automod-1.0.2 folder?

And expect for that, there is still no diff. I still get these "The directory ./../store/mods/somemod/_edited/styles/prosilver/template could not be created" errors.

When I delete it from AutoMOD, I get "There was an error deleting the selected MOD. The file ./../store/mods/somemod/install_mod.xml could not be removed".

When I try to delete the somemod folder in store/mods with FileZilla, I get "550 root: Permission denied".


Edit:
I noticed that when I changed write method from FTP to Compressed File Download, I was able to delete the folders in question. But this write method also does no change to my files. It doesnt even upload files.

I installed two MODs with FTP mode. With the first MOD, everything went ok. With the second MOD, it said everything was ok, but it had not actually written to any of the files! So I then again had to install it by hand. And I am quite sure this has not to do with the specific MOD(s), but with AutoMOD.

Locked

Return to “[3.0.x] AutoMOD”

Who is online

Users browsing this forum: No registered users and 5 guests