Icon problem / new topic

This forum is now closed. Please ask all styles-related questions in the phpBB 3.0 Styles Support & Discussion Forum.
Locked
Volion
Registered User
Posts: 94
Joined: Sun Nov 09, 2003 5:25 pm
Contact:

Icon problem / new topic

Post by Volion »

I modified the forum for mouse over graphics and clickable navigation in the, (index_body)(viewforum_body) now the new topic icons don’t show up when you post a new topic, what is weird is the locked icons do.

I checked the file names for the gif’s (see below) and they are correct, any idea what is going on?

folder_new

folder_new_big

Thanks,
Image
Proud supporter of phpBB-RPG.com.

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

Looks like you messed up something in template. Probably deleted wrong line.

Re-download original style and compare those files to original to see what you deleted.
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

Volion
Registered User
Posts: 94
Joined: Sun Nov 09, 2003 5:25 pm
Contact:

Post by Volion »

Modified section of the index_body,

</tr>
<!-- BEGIN forumrow -->
<tr>
<td class="row1" align="center" valign="middle" height="50"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td><td class="row1" width="100%" height="50" onMouseOver="this.style.backgroundColor='{T_TD_COLOR1}'; this.style.cursor='hand';" onMouseOut=this.style.backgroundColor="{T_TR_COLOR1}" onclick="window.location.href='{catrow.forumrow.U_VIEWFORUM}'"><span class="forumlink">
<a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
</span>
<span class="genmed">{catrow.forumrow.FORUM_DESC}<br /></span></td><td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOPICS}</span></td>
<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.POSTS}</span></td>
<td class="row2" align="center" valign="middle" height="50" nowrap="nowrap"><span class="gensmall"><!--<a href="{catrow.forumrow.U_LAST_TOPIC}">{catrow.forumrow.LAST_TOPIC}</a><br />-->{catrow.forumrow.LAST_POST}</span></td>

<!-- END forumrow -->
<!-- END catrow -->


Modified section of the viewforum_body

<!-- BEGIN topicrow -->
<tr>
<td class="row1" align="center" valign="middle" width="20"><img src="{topicrow.TOPIC_FOLDER_IMG}" width="19" height="18" alt="{topicrow.L_TOPIC_FOLDER_ALT}" title="{topicrow.L_TOPIC_FOLDER_ALT}" /></td>
<td class="row1" width="100%" onMouseOver="this.style.backgroundColor='{T_TD_COLOR1}'; this.style.cursor='hand';" onMouseOut=this.style.backgroundColor="{T_TR_COLOR1}" onclick="window.location.href='{topicrow.U_VIEW_TOPIC}'"><span class="topictitle">{topicrow.NEWEST_POST_IMG}{topicrow.TOPIC_TYPE}<a href="{topicrow.U_VIEW_TOPIC}" class="topictitle">{topicrow.TOPIC_TITLE}</a></span><span class="gensmall"><br />
{topicrow.GOTO_PAGE}</span></td>
<td class="row2" align="center" valign="middle"><span class="postdetails">{topicrow.REPLIES}</span></td>
<td class="row3" align="center" valign="middle"><span class="name">{topicrow.TOPIC_AUTHOR}</span></td>
<td class="row2" align="center" valign="middle"><span class="postdetails">{topicrow.VIEWS}</span></td>
<td class="row3Right" align="center" valign="middle" nowrap="nowrap"><span class="postdetails">{topicrow.LAST_POST_TIME}<br />{topicrow.LAST_POST_AUTHOR} {topicrow.LAST_POST_IMG}</span></td>
</tr>
<!-- END topicrow -->

Which lines are preventing folder_new_big from displaying correctly?
Image
Proud supporter of phpBB-RPG.com.

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

it is there, as it is supposed to be:

index_body.tpl:
<img src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" />

viewforum_body.tpl:
<img src="{topicrow.TOPIC_FOLDER_IMG}" width="19" height="18" alt="{topicrow.L_TOPIC_FOLDER_ALT}" title="{topicrow.L_TOPIC_FOLDER_ALT}" />

code is correct. look at source of forum page and try to find folder image there - maybe you'll find error.
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

Volion
Registered User
Posts: 94
Joined: Sun Nov 09, 2003 5:25 pm
Contact:

Post by Volion »

Checked and re checked all the lines, I am at a total loss.
Getting intermediate Icon display, one time it will show the correct new posts Icon, next time it will not.

I have even loaded up a default template, having the same result..I am guessing perhaps there is a corrupted file in the primary BB code, any idea where the display the folder_new_ big code would be?
Image
Proud supporter of phpBB-RPG.com.

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

its in index.php

also i suggest you to check cfg file - maybe something is wrong there.
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

Volion
Registered User
Posts: 94
Joined: Sun Nov 09, 2003 5:25 pm
Contact:

Post by Volion »

Thanks for all your help, I appreciate it,

after deleting the entire phpBB folder off site, deleted and recreated the entire database, and after reinstalling every thing, it still does not display correct Icons when posting.
Last edited by Volion on Thu Nov 13, 2003 6:19 pm, edited 1 time in total.
Image
Proud supporter of phpBB-RPG.com.

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

http://www.volion.com/phpBB2/index.php ? Folder icons are correct there.
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

Volion
Registered User
Posts: 94
Joined: Sun Nov 09, 2003 5:25 pm
Contact:

Post by Volion »

This is a full install with a completely new database. (Shrug)

Yes that’s the right pathway to the BB, log in and post a topic, the (no new posts) icon will remain up. I am beyond reason as to why it does not display new posts after one is made.
Image
Proud supporter of phpBB-RPG.com.

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

Volion wrote: I am beyond reason as to why it does not display new posts after one is made.

You should have said that earlier.

Answer is simple - you made that post so you can't see it as new post. If you want to see new post icon you should use different computer or different browser. And you must be logged in because guests don't see new posts icons and login should be different from one that you used to post.
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

Volion
Registered User
Posts: 94
Joined: Sun Nov 09, 2003 5:25 pm
Contact:

Post by Volion »

Ug (beats head on desk) <user error>


Question: How do I change the log in box color, its white and my text is also white?

I have set every thing to 000000 in the style controls, do i need to make a change to another doc?
Image
Proud supporter of phpBB-RPG.com.

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

in login_body.tpl replace

Code: Select all

<input type="text"
with

Code: Select all

<input type="text" class="post"
and

Code: Select all

<input type="password"
with

Code: Select all

<input type="password" class="post"
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

Volion
Registered User
Posts: 94
Joined: Sun Nov 09, 2003 5:25 pm
Contact:

Post by Volion »

Worked great, thanks again for all the help.

-V
Image
Proud supporter of phpBB-RPG.com.

Locked

Return to “[2.0.x] Styles Development & Discussion”