Help me fix my view_topic.tpl

This forum is now closed. Please ask all styles-related questions in the phpBB 3.0 Styles Support & Discussion Forum.
Locked
jam161
Registered User
Posts: 104
Joined: Sun Apr 25, 2004 9:39 pm

Help me fix my view_topic.tpl

Post by jam161 »

my forums located at http://www.purge.worthplaying.com/phpbb

it appears at random that the topics stretch the page wider then it should be.. (no not big images ... just randomly.)

Code: Select all

 
<table width="98%" border="0" cellpadding="0" cellspacing="0" align="center">
  <tr> 
    <td colspan="3"><table width="100%" border="0" cellpadding="0" cellspacing="0">
        <tr> 
          <td width="410" height="31" background="templates/subSilver/forumstuff/topleftwide.gif"><span class="gensmall">&nbsp;&nbsp;<a class="gensmall" href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a></span></td>
          <td height="31" background="templates/subSilver/forumstuff/topmiddle.gif">&nbsp;</td>
          <td width="160" height="31" background="templates/subSilver/forumstuff/topright.gif">&nbsp;</td>
        </tr>
      </table></td>
  </tr>
  <tr> 
    <td><table width="100%" cellpadding="0" cellspacing="0" border="0">
          <td width="27" background="templates/subSilver/forumstuff/border_left.gif"><img src="templates/subSilver/forumstuff/border_left.gif" width="27" height="21"></td>
        <td background="templates/subSilver/forumstuff/blue_static.jpg"><table width="100%" border="0" cellspacing="0" cellpadding="0">
            <tr> 
              <td><table border="0" cellspacing="0" cellpadding="0">
                  <tr> 
                    <td>
<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr> 
    <td align="left" valign="bottom" colspan="2"><span class="gensmall"><b>{PAGINATION}</b></span></td>
  </tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr> 
	<td align="left" valign="bottom" nowrap><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
	<td align="left" valign="middle" width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a> 
      <font color="#FFCC00">»</font> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
  </tr>
</table>

<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
	<tr align="right">
		<td class="catHead" colspan="2" height="28"><span class="nav"><a href="{U_VIEW_OLDER_TOPIC}" class="nav">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="nav">{L_VIEW_NEXT_TOPIC}</a> &nbsp;</span></td>
	</tr>
	{POLL_DISPLAY} 
	<tr>
		<th class="thLeft" width="150" height="26" nowrap>{L_AUTHOR}</th>
		<th class="thRight" nowrap>{L_MESSAGE}</th>
	</tr>
	<!-- BEGIN postrow -->
	<tr> 
		<td width="150" align="left" valign="top" class="{postrow.ROW_CLASS}"><span class="name"><a name="{postrow.U_POST_ID}"></a><b>{postrow.POSTER_NAME}</b></span><br /><span class="postdetails">{postrow.POSTER_RANK}<br />{postrow.RANK_IMAGE}{postrow.POSTER_AVATAR}<br /><br />{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br />{postrow.POSTER_FROM}</span><br /></td>
		<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">
			<tr>
				<td width="100%"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: {postrow.POST_DATE}<span class="gen">&nbsp;</span>&nbsp; &nbsp;{L_POST_SUBJECT}: {postrow.POST_SUBJECT}</span></td>
				<td valign="top" nowrap>{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}</td>
			</tr>
			<tr> 
				<td colspan="2"><hr /></td>
			</tr>
			<tr>
				<td colspan="2"><span class="postbody">{postrow.MESSAGE}{postrow.SIGNATURE}</span><span class="gensmall">{postrow.EDITED_MESSAGE}</span></td>
			</tr>
		</table></td>
	</tr>
	<tr> 
		<td class="{postrow.ROW_CLASS}" width="150" align="left" valign="middle"><span class="nav"><a href="#top" class="nav">{L_BACK_TO_TOP}</a></span></td>
		<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="bottom" nowrap><table cellspacing="0" cellpadding="0" border="0" height="18" width="18">
			<tr> 
				<td valign="middle" nowrap>{postrow.PROFILE_IMG} {postrow.PM_IMG} {postrow.EMAIL_IMG} {postrow.WWW_IMG} {postrow.AIM_IMG} {postrow.YIM_IMG} {postrow.MSN_IMG}<script language="JavaScript" type="text/javascript"><!-- 

	if ( navigator.userAgent.toLowerCase().indexOf('mozilla') != -1 && navigator.userAgent.indexOf('5.') == -1 && navigator.userAgent.indexOf('6.') == -1 )
		document.write(' {postrow.ICQ_IMG}');
	else
		document.write('</td><td>&nbsp;</td><td valign="top" nowrap="nowrap"><div style="position:relative"><div style="position:absolute">{postrow.ICQ_IMG}</div><div style="position:absolute;left:3px;top:-1px">{postrow.ICQ_STATUS_IMG}</div></div>');
				
				//--></script><noscript>{postrow.ICQ_IMG}</noscript></td>
			</tr>
		</table></td>
	</tr>
	<tr> 
		<td class="spaceRow" colspan="2" height="1"><img src="templates/subSilver/images/spacer.gif" alt="" width="1" height="1" /></td>
	</tr>
	<!-- END postrow -->
	<tr align="center"> 
		<td class="catBottom" colspan="2" height="28"><table cellspacing="0" cellpadding="0" border="0">
			<tr><form method="post" action="{S_POST_DAYS_ACTION}">
				<td align="center"><span class="gensmall">{L_DISPLAY_POSTS}: {S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></span></td>
			</form></tr>
		</table></td>
	</tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0" align="center">
  <tr> 
    <td align="left" valign="middle" nowrap><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
    <td align="left" valign="middle" width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a> 
      <font color="#FFCC00">»</font> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
    <td align="right" valign="top" nowrap><span class="gensmall">{S_TIMEZONE}</span><br />
      <span class="nav">{PAGINATION}</span> </td>
  </tr>
  <tr>
    <td align="left" colspan="3"><span class="nav">{PAGE_NUMBER}</span></td>
  </tr>
  <tr> 
    <td align="left" colspan="3">{QUICK_REPLY_FORM}</td>
  </tr>
</table>
                      </td>
                  </tr>
                </table></td>
            </tr>
          </table></td>
          <td width="9" background="templates/subSilver/forumstuff/border_right.gif"><img src="templates/subSilver/forumstuff/border_right.gif" width="9" height="21"></td>
      </table></td>
  </tr>
  <tr> 
    <td height="9" colspan="3"><table width="100%" border="0" cellpadding="0" cellspacing="0">
        <tr> 
          <td width="164" height="9"><img src="templates/subSilver/forumstuff/bottomleft.gif" width="164" height="9"></td>
          <td height="9" background="templates/subSilver/forumstuff/bottommiddle.gif"><img src="templates/subSilver/forumstuff/bottommiddle.gif" width="258" height="9"></td>
          <td width="39" height="9"><img src="templates/subSilver/forumstuff/bottomright.gif" width="39" height="9"></td>
        </tr>
      </table></td>
  </tr>
</table>
<br>
<br>
<table width="90%" border="0" cellspacing="0" cellpadding="0" align="center">
  <tr> 
    <td height="9" colspan="3"><table width="100%" height="9" border="0" cellpadding="0" cellspacing="0">
        <tr> 
          <td width="15" height="9" background="templates/subSilver/forumstuff/border_207_top_01.gif"><img src="templates/subSilver/forumstuff/border_207_top_01.gif" width="15" height="9"></td>
          <td height="9" background="templates/subSilver/forumstuff/border_207_top_02.gif"><img src="templates/subSilver/forumstuff/border_207_top_02.gif" height="9"></td>
          <td width="15" height="9" background="templates/subSilver/forumstuff/border_207_top_03.gif"><img src="templates/subSilver/forumstuff/border_207_top_03.gif" width="15" height="9"></td>
        </tr>
      </table></td>
  </tr>
  <tr> 
    <td bgcolor="#666666"><img src="templates/subSilver/forumstuff/transparent.gif" width="1" height="1"></td>
    <td background="templates/subSilver/forumstuff/blue_static.jpg"><table width="100%" cellspacing="2" border="0" align="center">
        <tr> 
          <td width="40%" valign="top" nowrap align="left"><span class="gensmall">{S_WATCH_TOPIC}</span><br />
            <span class="nav">{S_TOPIC_ADMIN}</span>&nbsp;<br />
            
</td>
          <td align="right" valign="top" nowrap>{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
        </tr>
      </table> </td>
    <td bgcolor="#666666"><img src="templates/subSilver/forumstuff/transparent.gif" width="1" height="1"></td>
  </tr>
  <tr> 
    <td height="3" colspan="3"><table width="100%" height="3" border="0" cellpadding="0" cellspacing="0">
        <tr> 
          <td width="10" height="3" background="templates/subSilver/forumstuff/border_207_bottom_01.gif"><img src="templates/subSilver/forumstuff/border_207_bottom_01.gif" width="10" height="3"></td>
          <td height="3" background="templates/subSilver/forumstuff/border_207_bottom_02.gif"><img src="templates/subSilver/forumstuff/border_207_bottom_02.gif" height="3"></td>
          <td width="8" height="3" background="templates/subSilver/forumstuff/border_207_bottom_03.gif"><img src="templates/subSilver/forumstuff/border_207_bottom_03.gif" width="8" height="3"></td>
        </tr>
      </table></td>
  </tr>
</table><br />

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

can you link to exact topic on your forum where you see problem?
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

jam161
Registered User
Posts: 104
Joined: Sun Apr 25, 2004 9:39 pm

Post by jam161 »


User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

jam161
Registered User
Posts: 104
Joined: Sun Apr 25, 2004 9:39 pm

Post by jam161 »

not to make a fuss or anything.. but i dont see any large image in that post.. :roll:


plus i dont like how that mod works... i would understand my view topic being messed up if there was a large image... but theres nothing in that thread..

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

You have large images in signatures. And because of IE bug it widens posts. If you don't like solution in that mod then other solution is ask all your users to switch to normal browsers (Mozilla or Opera) or wait until microsoft fixes their bug (as if that will ever happen).
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

jam161
Registered User
Posts: 104
Joined: Sun Apr 25, 2004 9:39 pm

Post by jam161 »

well then why does it not do it all the time... and that sig image is no wider then what would fit.

User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Post by Arty »

Its IE bug. Even though that image is smaller that post width it still causes IE bug to show.
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework

jam161
Registered User
Posts: 104
Joined: Sun Apr 25, 2004 9:39 pm

Post by jam161 »

ok well then ill just tell the forum people the boogie man did it if they ask... thanks

custmguru®
Registered User
Posts: 233
Joined: Wed Apr 10, 2002 6:06 pm
Location: Somewhere, Over the rainbow
Contact:

Post by custmguru® »

it's not a huge bug. it's a simple change that fixes it. ill post a link once i find it again.


Locked

Return to “[2.0.x] Styles Development & Discussion”