side link menu in phpvb2, is it possible?

This forum is now closed. Please ask all styles-related questions in the phpBB 3.0 Styles Support & Discussion Forum.
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

side link menu in phpvb2, is it possible?

Post by dvdsecretz »

wonder if anyone can help.

i am running the new phpvb2 template. is it possible to have a side (say on the left) side menu where i can include my links?

any help would upmost appreciated. i have no idea which files would have to be edited.

thanks

DvD ;o)
User avatar
Daz
Registered User
Posts: 5236
Joined: Fri Dec 07, 2001 2:39 pm
Location: Yorkshire, UK

Post by Daz »

Hi,

Anything is possible (within reason) but first see this release as a guide or base to what you want to do;

http://www.phpbb.com/phpBB/viewtopic.php?t=22237
Please and Thank You works wonders...
I reserve the right to post illogical (and totally wrong) replies.
...It's the subtle perfection in attention to detail that makes your work rock the way it does - cdkrg
Think simple - it's not necessarily what you draw that matters, it's what you perceive - Daz

Note: ForumImages<dot>com is no longer anything to do with me.
ickie
Registered User
Posts: 20
Joined: Fri Apr 05, 2002 1:16 pm
Location: Pensacola Fl.
Contact:

Post by ickie »

I have stuff on both sides, take a peek.
http://www.ickie.net/phpBB2/
Ickie Berleim
AJ Riddle
I've Been Banned!
Posts: 94
Joined: Tue May 14, 2002 12:42 am
Location: BCII (Black-Cell Insane Isylum in Cukkuton, Missouri)
Contact:

Post by AJ Riddle »

stop advertising!
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

Post by dvdsecretz »

daz

just gone through it and yeah that is on the lines what i want.

i just tried using:

<!-- START LEFT COLUMN --><td width="175" class="bodyline" valign="top" nowrap="nowrap"><table

width="100%" cellpadding="2" cellspacing="1" border="0" class="forumline">
<tr>
<th class="thCornerL" height="25" nowrap="nowrap">DVDSECRETS Menu</th>
</tr>
<tr>
<td class="row1">Test Test Test</td>
</tr>
</table></td><!-- FINISH LEFT COLUMN -->

but having probs.

changing the 'table width="100%"' to 20% resised the side menu to what i want, but when i started adding links they would appear fine BUT the whole forum side would move down.

i was trying this with BMan1Blue and phpvb2 templates.

its all defaulted to subsilver template.

is there a way i can use this with BMan1Blue and phpvb2 templates?

than

DvD ;o)
User avatar
Daz
Registered User
Posts: 5236
Joined: Fri Dec 07, 2001 2:39 pm
Location: Yorkshire, UK

Post by Daz »

Hi,

I would leave the width of the left hand table at 100% and alter the <td> from 175 to whatever to use the space better.

You will have to add valign="top" to the other column to keep the forum at the top.

You shouldn't need to do much to use the phpVB2 styling - Nick may have declared his own CSS and you will have to change the classes to suit.
Please and Thank You works wonders...
I reserve the right to post illogical (and totally wrong) replies.
...It's the subtle perfection in attention to detail that makes your work rock the way it does - cdkrg
Think simple - it's not necessarily what you draw that matters, it's what you perceive - Daz

Note: ForumImages<dot>com is no longer anything to do with me.
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

Post by dvdsecretz »

thanks man, i have installed the BMan1Blue template and got the side link menu to work, all is good.

just got one small minor problem, when viewing certain messages with say long URL's in them the right side of the forum gets missaligned.

any idea what could be wrong with that?

my site is at: www.dvd-secrets.co.uk

thanks for the help :lol:

DvD
User avatar
Daz
Registered User
Posts: 5236
Joined: Fri Dec 07, 2001 2:39 pm
Location: Yorkshire, UK

Post by Daz »

Hi,

Maybe there is an open forum, but otherwise;

Username:
Password:
Please and Thank You works wonders...
I reserve the right to post illogical (and totally wrong) replies.
...It's the subtle perfection in attention to detail that makes your work rock the way it does - cdkrg
Think simple - it's not necessarily what you draw that matters, it's what you perceive - Daz

Note: ForumImages<dot>com is no longer anything to do with me.
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

Post by dvdsecretz »

oh yeah sorry man.

here is a test account:

User Name: redfred
Password: test

once logged in, here is an example of the problem:

http://www.dvd-secrets.co.uk/phpBB2/vie ... php?t=7982

(right of the forum is misaligned)

this is only on some of the posts, for example in that thread i have figured if the thread starter doesnt' attach his signature then the alignment is ok.

the signature is not massive or anything, just a very odd problem

thanks for taking time out and helping, mucch appreciated, any suggestions please let me know

;o)

DvD
User avatar
Daz
Registered User
Posts: 5236
Joined: Fri Dec 07, 2001 2:39 pm
Location: Yorkshire, UK

Post by Daz »

Hi,

I am assuming a little here as this problem is dependant on resolution, but I take it you are logged in as Admin/Mod? as this makes it look worse.

It had me scratching my head for a while, but the problem is related (as you have noticed) to the use of signatures. It is not the signature as such, it is the image, as if you look at the alignment of the right hand side of the image you will see if lines up with the left hand edge of the quote button.

I solved it by splitting the tables in posting_body.tpl - I can give you the code for subSilver if you like.

---

I think you can lose a little of the 'white' space around the tables and I don't think the curved top of the main forum tables works with the side menu - I would either get rid of the curve or make a bigger one to go in overall_header.tpl
Please and Thank You works wonders...
I reserve the right to post illogical (and totally wrong) replies.
...It's the subtle perfection in attention to detail that makes your work rock the way it does - cdkrg
Think simple - it's not necessarily what you draw that matters, it's what you perceive - Daz

Note: ForumImages<dot>com is no longer anything to do with me.
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

Post by dvdsecretz »

daz, the code would be great.

my email addy is: admin@dvd-secrets.co.uk

will i be able to use the code on the BMan1Blue template?

thanks man

;o)
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

Post by dvdsecretz »

if i cant solve it i suppose i could remove the top curve, thanks for pointing that out.

do you know if its possible to center the forum indexin the right frame or table as its more on the left side when viewing it on 1024x768

:wink:
User avatar
Daz
Registered User
Posts: 5236
Joined: Fri Dec 07, 2001 2:39 pm
Location: Yorkshire, UK

Post by Daz »

Hi,

Just add align="center" to the td tag. If you get rid of the top curve you can set it to 100% and let it fill the space though.

viewtopic_body.tpl (finding a subSilver is getting harder on my PC, but BACKUP your original first - (BMan1 may have changed his code);

Code: Select all

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr> 
	<td align="left" valign="bottom" colspan="2"><a class="maintitle" href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a><br />
	  <span class="gensmall"><b>{PAGINATION}</b><br />
	  &nbsp; </span></td>
  </tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0">
  <tr> 
	<td align="left" valign="bottom" nowrap><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
	<td align="left" valign="middle" width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a> 
	  -> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
  </tr>
</table>

<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
	<tr align="right">
		<td class="catHead" colspan="2" height="28"><span class="nav"><a href="{U_VIEW_OLDER_TOPIC}" class="nav">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="nav">{L_VIEW_NEXT_TOPIC}</a> &nbsp;</span></td>
	</tr>
	{POLL_DISPLAY} 
	<tr>
		<th class="thLeft" width="150" height="26" nowrap>{L_AUTHOR}</th>
		<th class="thRight" nowrap>{L_MESSAGE}</th>
	</tr>
	<!-- BEGIN postrow -->
	<tr> 
		<td width="150" align="left" valign="top" class="{postrow.ROW_CLASS}"><span class="name"><a name="{postrow.U_POST_ID}"></a><b>{postrow.POSTER_NAME}</b></span><br /><span class="postdetails">{postrow.POSTER_RANK}<br />{postrow.RANK_IMAGE}{postrow.POSTER_AVATAR}<br /><br />{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br />{postrow.POSTER_FROM}</span><br /></td>
		
<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="top"> 
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr> 
<td width="100%"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: 
{postrow.POST_DATE}<span class="gen">&nbsp;</span>&nbsp; &nbsp;{L_POST_SUBJECT}: 
{postrow.POST_SUBJECT}</span></td>
<td valign="top" align="right" nowrap>{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} 
{postrow.IP_IMG}</td>
</tr>
</table>
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr> 
<td> 
<hr />
</td>
</tr>
<tr> 
<td><span class="postbody">{postrow.MESSAGE}{postrow.SIGNATURE}</span><span class="gensmall">{postrow.EDITED_MESSAGE}</span></td>
</tr>
</table>
</td>
	</tr>
	<tr> 
		<td class="{postrow.ROW_CLASS}" width="150" align="left" valign="middle"><span class="nav"><a href="#top" class="nav">{L_BACK_TO_TOP}</a></span></td>
		<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="bottom" nowrap><table cellspacing="0" cellpadding="0" border="0" height="18" width="18">
			<tr> 
				<td valign="middle" nowrap>{postrow.PROFILE_IMG} {postrow.PM_IMG} {postrow.EMAIL_IMG} {postrow.WWW_IMG} {postrow.AIM_IMG} {postrow.YIM_IMG} {postrow.MSN_IMG}<script language="JavaScript" type="text/javascript"><!-- 

	if ( navigator.userAgent.toLowerCase().indexOf('mozilla') != -1 && navigator.userAgent.indexOf('5.') == -1 )
		document.write(' {postrow.ICQ_IMG}');
	else
		document.write('</td><td>&nbsp;</td><td valign="top" nowrap="nowrap"><div style="position:relative"><div style="position:absolute">{postrow.ICQ_IMG}</div><div style="position:absolute;left:3px;top:-1px">{postrow.ICQ_STATUS_IMG}</div></div>');
				
				//--></script><noscript>{postrow.ICQ_IMG}</noscript></td>
			</tr>
		</table></td>
	</tr>
	<tr> 
		<td class="spaceRow" colspan="2" height="1"><img src="templates/subSilver/images/spacer.gif" alt="" width="1" height="1" /></td>
	</tr>
	<!-- END postrow -->
	<tr align="center"> 
		<td class="catBottom" colspan="2" height="28"><table cellspacing="0" cellpadding="0" border="0">
			<tr><form method="post" action="{S_POST_DAYS_ACTION}">
				<td align="center"><span class="gensmall">{L_DISPLAY_POSTS}: {S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></span></td>
			</form></tr>
		</table></td>
	</tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0" align="center">
  <tr> 
	<td align="left" valign="middle" nowrap><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
	<td align="left" valign="middle" width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a> 
	  -> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
	<td align="right" valign="top" nowrap><span class="gensmall">{S_TIMEZONE}</span><br /><span class="nav">{PAGINATION}</span> 
	  </td>
  </tr>
  <tr>
	<td align="left" colspan="3"><span class="nav">{PAGE_NUMBER}</span></td>
  </tr>
</table>

<table width="100%" cellspacing="2" border="0" align="center">
  <tr> 
	<td width="40%" valign="top" nowrap align="left"><span class="gensmall">{S_WATCH_TOPIC}</span><br />
	  &nbsp;<br />
	  {S_TOPIC_ADMIN}</td>
	<td align="right" valign="top" nowrap>{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
  </tr>
</table>
Please and Thank You works wonders...
I reserve the right to post illogical (and totally wrong) replies.
...It's the subtle perfection in attention to detail that makes your work rock the way it does - cdkrg
Think simple - it's not necessarily what you draw that matters, it's what you perceive - Daz

Note: ForumImages<dot>com is no longer anything to do with me.
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

Post by dvdsecretz »

thanks bro, i appreciate all your help.

will let you know the outcome tonight, time to get some sleep, nearlly 10am, been messing around with it for over 10hrs solid now

;o)

DvD
dvdsecretz
Registered User
Posts: 54
Joined: Fri Apr 12, 2002 5:38 pm
Location: U.K.
Contact:

Post by dvdsecretz »

daz

i did the code you gave me above and also removed the top curve and yay its looking better. the index page has now also filled the screen and it looks much better this way.

a few things i cannot figure out:

* how to remove the black lines running vertically alongside the forum
* looking at members list, viewforumbody, who is online etc they are not filling up the page, which bit would i have to edit? i take it it would be the same thing for all of em that are not filling up the page.

after that i think it will be finished.

thanks bro, you have made my day today, thought i was gonna be at it for weeks

;o)

DvD
Locked

Return to “[2.0.x] Styles Development & Discussion”