Page 5 of 5

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Wed Apr 16, 2008 1:48 am
by RMcGirr83
Ah well, can't blame a guy for trying. Just about every other template the colors (fontcolor 2 for mods and fontcolor3 for admins) is changed in the ACP.

Mea culpa

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Wed Apr 16, 2008 2:19 am
by Peter77sx
Thatbitextra wrote:Peter77sx: Just add:

Code: Select all

.name { color: #F00; }
to the end of gold.css.
well this is strange... user name wont change color unless I mess with a:link
I even gave a:link it's own color and sure enough, was the only time user name color changed.
I'll keep testing. thanks.

RMcGirr83 wrote:Ah well, can't blame a guy for trying. Just about every other template the colors (fontcolor 2 for mods and fontcolor3 for admins) is changed in the ACP.

Mea culpa
This is true, except for user name. I tried it. thanks for the help though.

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Wed Apr 16, 2008 2:27 am
by Thatbitextra
Where are you wanting to change the username color? If it's in the Who's Online bit then, yes, it is via the ACP. But seeing as you mentioned the .name class I presumed that you are wanting to change the color of the user post author username in viewtopic as that is what .name handles.

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Wed Apr 16, 2008 2:42 am
by RMcGirr83
Peter77sx wrote:
RMcGirr83 wrote:Ah well, can't blame a guy for trying. Just about every other template the colors (fontcolor 2 for mods and fontcolor3 for admins) is changed in the ACP.

Mea culpa
This is true, except for user name. I tried it. thanks for the help though.
The user name color is set as the same color for an a href tag per this code in includes/page_header.php

Code: Select all

				$style_color = '';
				if ( $row['user_level'] == ADMIN )
				{
					$row['username'] = '<b>' . $row['username'] . '</b>';
					$style_color = 'style="color:#' . $theme['fontcolor3'] . '"';
				}
				else if ( $row['user_level'] == MOD )
				{
					$row['username'] = '<b>' . $row['username'] . '</b>';
					$style_color = 'style="color:#' . $theme['fontcolor2'] . '"';
				}

				if ( $row['user_allow_viewonline'] )
				{
					$user_online_link = '<a href="' . append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=" . $row['user_id']) . '"' . $style_color .'>' . $row['username'] . '</a>';
					$logged_visible_online++;
				}
				else
				{
					$user_online_link = '<a href="' . append_sid("profile.$phpEx?mode=viewprofile&" . POST_USERS_URL . "=" . $row['user_id']) . '"' . $style_color .'><i>' . $row['username'] . '</i></a>';
					$logged_hidden_online++;
				}
as you can see the $style_color is only set (and therefore overrides the a tag coloring) if the user is a mod or admin.

I know I didn't supply and answer but at least you know why the coloring is applied that way.

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Wed Apr 16, 2008 9:31 pm
by E.Isolation
Just a quick note to say how much I like this style. Thanks a lot for making it available! The extra color options are a great addition. It is by far the best style (for my forum) that I've seen.

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Tue Jul 29, 2008 11:10 am
by Jay`Z
Hey guys.

I noticed a strange thing with this new SubBlack theme.
First I thought it was just on my board, but seems to be the same even on the demo board presented in this topic.
The thing goes like this: When viewing a topic, at the begining of every post, on the left top corner there's some small writing that says something like:

Code: Select all

Posted: Wed Nov 01, 2006 8:04 pm    Post subject: Unread Topic
And just below that there should be a horizontal line (<hr>?!).
Well the problem is that, that line doesn't seem to display in Mozilla FireFox (neither v2, nor v3), but does display fine in Internet Explorer 7.
I`ve added some screen shots from both browsers to better illustrate the problem:

IE 7: line ok
FireFox 3: no line

I`ve been using subBlack for a long time but this is the first time I notice the problem (i mostly use IE 7)
Can anyone please explain this, and maybe find a fix?

Thanks a lot,

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Sat Aug 30, 2008 2:23 pm
by maxhel
icons for report system??

can make for style sub black

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Sat Aug 30, 2008 3:22 pm
by maxhel
this buttons for advance report system

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Sat Mar 21, 2009 5:35 pm
by Jay`Z
So can anyone please fix the problem I reported above.
I noticed it's the same in Google Chrome as well. :cry:

Re: [Release] subBlack 1.2.1 for phpBB 2.0.22

Posted: Sat Mar 21, 2009 5:57 pm
by Thatbitextra
Jay`Z wrote:So can anyone please fix the problem I reported above.
I noticed it's the same in Google Chrome as well. :cry:
Hi,

Sorry for not replying before, not sure what happened :?
Anyway, to fix it, in main.css, change:

Code: Select all

hr {
	height: 0px;
	border: 0px solid #CCCCCC;
}
to:

Code: Select all

hr {
	height: 0px;
	border: 0px solid #CCCCCC;
	border-width: 1px 0px 0px 0px;
}
:)