what do you think i should rename it to
I don't know. I would suggest subLimit, but that screenshot doesn't look like subClone so i think name should be completely different.
edit: i didn't copy soxie's post - we just posted same idea at the same time. lol.