EasyMOD alpha3 v0.0.8 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
JuniorZ
Registered User
Posts: 188
Joined: Wed Apr 24, 2002 10:11 pm
Location: http://localhost/
Contact:

Post by JuniorZ » Mon May 26, 2003 8:47 pm

JuniorZ wrote: Why this??

Code: Select all

Critical Error: FTP ERROR: could not move file [httpdocs/trabalho/../../../language/lang_english/lang_admin.php] to [/home/httpd/vhosts/phpbb.com.br/httpdocs/trabalho/admin/mods/EasyMOD/./backups/language/lang_english/lang_admin.php.txt]
ATTEMPING REMAINDER OF POST PROCESS


The problem:

The COPY action has the following sintax:
MOD Template Tutorial - by AbelaJohnB wrote:

Code: Select all

# 
#-----[ COPY ]------------------------------------------ 
# 
copy foo_body.tpl to templates/subSilver/foo_body.tpl 
copy foo_body.tpl to templates/subSilver/ 
copy *.tpl to templates/subSilver/ 
copy *.* to templates/subSilver/ 



The EasyMOD installation script has the following COPY action:
EasyMOD installer script wrote: The following action will be executed in the final step: copy ../../../language/lang_english/lang_admin.php ./backups/language/lang_english/lang_admin.php.txt
copy ./processed/language/lang_english/lang_admin.php.txt ../../../language/lang_english/lang_admin.php
copy ../../../language/lang_portuguese_brazil/lang_admin.php ./backups/l
[...]


So the $to and $from variables sent to modio_move() function (I think) aren't right...

Ex:

Code: Select all

copy ../../../language/lang_english/lang_admin.php ./backups/language/lang_english/lang_admin.php.txt
The correct should be:

Code: Select all

copy language/lang_english/lang_admin.php backups/language/lang_english/lang_admin.php.txt
In other words the COPY actions assumes that the $to and $from are relative to your phpBB root path.

Right?? (or not?)
SuportephpBB.org
Sorry by the Horrible English. ;)

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Mon May 26, 2003 9:15 pm

JuniorZ wrote: Ex:

Code: Select all

copy ../../../language/lang_english/lang_admin.php ./backups/language/lang_english/lang_admin.php.txt
The correct should be:

Code: Select all

copy language/lang_english/lang_admin.php backups/language/lang_english/lang_admin.php.txt


i'm not sure : this error occur when you execute the script which is located into the folder ./admin/EasyMOD/easymod_install.php

so the path ../../../language/lang_english/lang_admin.php is correct :
- chmod into EasyMOD/ (..)
- chmod into admin/ (..)
- chmod into yourphpBB root folder (..)
- go into language/lang_english/

so it's the correct path
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Mon May 26, 2003 9:23 pm

Kazer0 wrote:
Warning: main() [function.main]: SAFE MODE Restriction in effect. The script whose uid is 99 is not allowed to access ../extension.inc owned by uid 32050 in /home/shiftxd/public_html/try/admin/admin_easymod.php on line 83

Warning: main(../extension.inc) [function.main]: failed to create stream: Inappropriate ioctl for device in /home/shiftxd/public_html/try/admin/admin_easymod.php on line 83

Fatal error: main() [function.main]: Failed opening required '../extension.inc' (include_path='') in /home/shiftxd/public_html/try/admin/admin_easymod.php on line 83



strange : it's seems it can't access to the file extension.inc : check if the file extension.inc is correctly uploaded onto your FTP server. Maybe you could talk about the SAFE MODE restrictions to your host (because it's the one which has activated it)
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Kazer0
Registered User
Posts: 876
Joined: Sun Nov 10, 2002 2:05 am
Location: {postrow.POSTER_FROM}
Contact:

Post by Kazer0 » Mon May 26, 2003 9:28 pm

Extension.inc is where it should be...
Andrew Charron || alexis support forum || Specializing in phpBB website template integration
Hurry up, my feash is siek.
AndrewCharron.com version 5 released!

User avatar
espenhh
Registered User
Posts: 215
Joined: Sun Mar 17, 2002 8:27 pm
Location: Norway
Contact:

Post by espenhh » Mon May 26, 2003 9:54 pm

Nuttzy99 wrote:
espenhh wrote:It's okay with some warnings for me, but easymod dont show up in the adminpanel!!!!!!!! That's confusing!!!!

Nothing I can do to fix this. It's really strange that I cant make it with this warning, but all you other can... Hmm :?
No, some others are getting the message too, but they are ignoring it b/c it is harmless.

You do have a big problem though if MOD Center is not appearing in the ACP. Sounds like it did not install correctly. What did you use for the write and move methods? Also, please post the scan info the installer displays on the left side of the first page so I can see what is going on ;)

-Nuttzy :cool:


Database type     :: mysql
phpBB version     :: 2.0.4
EasyMOD version   :: 0.0.8
File Access Info
read access       :: OK
write access      :: OK
root path write   :: OK
chmod access      :: OK
unlink access     :: OK
mkdir access      :: OK
tmp path write    :: OK
FTP extension     :: OK
copy access       :: failed


Will try to install it again tomorrow... Hopefully it goes then :D
ALT du trenger til phpBB - på Norsk!
Besøk phpbb.no:
Image

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Mon May 26, 2003 10:36 pm

Kazer0 wrote: Extension.inc is where it should be...


strange :? so i think it's a problem du to the SAFE MODE restrictions, but wait for Nuttzy's help
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Tue May 27, 2003 1:08 am

I will have two follow up releases:

0.0.9 will fix the most pressing issues and add the advanced debug output

0.0.10 will fix the remaining known issues.

I'm hoping for 0.0.9 to be released in a few days but quite frankly I'm going to take my sweet a$$ time :D

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

_Vlad_
Registered User
Posts: 23
Joined: Tue Apr 29, 2003 2:18 pm
Location: California
Contact:

Post by _Vlad_ » Tue May 27, 2003 5:32 am

I have a forum with two templates. I have installed several MODS, many of which require editing the template files as well as the main files. The one template doesnt have any changes made to it, I havent installed the MODS on it too. Will EasyMod work to install MODS on the new template, and also install new mods on templates I have already Modded manually?

Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions » Tue May 27, 2003 6:55 am

already been answered.....

when easymod backsup the files....it includes the already modded files....

look next time please :wink:
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

User avatar
god49
Registered User
Posts: 186
Joined: Fri Nov 08, 2002 2:57 pm

Post by god49 » Tue May 27, 2003 10:42 am

so did anyone ever figure out if it works on a localhost yet?

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Tue May 27, 2003 10:44 am

god49 wrote: so did anyone ever figure out if it works on a localhost yet?


give it a try yourself and say us your results :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Tue May 27, 2003 10:52 am

I said that it worked on localhost way back on the first page! :roll:

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Tue May 27, 2003 12:18 pm

GPHemsley wrote: I said that it worked on localhost way back on the first page! :roll:


yes, you said that it work on your local server (you are using an Abyss Web Server X1 Update 1 (v 1.1.4) with MySQL on a Windows XP computer. ) , but maybe it doesn't work for others :wink:


I will try on my server (Apache 2 + PHP 4.3.1 + MySQL 4.0.13 and MS-SQL Server 2000 on a Windows XP computer) tonight :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Tue May 27, 2003 12:45 pm

morpheus2matrix wrote: yes, you said that it work on your local server (you are using an Abyss Web Server X1 Update 1 (v 1.1.4) with MySQL on a Windows XP computer. ) , but maybe it doesn't work for others :wink:

OK, so I said it worked on my local server, but look at the question:
god49 wrote: so did anyone ever figure out if it works on a localhost yet?
That seems very general, does it not?

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Tue May 27, 2003 1:46 pm

GPHemsley wrote: [That seems very general, does it not?


you're right :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Locked

Return to “[2.0.x] MOD Writers Discussion”