EasyMOD alpha3 v0.0.8 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 7:52 pm

Questions wrote: whats going on??
I replied to these already on the previous page ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions » Sun May 25, 2003 8:05 pm

-EDIT-
Last edited by Questions on Sun May 25, 2003 8:07 pm, edited 1 time in total.
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 8:05 pm

FYI, I updated the bug tracker and known issues. I hope to start working on these soon. The improved debugger might be released as a seperate proggie, I dunno yet.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sun May 25, 2003 8:09 pm

Um.. Nuttzy... I hate to be picky (wait, no I don't... :P), but the bug that I found was on the 24th, not the 25th.... :D Not that it's that big of a deal or anything.... ;)

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 8:20 pm

You!!! Actually I'm going by the date I officially recognized it as a bug, which was indeed 5/25 (about 15 min past midnight in my time zone ;))

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions » Sun May 25, 2003 8:21 pm

Nuttzy99 wrote:
Questions wrote:

Code: Select all

Warning: Unable to create '..//'

Critical Error: COPY ERROR: could not move file [./mods/board_msg_xl/board_message_xl.php] to [..//]
...looks to me to be an error with the MOD itself. If you post the line from the MOD script where it tries to copy board_message_xl.php then I'll take a look ;)
FIND FAILED: In file [includes/usercp_register.php] could not find:

$location = $userdata['user_from'];

MOD script line #240
Most likely you have another MOD installed that has modified this line already. You might want to manually search for "$location = " (without the quotes) to see what the line now looks like. I'd be interested in knowing what MOD changed that line too.

-Nuttzy :cool:



I dont understand what you mean by "If you post the line from the MOD script where it tries to copy board_message_xl.php then I'll take a look ;)" .........

and about the country flags mod...i have no clue what mod could have changed that, i dont have any mods installed.......but WAIT....when i upgraded to 2.0.4 it didnt update the files....so im converting to phpbb2.0.4 so i'll post back in a minute....
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions » Sun May 25, 2003 8:53 pm

ok, im getting copy to errors......

i've went back and changed the install.txt file for the board message i still get an error .....

Code: Select all

Warning: Unable to create '../board_message_xl.php': Permission denied in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1708


General Error 
Critical Error: COPY ERROR: could not move file [./mods/board_msg_xl/board_message_xl.php] to [../board_message_xl.php]
ATTEMPING REMAINDER OF POST PROCESS
that's the LAST step to installing the mod....and it gave me this :cry:
i was excited it got threw the rest of the installation....untill it reached that point....then i was like OH NO :cry: !!!
so im hoping you can guide me on how to change that.....

and also, what should my settings be?
Reading -
Writting -
Moving -
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

Super Saiyan Gecko
Registered User
Posts: 77
Joined: Wed Mar 12, 2003 9:20 am
Location: Planet Vegeta
Contact:

Post by Super Saiyan Gecko » Sun May 25, 2003 9:04 pm

Excuse me for cursing but... FOOOOOOOOOOOOOOOOOOOOOOOOOOOOKKKKKKKKKKKKKKKK.............
Damnit, I don't understand any code and I'm not willing to learn it either.... So what tha hell do I do now?
I need a lot of MODs I found, and I don't even know how to install them....

:cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
Signature edited for violation of Forum Rules

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sun May 25, 2003 9:10 pm

Nuttzy, I just realized something... The e-mail addresses don't parse on Steps 1 & 3 when looking at the MOD stats, and aside from EasyMOD itself, the MOD History's Author column doesn't parse correctly (it links to the name instead of the website).

Questions
Registered User
Posts: 705
Joined: Mon Sep 30, 2002 11:06 pm
Location: Cyberspace Learning: PHP & MySQL
Contact:

Post by Questions » Sun May 25, 2003 9:25 pm

haha....it works for me now.....

Nuttzy.......


one HELL OF AH JOB MAN..........
you are a god.......
I will Install MODs to your forum, or install a fresh phpBB 2.0.10 to your host for reasonable prices.
Contact me via AIM @: Gam LDub


(Please note: I use paypal as my money transaction, so before you contact me to do any work to your site, make sure you have one. Thank you.)

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sun May 25, 2003 9:33 pm

Woo hoo! I installed this on my online server and it worked right the first time. I saw no error message whatsoever, except for when it was installing the Flags MOD, I got the same error as before, but I knew why and I just edited the Install file. The only other problem was the one that you said it would have: processing the COPY with * in it. Thanks a lot for this, it's great!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 9:37 pm

@Questions: glad to see you got it working ;)
GPHemsley wrote: Nuttzy, I just realized something... The e-mail addresses don't parse on Steps 1 & 3 when looking at the MOD stats, and aside from EasyMOD itself, the MOD History's Author column doesn't parse correctly (it links to the name instead of the website).
On a correctly formatted MOD it does ;) Glad to hear it works on your server :D

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 9:42 pm

Super Saiyan Gecko wrote: Excuse me for cursing but...
First of all I have a very little tolerance for posts like this. Whining posts where someone says he is unwilling to do something makes me not want to help them.

But I'll try. I'm not asking for you to perform brain surgery here. I'm telling you to edit the online_offline_1_2_0.mod file, search for outputs graphically a user's online status and remove the single quote (') from user's. If you can't handle that, then I cannot help you.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Kazer0
Registered User
Posts: 876
Joined: Sun Nov 10, 2002 2:05 am
Location: {postrow.POSTER_FROM}
Contact:

Post by Kazer0 » Sun May 25, 2003 9:56 pm

Nuttzy99 wrote:
Kazer0 wrote:
read access :: OK
write access :: OK
root path write :: failed
chmod access :: OK
unlink access :: OK
mkdir access :: OK
tmp path write :: failed
FTP extension :: OK
copy access :: OK
Judging from this, write=server and move=FTP should work fully automated for you. The script should work also. You don't need to chmod -R 777 everything... just everything from the "mods" folder down.
Reading Server
Writing On Screen
Moving Copy
If you write on screen then you MUST manually move. Copy doesn't work by magic, the files have to already be on the server ;)

And those fclose and chmod warnings have been discussed and you can ignore them.
I tried it all now. I keep getting that error in the ACP.
BTW, Is it supposed to say
MOD ainstall

in the acp?
Sounds like through all the problems you had that lang_easymod.php never got moved into language/lang_english directory.

-Nuttzy :cool:


Nope. Write: server doesnt work because of php safe mode.
Andrew Charron || alexis support forum || Specializing in phpBB website template integration
Hurry up, my feash is siek.
AndrewCharron.com version 5 released!

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sun May 25, 2003 10:00 pm

Nuttzy99 wrote: On a correctly formatted MOD it does ;)


This parses correctly (on MOD History):

Code: Select all

## Mod Author:   Nuttzy99 < pktoolkit@blizzhackers.com > (Nuttzy) http://www.blizzhackers.com
But this doesn't:

Code: Select all

## MOD Author: GPHemsley < GPHemsley@aol.com > (Gordon P. Hemsley) http://lttp.iwebland.com/

Locked

Return to “[2.0.x] MOD Writers Discussion”