Page 3 of 25

Posted: Sun May 25, 2003 4:12 am
by smithy_dll
GPHemsley wrote: It's not updated for the new template....


the changes weren't that great, i'll update to the new disclaimers etc... some time soon

Posted: Sun May 25, 2003 4:14 am
by GPHemsley
Davidls wrote:
GPHemsley wrote: It's not updated for the new template....


the changes weren't that great, i'll update to the new disclaimers etc... some time soon

OK, this is getting a little off-topic, but the changes are great enough to give a Fail for a MOD that really Passes.... (and vice-versa)

Posted: Sun May 25, 2003 4:18 am
by Nuttzy99
Questions wrote: i installed it......
Cool, so I'm ignoring your first post then ;)
Warning: mkdir() failed (Permission denied) in /home/sicclyri/public_html/demo/admin/admin_easymod_functions.php on line 1403

Could not open [includes/functions.php.txt] for writing.
What do you have set for the write method? I'm guessing "sever". If that is the case then it appears that you need to chmod -R 7777 the directory of the new MOD you are trying to install. You'll probably need to do that for each MOD you try to install.

-Nuttzy :cool:

Posted: Sun May 25, 2003 4:19 am
by Nuttzy99
Pit wrote: As for programs having uppercase characters in the default directory name..hmm, I can't think of any, can you? ;)
Uh... yeah, that was kinda of dumb of me :P

-Nuttzy :cool:

Posted: Sun May 25, 2003 4:26 am
by LLivingLarge
Why won't anyone tell me why CHMOD is not being verified. I am still getting parser errors as well.

Posted: Sun May 25, 2003 4:32 am
by Rism
dont ignore the first post that Questions wrote, some of us (me) are having the same problem. :oops:

Posted: Sun May 25, 2003 4:45 am
by Nuttzy99
FYI, I'm responding to posts in the order they came. Rism, I doubt you are having the "same" error. You need to post EXACTLY what problem you are having.

-Nuttzy :cool:

Posted: Sun May 25, 2003 4:50 am
by Nuttzy99
LLivingLarge wrote: Which files do I CHMOD?
This is not helpful. I need to know more information. Is this from running the installer or did you get it installed? What are you using for write and copy settings? No one said you had to chmod anything, so why are you asking this question? Is it b/c a chmod error is appearing on screen? Is so, you need to post ALL errors you are getting.

-Nuttzy :cool:

Posted: Sun May 25, 2003 4:51 am
by Josh Windu
any ideas for my problems nuttzy?

Posted: Sun May 25, 2003 4:59 am
by Rism
ok when i go to the installer i get
Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation.


but when i go to easymod in my acp i get
Warning: main() [function.main]: SAFE MODE Restriction in effect. The script whose uid is 99 is not allowed to access ../extension.inc owned by uid 540 in /home/yury/public_html/forum/admin/admin_easymod.php on line 83

Warning: main(../extension.inc) [function.main]: failed to create stream: Inappropriate ioctl for device in /home/yury/public_html/forum/admin/admin_easymod.php on line 83

Fatal error: main() [function.main]: Failed opening required '../extension.inc' (include_path='.:/home/yury/public_html:/usr/local/lib/php') in /home/yury/public_html/forum/admin/admin_easymod.php on line 83


what do i do? :oops:

Posted: Sun May 25, 2003 5:06 am
by Nuttzy99
Ptirhiik - RPGnet-fr wrote: issues on finding lines
This I'll have to see for myself. What MOD is giving a problem?
Categories hierarchy, on index.php. Is the trim() performed on searched and readed lines ?
It is performed on the needle (searched), not the haystack (read). I'll check it out.
upload process
Actualy this will be an "add" button on the "Unprocessed MODs" screen, in order to upload a mod dir to the admin/mod dir. Also a remove button could be of some use ;).
Ohhhhh... I get it, I thought you were point out a problem. I'll take the suggestion into consideration ;)
loose of tabulation on the display step 1 of 3 of mod installation
All indentation tabs (#15) are removed from the code. This could be rather confusing when you have to check on an error ie.
Hrmmmm... yeah... I didn't think it was a big deal but you are right. I can use <PRE> and that should keep the tabs. - to do: use PRE on process screen
all the FIND/PROCESS doesn't seem to be performed in a file when an error has been encountered
what files are giving you the issue?
index.php, categories hierarchy mod, on the display of the first pass.
I'll check it out.
I keep by my side further request, as mentioning in the header of each phpBB file the date of modding and the name/version of the mod, building also a changelog list, those kind of thing that will be more for the beta stage ;).
Header info is a good idea, I'll consider it. From what you've said before, I think by "changelog" you are suggesting that I keep a commented out line of the original line before it was modified. This is not a good idea because you are adding extra info to the file that is very likely to screw up FINDs on future MOD installs. I could skip lines starting with // but I don't like the idea. On the other hand, it could be necessary depending on how I implement the uninstaller. Like you said, we'll see when the beta comes out ;)

-Nuttzy :cool:

Posted: Sun May 25, 2003 5:14 am
by Nuttzy99
GPHemsley wrote:
Nuttzy99 wrote:
Constant IN_PHPBB already defined [...] on line 24
Sounds like you have a previous version of EM installed and still have the entry in consants.php. Is that right?

The only version I have ever installed was this one... Of course I did it 3 times, so....
Actually I looked and this a legit thing I should fix - to do: move define('IN_PHPBB', 1); in em_functs down few lines

-Nuttzy :cool:

easy question

Posted: Sun May 25, 2003 5:14 am
by netzr0
Nuttzy,
I installed it and it all installed fine.
I really don't like doing a chmod 777, so just did a
chmod a+w on the directories (is there a reason you check the stat of a file and not the directory?)

The question i have is, i want to test this out with other mods.
Do i just unzip them in the admin/mods directory? and then go to the APC "Install MODs " ???

--netzr0

Posted: Sun May 25, 2003 5:16 am
by Nuttzy99
Davidls wrote: Technically it should install anything that passes the MOD Template specs.
A parser that validates MOD Templates can be found here: http://smigit.www2.dotnetplayground.com/validator.aspx
Excellent tool!!
I'm gonna test this as soon as I can nuttzy 8)
Thanks ;)

-Nuttzy :cool:

Posted: Sun May 25, 2003 5:22 am
by AbelaJohnB
GPHemsley wrote: OK, this is getting a little off-topic, but the changes are great enough to give a Fail for a MOD that really Passes.... (and vice-versa)



If you mean the phpBB MOD Validators, that is simply not true GPHemsley. Davids app probably does though ;)

http://www.phpbb.com/phpBB/viewtopic.ph ... 200#587200


@Nuttzy, awesome, awesome, awesome job man!!!