EasyMOD alpha3 v0.0.8 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
Josh Windu
Registered User
Posts: 377
Joined: Sun Jul 14, 2002 3:14 am
Location: Australia
Contact:

Post by Josh Windu » Sun May 25, 2003 6:38 am

ok i tried installing it with
Reading: server - (only option for now)
Writing: download - server is recommended
Moving: manually load - automated FTP is recommended


so i could then try changing it when it finnished.

When I got to step 4 down the bottom i got

Code: Select all

Warning: fclose(): supplied argument is not a valid stream resource in /home/decoder/public_html/cacfe/admin/mods/EasyMOD/admin_easymod_functions.php on line 1576

Warning: fclose(): supplied argument is not a valid stream resource in /home/decoder/public_html/cacfe/admin/mods/EasyMOD/admin_easymod_functions.php on line 1576
this was just above the:

Post-Process Complete. EasyMOD is installed!
Nitrotech - Alpha stage... Your own fully customisable forum! and site!

LLivingLarge
Registered User
Posts: 37
Joined: Mon May 19, 2003 3:20 am

Post by LLivingLarge » Sun May 25, 2003 6:39 am

Here are my stats at Step 1.

(I have an FTP server)

read access :: OK
write access :: OK
root path write :: OK
chmod access :: failed
unlink access :: OK
mkdir access :: OK
tmp path write :: failed
FTP extension :: module not loaded
copy access :: OK

After Step 2 when I get to step Step 3

Critical Error

Could not open [language/lang_english/lang_admin.php.txt] for writing.

Current working directory: /data/members/free/tripod/uk/n/g/a/nganimeclub/htdocs/phpBB/admin/mods/EasyMOD

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sun May 25, 2003 8:13 am

Which mods can be installed with EasyMOD?

User avatar
smithy_dll
Former Team Member
Posts: 7630
Joined: Tue Jan 08, 2002 6:27 am
Location: Australia
Name: Lachlan Smith
Contact:

Post by smithy_dll » Sun May 25, 2003 8:52 am

Technically any MOD that has made it into the phpBB MOD Database
or has a template that validates using the validator, will be EMC.

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sun May 25, 2003 10:11 am

i get this error when trying to install the flags mod

Code: Select all

 
Critical Error

FIND FAILED: In file [viewtopic.php] could not find:

u.user_posts, u.user_from, 

MOD script line #389 
what can i do to fix it? :?

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sun May 25, 2003 10:27 am

Sorry for double posting but
how can i install other mods with it?
i got bbcode_blur_1-2-0 so how do i install it with EasyMOD?

User avatar
morpheus2matrix
Former Team Member
Posts: 9171
Joined: Wed Apr 10, 2002 7:31 pm
Location: France
Contact:

Post by morpheus2matrix » Sun May 25, 2003 12:32 pm

Very Good job Nuttzy :wink:
Former phpBB MOD-Team Member -

Forgive my bad English :(

No support by PM/Email - Thanks - You can thanks me here :) - Pay me for installing MOD's :lol:

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 12:52 pm

Rism wrote: in step 3 i get this error

Code: Select all

Parsing: language/lang_english/lang_admin.php

Warning: file_exists() [function.file-exists]: SAFE MODE Restriction in effect. The script whose uid is 540 is not allowed to access /home/yury/public_html/forum/admin/mods/EasyMOD/processed owned by uid 99
[/quote]  Sounds like you have remnants of previous installs hanging around still.  In the EasyMOD folder, see if there is a "processed" and/or a "backups" folder.  If so delete them.  Then you should be able install.

[b]to do: when the install fails, besides the error message I should also post the scan info, the cwd, the selected settings, and a directory listing of the EasyMOD dir; then peeps can post this info easily.[/b]

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 1:04 pm

Josh Windu wrote:

Code: Select all

read access       :: OK
write access      :: OK
root path write   :: failed
chmod access      :: OK
unlink access     :: OK
mkdir access      :: OK
tmp path write    :: OK
FTP extension     :: OK
copy access       :: OK
The chmod access, write access and unlink access are only OK because I chmodded the admin and mods and easymod.

I am trying to install on

Reading: server (only option for now)
Writing: tmp write & ftp server is recommended
Moving: automated FTP automated FTP is recommended


I know you've since changed to download+manual but I'm still interested as to why your FTP failed. BTW the errors you got from download+manual have been discussed and can be ignored. When you tried FTP, the second step of the installer tests this connection. Did it succeed?

Also, since you did the chmod (only really necessary on EM, CF, and whatver other mod folders you upload) I would recommend that you use write=server and move=script if you have shell access. But still the best thing would be to get FTP working, so I'm willing to figure it out if you are ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 1:11 pm

LLivingLarge wrote:

Code: Select all

read access       :: OK
write access      :: OK
root path write   :: OK
chmod access      :: failed
unlink access     :: OK
mkdir access      :: OK
tmp path write    :: failed
FTP extension     :: module not loaded
copy access       :: OK
Could not open [language/lang_english/lang_admin.php.txt] for writing.

Current working directory: /data/members/free/tripod/uk/n/g/a/nganimeclub/htdocs/phpBB/admin/mods/EasyMOD


Strange! You can write, mkdir, and unlink but you cannot chmod!?!?! Makes no sense to me. Doesn't sound like a Safe Mode thing. I also need to know what you are using for write and move settings. I recommend write=server and move=ftp. Just remember that if you are writing on the server that you'll need to chmod -R 777 any directory of a MOD you are trying to install (like EM and CF).

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 1:23 pm

BTW Jesse, EM will try to install any MOD. If the MOD author has made the MOD inconsistent with the MOD Template then it will likely fail.
Jesse_tyler wrote: i get this error when trying to install the flags mod

Code: Select all

 
Critical Error

FIND FAILED: In file [viewtopic.php] could not find:

u.user_posts, u.user_from, 

MOD script line #389 
what can i do to fix it? :?
Hrmmmm.... you must have some other MOD installed that is interferring. If you look at line #389 of the CF MOD script then you will see it says:

Code: Select all

#
#-----[ FIND ]------------------------------------------ 
#
# from the sql statement starting as: $sql = "SELECT u.username
#
u.user_posts, u.user_from,
...I suggest that in your viewtopic.php that you find the line containing u.user_from that startes with SELECT u.username. Another MOD probably inserted some text between "u.user_posts, " and "u.user_from,". Just move the offending text before or after these and you should be set.

That's what you must do when a FIND fails ;)

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

LLivingLarge
Registered User
Posts: 37
Joined: Mon May 19, 2003 3:20 am

Post by LLivingLarge » Sun May 25, 2003 1:23 pm

I use SmartFTP and Lycos' WebFTP in tandem. SmartFTP to upload and WebFTP to edit files.

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 1:27 pm

Jesse_tyler wrote: Sorry for double posting but
how can i install other mods with it?
i got bbcode_blur_1-2-0 so how do i install it with EasyMOD?

Nuttzy99 wrote:
netzr0 wrote:The question i have is, i want to test this out with other mods.
Do i just unzip them in the admin/mods directory? and then go to the APC "Install MODs " ???
Exactly right :D
Actually to clear this up a bit, each MOD needs it own folder in admin/mods and the MOD script file must appear in the directory. So for the scroll MOD you would make something like admin/mods/scroll and place the MOD script in the scroll directory.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 1:29 pm

morpheus2matrix wrote: Very Good job Nuttzy :wink:
Thanks M2M ;) Eventually you'll probably end up providing more support for it than I do, Mr. phpBB Guru :lol:

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sun May 25, 2003 1:35 pm

@LLivingLarge
Nuttzy99 wrote: I also need to know what you are using for write and move settings. I recommend write=server and move=ftp.
When you configure EM, what are you using for write and move?

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Locked

Return to “[2.0.x] MOD Writers Discussion”