EasyMOD alpha3 v0.0.9 released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Locked
LLivingLarge
Registered User
Posts: 37
Joined: Mon May 19, 2003 3:20 am

Post by LLivingLarge » Sat Jun 07, 2003 3:07 am

DEBUG Server Write
check server write tests
write access :: OK
chmod access :: failed
unlink access :: OK
mkdir access :: OK
----------------------------



get cwd listing


----------------------------



make the processed dir
successfully made:



----------------------------



make the processed/language dir
successfully made:



----------------------------



make the processed/language/lang_english dir
successfully made:



----------------------------



trying to write lang_easymod.php.txt
successfully wrote lang_easymod.php.txt!



----------------------------



trying to chmod lang_easymod.php.txt
failed to chhmod lang_easymod.php.txt; continuing anyway


----------------------------



trying to delete lang_easymod.php.txt
successfull chmod'd lang_easymod.php.txt!



----------------------------


Expanded Debug Info
(formatted for forum posting)
EM installer v0.0.9 wrote: phpBB version: 2.0.4
Working Dir: /data/members/free/tripod/uk/n/g/a/nganimeclub/htdocs/phpBB2/admin/mods/EasyMOD
Install Step: 1
Mode:
The Error wrote: No error.


Permissions: (including system errors)
read access :: OK
write access :: OK
root path write :: OK
chmod access :: failed
unlink access :: OK
mkdir access :: OK
tmp path write :: failed
FTP extension :: module not loaded
copy access :: OK



Recommendations:
write: server
move: copy

Selected settings:
write:
move:
ftp dir:

CWD Listing:

Code: Select all

drwxrwsr−x . 
drwxrwsr−x .. 
−rw−rw−r−− easymod_install.php 
−rw−rw−r−− admin_easymod_functions.php 
−rw−rw−r−− em_debug_wri.php 
drwxr−sr−x processed 
−rw−rw−r−− easymod.gif 
drwxrwsr−x includes 
−rw−rw−r−− lang_easymod.php 

Not testing FTP since it is not being used.


Nuttzy, before you release 0.0.9b... Release 0.0.9a with the debug.
Official Guinea Pig of Nuttzy99...

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jun 07, 2003 5:17 am

Ptirhiik - RPGnet-fr wrote: As I understood, EMC doesn't mean : installable with easyMOD, but is rather preferences about mod instructions and the way to write them, that comes over the official mod template. But according to what Nuttzy said, it has to be well defined before mentioning on any mod "EMC".
Yes, EMC means it is optimized for EM and has the best chance of installing even if you have many other MODs installed. If you have a virgin board, then EM should be able to install any MOD in the MODs DB right now. However, other MODs might not install b/c of the way the first MOD was written. EMC MODs will optimized to give the best chance of getting many MODs to install even if they are modifying the same lines of code.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Sat Jun 07, 2003 5:21 am

Nuttzy99 wrote: Yes, EMC means it is optimized for EM and has the best chance of installing even if you have many other MODs installed. If you have a virgin board, then EM should be able to install any MOD in the MODs DB right now. However, other MODs might not install b/c of the way the first MOD was written. EMC MODs will optimized to give the best chance of getting many MODs to install even if they are modifying the same lines of code.

-Nuttzy :cool:

Oh yeah, I forgot about that.... Now that you mention it, I remember what the old guidelines said.... But still... I try to write my MODs as simple, straightforward, and consistant as possible.... Not that that has any bearing on any of the other MODs. ;) :roll:

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jun 07, 2003 5:23 am

LLivingLarge wrote: successfully wrote lang_easymod.php.txt!
What the heck? It worked and yet nothing is theoretically different from what EM is trying to do. One glitch is that a directory listing was supposed to print and did not. What kind of server are you running on: unix, windows, Mac, or don't know? Let me know so I can have you try something else so I can get that directory listing. From the crude one that does print in the standard debug info, I can see that the processed directory was actually created. That's a good sign that this is a fixable problem, whatever it is!

I'm going to PM Kazer0 and StarCast to get them testing too.

Thanks,
-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sat Jun 07, 2003 10:52 am

Well i get this when installing on my new host:

Code: Select all

read access       :: OK
write access      :: failed
root path write   :: failed
chmod access      :: unattempted
unlink access     :: unattempted
mkdir access      :: unattempted
tmp path write    :: OK
FTP extension     :: OK
copy access       :: failed
anything to fix this?
i have FTP access and my host is http://www.freehu.com/

StarCast
Registered User
Posts: 2
Joined: Thu Jun 05, 2003 1:47 am

Post by StarCast » Sat Jun 07, 2003 2:31 pm

DEBUG Server Write
check server write tests
write access :: OK
chmod access :: OK
unlink access :: OK
mkdir access :: OK
----------------------------



get cwd listing


----------------------------



make the processed dir
successfully made:



----------------------------



make the processed/language dir

Warning: SAFE MODE Restriction in effect. The script whose uid is 691 is not allowed to access processed owned by uid 48 in /home/virtual/site6/fst/var/www/html/sd.munl3y.com/forum/admin/mods/EasyMOD/em_debug_wri.php on line 884
failed to make processed/language dir!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jun 07, 2003 2:33 pm

Jesse_tyler wrote: anything to fix this?
i have FTP access and my host is http://www.freehu.com/
You have /tmp write access so you are all set. Just use /tmp and ftp for write and ftp for move. I'm sure this is what EM recommends, correct?

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sat Jun 07, 2003 2:35 pm

Nuttzy99 wrote:
Jesse_tyler wrote:anything to fix this?
i have FTP access and my host is http://www.freehu.com/
You have /tmp write access so you are all set. Just use /tmp and ftp for write and ftp for move. I'm sure this is what EM recommends, correct?

-Nuttzy :cool:


-.-

Code: Select all

Testing selected write method
Testing FTP access...
1) Logged in successfully
FTP ERROR: could not cd to http://www4.freehu.com/4/Jesse_Ty/phpBB2/admin/mods/EasyMOD

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jun 07, 2003 2:38 pm

StarCast wrote: Warning: SAFE MODE Restriction in effect. The script whose uid is 691 is not allowed to access processed owned by uid 48 in /home/virtual/site6/fst/var/www/html/sd.munl3y.com/forum/admin/mods/EasyMOD/em_debug_wri.php on line 884
failed to make processed/language dir!
What the heck!?!?! So it let's you make the processed dir, but not the processed/language dir? What the heck is that all about?? I need to get those directory listings working. If you are familiar with unix, is there some reason why "ls -l" won't work on your system? Kazer0 has the same thing. Also, do you know if you had the "processed" directory before the program ran, or did em_debug_wri.php create it? Makes no sense to me. I will generate another debug script for you to run that will have at least basic directory listing output.

Thank you!
-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sat Jun 07, 2003 3:07 pm

It Doesn't seem to want to work :cry:

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jun 07, 2003 3:15 pm

Well this is just all wrong. You have filled in the wrong value for phpBB2 dir. It is not supposed to be a web address. It is supposed to the the location of the phpBB2 directory from where your FTP connection starts. So I am guessing that when you connect via FTP to the server, you start in the Jesse_Ty directory. Therefore the correct entry would simply be "phpBB2" (without quotes).

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sat Jun 07, 2003 3:20 pm

Well

Code: Select all

Testing FTP access...
1) Logged in successfully
FTP ERROR: could not cd to server4.freehu.com/phpBB2/admin/mods/EasyMOD
oop! i was trying 0.0.8 because 0.0.9 didn't work so i'm going to try 0.0.9 again :P

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jun 07, 2003 3:33 pm

Jesse_tyler wrote: server4.freehu.com/phpBB2/admin/mods/EasyMOD
Ok do try again, and I hope you realize this is also completely wrong. Do not put a domain in front! Just the directory name(s).

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sat Jun 07, 2003 3:36 pm

Well....
I installed 0.0.9 before with different options now i can't go in the admin panel for some weird reason :( is there any way to uninstall EasyMOD?

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Sat Jun 07, 2003 3:44 pm

Forget that...HAHAHAAH! i had to change the version number to 0.1.0 to be able to install it! :lol: :lol: :lol: and the FTP works :D thanks :D

EDIT! Nooooooo!!!!!

Code: Select all

FTP ERROR: could not write tmp file [/tmp/cfgviMkbR] to [/home/server3/public_html/4/Jesse_Ty/phpBB2/admin/mods/EasyMOD/./processed/language/lang_english/lang_admin.php.txt]
[/code]

Locked

Return to “[2.0.x] MOD Writers Discussion”