EasyMOD alpha3 v0.0.9c released

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Aexoden
Registered User
Posts: 364
Joined: Mon Jan 14, 2002 1:18 am
Location: Medical Lake, WA
Name: Jason Lynch
Contact:

Post by Aexoden » Fri Jul 04, 2003 5:55 pm

Ptirhiik - RPGnet-fr wrote:
Aexoden wrote:I'm having a problem running it on my web hosting, related to FTP access. It seems that my FTP server doesn't permit certain combinations of directory changes.
Try a CDW "./admin/mods/../../" : it should prevent the system to detect you're going from a point to the same point. Note it's just a guess ;).

It doesn't seem to be about going from a point to the same point. It's just an unfortunately coincidence that my example chose that. For instance, starting from public_html/easymod, my phpbb root for the easymod test installation, it attempts to go to admin/mods/EasyMOD/../../../language/lang_english, which is where the problem crops up. Server doesn't seem to like having ".." as a directory anywhere but first (any number of them). Now to see if this is a common configuration or whether my host just has an odd FTP setup. This version of EasyMOD blows the older ones I tested away. It's getting to where I see a future without manual MOD installs. ;)

User avatar
blueadmin
Registered User
Posts: 124
Joined: Wed May 14, 2003 4:58 pm
Location: Bradford, UK

Post by blueadmin » Fri Jul 04, 2003 6:09 pm

i don't know, but would it be at all possible to use sessions in the easymod control panel as i find it annoying having to log into each bit. :?:
Ho Ho Ho merry christmas
You Stuck? Read this before askinghere and here

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Fri Jul 04, 2003 6:13 pm

Edit!:

Code: Select all

Testing selected write method
Testing FTP access...
1) Logged in successfully
2) CD to EasyMOD path successfully
3) wrote to phpBB root successfully
Write access method confirmed!
The modified files will be written to a buffer and then FTP'd into place.

Testing selected move method
Testing FTP access...
1) Logged in successfully
2) CD to EasyMOD path successfully
3) wrote to phpBB root successfully
Move access method confirmed!
The core phpBB files will automatically be replaced by modified files via FTP.
:P

Jesse_tyler
Registered User
Posts: 103
Joined: Wed Apr 02, 2003 9:00 pm
Location: Idaho
Contact:

Post by Jesse_tyler » Fri Jul 04, 2003 6:18 pm

Sorry for double posting but..

Code: Select all

Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../language/lang_english]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../language/lang_english]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/admin]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/images]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
Critical Error: FTP ERROR: could not change directory to [admin/mods/EasyMOD/../../../templates/subSilver/images]
Current dir: [/phpBB2]
ATTEMPING REMAINDER OF POST PROCESS
:?

i think it would be better if it tryed for a full path not ../../../ :?:

User avatar
SarcNBit
Registered User
Posts: 162
Joined: Tue Jun 17, 2003 3:42 pm
Location: Ohio, USA

Post by SarcNBit » Fri Jul 04, 2003 6:35 pm

Nuttzy99 wrote: Known 0.0.9c Issues:
  • lots of things like (file path issues) are sloppy and held together with bandaides - I think it all works though :roll:


This may be covered by the above statement, but just so you know on the installation confirmed screen, the link to the admin panel (which points to the forum index) in the lines that read:

Code: Select all

Installation Confirmed. EasyMOD is installed!

You can now proceed to the Administration Panel and select "Install MODs" under "MOD Center". You may install the included MODs if you desire.
has a double / before the index.php (for example http://www.example.com/phpbb2//index.php )

Is that nitpicking or what :lol: The installation went great :!:

Where does the program look for other MODs to install? I would like to test it with the mycalendar+ MOD but am unsure where to put the folder. Putting it alongside the CF MOD folder didn't seem to work.

User avatar
blueadmin
Registered User
Posts: 124
Joined: Wed May 14, 2003 4:58 pm
Location: Bradford, UK

Post by blueadmin » Fri Jul 04, 2003 6:38 pm

you have to put it in a new folder in the admin/mods directory (ie admin/mods/mymod) with the intall text file at the root of the new folder (ie admin/mods/mymod/install.txt).
Ho Ho Ho merry christmas
You Stuck? Read this before askinghere and here

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Fri Jul 04, 2003 7:52 pm

SarcNBit wrote: Where does the program look for other MODs to install? I would like to test it with the mycalendar+ MOD but am unsure where to put the folder. Putting it alongside the CF MOD folder didn't seem to work.

All MODs should go in the folder admin/mods/ (which is where you'll see the EasyMOD and Country Flags folders). Make sure the install file is directly inside the root of the admin/mods/MOD_NAME/ folder. If it is, then the heading is not correct. Make sure that it follows the MOD Template heading. Remember that EasyMOD needs a real name in order to list it on the Install MODs window. It does not need a website in order to detect it. This mean make sure that it has the following:

Code: Select all

## MOD Author: phpBB.com_username < e-mail address > (Real Name)

Josh Windu
Registered User
Posts: 377
Joined: Sun Jul 14, 2002 3:14 am
Location: Australia
Contact:

Post by Josh Windu » Sat Jul 05, 2003 1:44 am

Nuttzy99 wrote: @JW: I need more info. Please post the entire error message, complete with all the debugging info. Or did you not get an error message? If not then tell my what files were not copied properly and what happened to them.

Thanks,
-Nuttzy :cool:


sorry nuttzy was 2 tired :P

I didnt get an error message while installing the flags mod. It didnt copy the flags ;)

I dont think anything happend to the files :?
Nitrotech - Alpha stage... Your own fully customisable forum! and site!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jul 05, 2003 2:40 am

Nuttzy99 wrote: 4) You may optionally install the Country Flags MOD (CF) which is included with the download. Do NOT install if you already have CF installed. NOTE: there is an issue with copying the flag images so you will probably need to manually move them into place.
So there is no unintended problem ;) That's a relief!

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Josh Windu
Registered User
Posts: 377
Joined: Sun Jul 14, 2002 3:14 am
Location: Australia
Contact:

Post by Josh Windu » Sat Jul 05, 2003 2:43 am

oh woops

sorry :?
Nitrotech - Alpha stage... Your own fully customisable forum! and site!

User avatar
Jaeboy
Registered User
Posts: 446
Joined: Fri Oct 18, 2002 4:42 pm
Location: HkG SAR
Contact:

Post by Jaeboy » Sat Jul 05, 2003 4:31 am

Tested, no problem! But still need chmod 777 to have full file access...
A personal blog :: My Blog | lalaland

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jul 05, 2003 8:39 am

Jesse_tyler wrote: Current dir: [/phpBB2]
This doesn't look right (but it might be). Run the 1st step of the installer. On the second step where it confirms FTP works and everything, click the debug info link on the bottom of the page and post the info here. Could be a second case of ../../ causing a problem which means I need to fix it sooner rather than later ;)

EDIT: you do have subSilver installed, right??? I assume you do, but I gotta ask the question ;) If you do, go ahead and report back that debug info. If you don't have subSilver, then you need to put it back.

-Nuttzy :cool:
Last edited by Nuttzy99 on Sat Jul 05, 2003 8:44 am, edited 2 times in total.
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jul 05, 2003 8:42 am

blueadmin wrote: i don't know, but would it be at all possible to use sessions in the easymod control panel as i find it annoying having to log into each bit. :?:
It does use sessions. Sounds like you have one of those damn cookie problems. Not much I can do for ya.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

Nuttzy99
Former Team Member
Posts: 4917
Joined: Fri Aug 03, 2001 7:09 am
Location: the 11th dimension
Contact:

Post by Nuttzy99 » Sat Jul 05, 2003 8:48 am

Jaeboy wrote: Tested, no problem! But still need chmod 777 to have full file access...
This is the wrong way to go about things. Do you FTP access? If so, use the FTP options so that you do not need to 777 everything and make yourself vulnerable.

-Nuttzy :cool:
SpellingCow.com - Free spell check service for your forums or any web form!
No Support via PM please!

User avatar
Jaeboy
Registered User
Posts: 446
Joined: Fri Oct 18, 2002 4:42 pm
Location: HkG SAR
Contact:

Post by Jaeboy » Sat Jul 05, 2003 9:25 am

Nuttzy99 wrote:
Jaeboy wrote:Tested, no problem! But still need chmod 777 to have full file access...
This is the wrong way to go about things. Do you FTP access? If so, use the FTP options so that you do not need to 777 everything and make yourself vulnerable.

-Nuttzy :cool:


Oh it's a test server on a free host :) Nevermind :lol:
A personal blog :: My Blog | lalaland

Locked

Return to “[2.0.x] MOD Writers Discussion”